locked
PP3 nstall did not provide latest copy of Connector software RRS feed

  • Question

  • Symptoms:

    When I attempt to use my WHS connector, I am told I need to upgrade my connector.  When I make such an attempt I get the dreaded "This operation cannot be completed at this time." message.

    While the Home Server Console still works on the server, backups have stopped working (existing backup are still there).  The last successful backup was done on Nov 28.  PP3 was installed on Nov 29.

    MY INVESTIGATIONS:

    1. PP3 reportedly installed correctly.  The resources screen of the Home Server Console, indicates I have pp3 installed and version 6.0.2423.0 of the Console, Backup & Restore, Drive Extender, Remote Access, and Storage Manager.

    2.  The "Date Modified" on all the Connector software in my "Software\Windows Home Server\Home Server Connector Software" is March 11, 2009 (or earlier).

    3.  I've been using WHS since Nov 2008 so it appears the connector software was updated at least once since initial installation.

    CORRECTIVE ACTIONS:

    1. Installed the Connector by using the WHSConnectorInstall.exe from my server.  The results is the same "... cannot be completed ..." message.

    2. Installed the Connection by using the "setup.exe" in the "Home Server Connector Software" folder on the server.  The result is: the existing connector is uninstalled (the icon disappears from the tray), the connector is successfully reinstalled, it tells me the software must be upgraded (it seems to think it completes the upgrade). However, the tray icon still says I need to upgrade and I'm back to where I started.

    3. I uninstalled PP3 and then reinstalled it.  Everything is still the same.

    4. I've tried the procedure in the Microsofts "Troubleshooting WHS Connector Installation" document. I have no name resolution problem.  The Firewall procedure is a bust because I get the proper responses to http://servername and http://servername:55000/enroll/id.xml however the https://servername:56000/enroll/id.xml works but it returns <ID>1<ID> instead of <ID>2<ID>.  The procedure only explains what to do if you get an error response (I don't) and doesn't explain what to do when you get the wrong response (I do).  Not surprisingly, the next step in the procedure returns the same (<ID>1<ID>) incorrect response.

    5.  I also saw one post that reported the new connector software being supplied in the Add-ins directory.  I looked, its not.

    MY CONCLUSIONS:

    1. I don't believe the results from step 4 are germain since that procedure is dealing with communications within an intranet. I can get the existing Connector software to install, its just the wrong version.  From what I've read (and I could be wrong here) the new Connector software should have been installed on the server as part of the PP3 installation process.

    2. It's possible, that given the really old last modified date on my exisitng software, maybe a previous update didn't update the connector and the PP3 update doesn't know how to deal with that.

    Sorry to bug everyone about this but the error messages I get aren't very descriptive and I can't find any similar problems in any searches.

    Anyway, thanks for whatever help you can give.

    Steve
    Wednesday, December 2, 2009 9:50 PM

Answers

  • Take a look at this FAQ and see if it helps.
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by smk8383 Wednesday, December 2, 2009 11:01 PM
    Wednesday, December 2, 2009 10:23 PM
    Moderator

All replies

  • Take a look at this FAQ and see if it helps.
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by smk8383 Wednesday, December 2, 2009 11:01 PM
    Wednesday, December 2, 2009 10:23 PM
    Moderator
  • Ken,

    I had looked at that post when I was doing my research.  Since you were so kind to respond, I checked again and this time noticed that the dates on the files referenced in your post were the correct version.  I copied them to the correct location, re-ran the install, and I'm back up!

    Thanks for your help!
    Steve
    Wednesday, December 2, 2009 11:04 PM
  • I'm glad it worked for you. :)

    Did you previously have Power Pack 3 (beta) installed? If so, could you give me the exact (and complete) steps you used to remove it? Send it to me by email if you like, my address is in my profile here. (You should remove the anti-spam device if you want me to actually see it. :) )


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, December 2, 2009 11:08 PM
    Moderator
  • No, I didn't have PP3 beta installed.  I removed (using the normal "Add/Remove Programs" item on the control panel) and reinstalled only the released version of PP3 (which is when I believe I got the updated connector files).
    Thursday, December 3, 2009 4:54 AM