locked
Problem with asmx RRS feed

  • Question

  • I have a asmx-webservice. When I try to access it by using the URL directly, I get an error "Requested Format Unrecognized" (I hope the translation is correct; I have a Dutch version). When I try to make a service reference, I get the following error: There was an error downloading 'http://bliep.hulppeldepup.nl/bliep.asmx/_vti_bin/ListData.svc/$metadata'.
    The request failed with HTTP status 405: Method Not Allowed.

    After some googling, I got to this page https://support.microsoft.com/en-us/kb/330221/nl that tells me that I have to adjust settingsin the firewall to remove unknown headers. Unfortunately it doesn't tell me how, and I can't find the answer anywhere.

    The strange thing is, that on the same site I have another asmx webservice that I access through AJAX, without problems. Now I want to do the same thing with a Windows Forms application, and problems arrise.

    How can I make my asmx webservice available for my program?
    Friday, May 29, 2015 2:14 PM

Answers

  • Hi Ellen,

    For AXMX related question, the WCF, ASMX and other Web Services forum should be the right place to get help, you need to redirect to there.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Just Karl Monday, June 1, 2015 7:30 PM
    • Marked as answer by Just Karl Wednesday, June 10, 2015 5:05 PM
    Monday, June 1, 2015 12:37 PM

All replies

  • Is it a asmx web service? based on the url you are using both asmx and .svc extention. which one you trying to use. 

    Also what is the authorization setting in the web.config for this web service?


    sivanitha

    Friday, May 29, 2015 2:55 PM
  • I've noticed that as well. It is a asmx webservice. I rightclick add Service Reference, Advanced, Add Web Reference, type the link to the URL and get the result noted above.

    In the meantime, I've noticed that if I make a web application, instead of a website, that the webservice works.

    I can't figure this out.

    Monday, June 1, 2015 6:50 AM
  • Hi Ellen,

    For AXMX related question, the WCF, ASMX and other Web Services forum should be the right place to get help, you need to redirect to there.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Just Karl Monday, June 1, 2015 7:30 PM
    • Marked as answer by Just Karl Wednesday, June 10, 2015 5:05 PM
    Monday, June 1, 2015 12:37 PM