locked
Router confing RRS feed

  • Question

  • I am useing a dlink 707 p.

    In

    Router Configeration Details i get a green tick for

     

    Verfiying your router supports UPnP

    Configureing your router

    Verifying your website in available on your home server

    Verifying REmote Access is available on your home server

     

    A red cross for the 3 remaining items

     

    Verifying your router is accepting website connections

    Veryifing your router is accepting remote access connections

    Veryifing your network configeration

     

    Is it a router configeration the the above 3 problams, if so anyone know how to configure?

     

     

    Thursday, August 30, 2007 10:17 PM

All replies

  • Hi,

    In this Topic you will find info and link to test your router issue.

    You can test to see if upnp actully working by testing this:

    https://yourdomainname.homeserver.com (if you using the homeserver domain)

    If not, simply forward these ports:

    443 TCP
    4125  TCP
    80 TCP (optional)

    In your router to your server ip, this Site can help, just chose your router model for the guide.

    My best.
    Thursday, August 30, 2007 10:41 PM
  • How is your network laid out? 

     

    Do you use DSL?

     

     

     

    Friday, August 31, 2007 10:36 PM
    Moderator
  • Well i am just about to give up on this dlink di707p router. Dlink are no help at all and the port forward site is not much better.

     

    I have a dsl connection to a dlink  dsl-502t moden which is connected to the di-707p router

     

    8 computers including the server connected to the router. It has been this way for 2 years with no problams.

     

    Is there a  whs router compatability list available.

     

    I realy need this to work as my partner travels the world and would like access to our server

    Thank Joel

     

    Saturday, September 1, 2007 2:30 AM
  • The problem you are having is likely a result of using two routers, so switching to different router instead of your di707p isn't likely to help. Your DSL device is a combination modem/router, and you have your di707p (or replacement) connected to that. You can probably determine if your router and DSL device are both providing routing functions fairly easily. Go into your router's management interface (a URL like http://192.168.1.1, probably, though the exact IP address will vary) and see what it reports for a WAN ip address. It should report something like 211.31.xxx.yyy (the xxx and yyy will be specific to your connection). This is the external IP address that the Internet (and the forum software here) sees. If your router shows anything else, then you definitely have more than one router in your connection to the Internet.

    You have a few choices. The options below are listed in increasing complexity for the end user and assume that your router and your DSL device are both providing routing functions right now.

    First, you could replace your di707p with a switch. That's the easy fix. It lets your DSL device (which is a router itself) take over all routing functions. Get a good switch, from a name brand; you'll need an 8 port switch, I think. You might be able to borrow one from a friend to see if this takes care of the problem. I like this solution for your configuration. It's easy, not terribly expensive, and you can actually upgrade your network as a result (you can get a gigabit switch for as little as $50 US or so that would do all you need). You'll lose the print server built in to your router, though.

    You can ask your DSL supplier for a plain DSL modem without any router features at all. Explain to your provider that you are having trouble accessing the internet, that you have several computers at home hooked up to a router that's then connected to your DSL device, and that you want a DSL device that lets your router act as the gateway. They may want some money to replace your current DSL device. (They may even refuse to do so because they want to control your interface to their network.)

    Next, you can change the configuration on your DSL device so that it doesn't act as a router. I think you will need to turn off NAT (and maybe DHCP, but that could depend on NAT being active), but your DSL device isn't distributed in the US, so I can't give you specifics here. Contact DLink and tell them the same as above: you have a DSL modem/router and an additional router, and you want your DSL modem/router to just act as a modem so your router can act as the gateway.

    You can also configure your router to turn off NAT and DHCP. Your router is no longer available in the US, and you're not in the US anyway, so I'm not able to give you specifics. And you may not be able to do this; the manual I can find for the US version doesn't show any easy way to turn off NAT.
    Saturday, September 1, 2007 2:20 PM
    Moderator
  • I changed the moden to a siemens speedstream 4200 and run the tests again.

    Still got the same results.

    Seems this siemens modem is also a router.

    Saturday, September 1, 2007 11:43 PM
  • According to the information I can find, that modem also does NAT forwarding and can act as a DHCP server, so even though it only has one WAN and one LAN ethernet port, it's probably acting as a router in your environment. I really think that the simplest solution for you is to replace the DLink router with a gigabit Ethernet switch (or a 10/100 switch for a few dollars US less), instead of trying to get a DSL modem configured properly (assuming your modem even allows you to turn off the features causing your problems; not all do).
    Sunday, September 2, 2007 2:35 AM
    Moderator
  • There must be others useing a dsl modem and seperate router. I would like to know a brand and model no.

    I dont want to ditch the 707p just yet.

    I can get hold of a Linsky AM300 which is supposed to be a dedicated adsl modem with no routing features.

    Sunday, September 2, 2007 6:00 AM
  •  Anniets wrote:

    There must be others useing a dsl modem and seperate router. I would like to know a beand and model no.

    I dont want to ditch the 707p just yet.

    I can get hold of a Linsky AM300 which is supposed to be a dedicated adsl modem with no routing features.

     

     

    Anniets

     

    Read this thread it may help.

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1957191&SiteID=50
    Sunday, September 2, 2007 10:54 AM
  • I posted this info last night elswhere but this may be your issue...

     

    "

    In the FAQ area the question was asked about the ports to forward for remote access. What you also have to do on many routers is also to configure firewall rules separately. The forwarders tell the router where to send the traffic when it gets in but the firewall will block it anyway. On mine (a Zyxell) I set "allow" rules using predefined settings for HTTP and HTTPS but I had to manually define the RDP rule as one did not exist. "

     

    This assumes that your router is also configured to act as a firewall as well. It is not impossible to have one device as a firewall and another as a router separately but unlikely 

     

    Sunday, September 2, 2007 9:14 PM
  •  

    Good point about the firewall. The easy way to try that is to just turn it off.

     

    I fianlly got some usefull infor from dlink

     

    They had never heard of whs. So i told them all that was happening and  the responce was this.

     

    A dsl 502-t modem which acts as a router as well, can have the the router turned off by choosing the bridge mode option.

    Then go into the 707p router in WAN and change it to PPPoE

     

    Which i did .

     

    Still get then same result.

     

    I will try and turn off the firewall completly.

    Monday, September 3, 2007 6:00 AM
  • Good news , i have made progress.

     I get a green for all but this one

     

     

    2. Configuring your router -

     WHS is trying to update your router. If this fails, WHS has failed to configure your router automatically.

     [There is not much a user can do beyond this point, except submit TALQ report].

     

     

     

    Does this mean it is now ok?

    Saturday, September 8, 2007 2:22 AM
  • If you have manually configured the port forwarding in your router, then probably. Try it from a location not on your home network: http://[yourserverhere].homeserver.com and let us know. And if it works, let us know what the network topology and configuration issues were.
    Saturday, September 8, 2007 1:01 PM
    Moderator
  • I havnt tried to log on from outside as yet but with a big green tick beside router it may be ok. There is just the one red one as i said earlier. The problam was mis-information from both dlink and port forward site.

    Dlink sent detailed instructions but the window images they sent did not match the port forward window on the router nor did the instructions because of the difference in what i can see in my router to their images.

    Same with port forward site thier images differ to what i see on my router.

     

    The main difference was on the router window there is a private and a public port. On what dlink and portforward offered this doesnt exist.

    Which causes confusion.

    I could not get get dlink to listen. They were insistant that i was trying to get to the router from my internal network. I could not get it in their heads that i was trying fto log on the server from an outside computer.

    Dlink also said the 3 ports could be done at once. This is wrong. They had to be done individually.

    And they had to be done in the private port and public port options.

    I also found out that the router part of a dsl modem can be turned off by activating the bridge, but i didnt do that.

     

    That has probably confused everone.

     

     

    Saturday, September 8, 2007 8:40 PM
  • Check this thread if you haven't already.
    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1987083&SiteID=50

    Here's what I had to do in order to get WHS to work.

    1. Configure my Cisco 678 DSL modem/Router using the ports forward to xx.0.0.x 443 tcp and xx.0.0.x 4125 tcp

    2. On my Linksys router I needed to forward to the whs box with 192.168.1.104 443 tcp and 192.168.1.104 4125 tcp


    I don't know if this will work for your case.  I'm not sure this is the right way actually.  I just know that it works and have not had any problems with it.  If the above is not correct in some way please let me know.

    Regards
    John
    Saturday, September 8, 2007 9:56 PM
  •  

    I now have remote access.

    Thanks to all those whose input was so valuable.

     

    If anyone reads this and has a dlink 707prouter  i know exactly what to do. So please contact me or leave a post.

    Thank you all

    annie

    Monday, September 10, 2007 1:34 AM
  • Annie, given the amount of pain you've gone through, I'd suggest a "how to" post would be useful. Make sure to give the general setup you're starting with (what DSL modem, router, and ISP) and maybe include a link to this discussion thread. Then just give a step by step that takes the user through configuring everything.

    Oh, and I'm glad you've up and running now!
    Monday, September 10, 2007 3:33 AM
    Moderator