locked
Remote desktop is different session from physical access RRS feed

  • Question

  • Hey all. I have been using WHS since the beta phase, and there is one problem that has been bugging me.

    I access my server in 3 different ways. Using remote desktop from my XP machine, logmein, and physically sitting at the server (I know that's not how WHS is intended to be used).

    If I physically sit down at the machine and log in via Administrator (or any user that I have created and added to the Administrators group) and open programs, then connect through LogMeIn (.com) from another computer and log in to the same account, all of those same windows are open and I can see exactly what I saw when sitting at the computer. However if I go downstairs and use remote desktop and log in to that same account, it's an entirely different session. How can I stop this from happening? I would like to see the same thing when I use remote desktop.



    Thanks for any help.
    Sunday, June 14, 2009 12:52 AM

Answers

All replies

  • What you are referring to is accessing the remote desktop "console".  The console session is the same one you get from sitting down to the machine. 

    Here is a link to an article that talks about command line parameters when you start remote desktop:

    http://weblogs.asp.net/jeffwids/archive/2005/12/14/remote-desktop-to-console-session-on-windows-server-2003.aspx

    The default remote desktop GUI doesn't have a checkbox for console session, so I use another app called Royal TS, you can find the free version here:

    http://www.code4ward.net/main/RoyalTS/Overview.aspx

    In this case, there is a checkbox.

    Note that if someone ELSE is on the console session, and you log into the console session, you will force the other guy off.  There is only one console session.

    DDanster
    • Marked as answer by flipzmode Sunday, June 14, 2009 11:27 AM
    Sunday, June 14, 2009 5:14 AM
  • Thanks for the response, that's exactly what I needed!
    Sunday, June 14, 2009 11:28 AM
  • The default remote desktop GUI doesn't have a checkbox for console session...

    FYI: To run a 'console' terminal session, use /console: run->start->"mstsc /console" (optionally add a saved .rdp sessionparameter file}

    - Theo.
    No home server like Home Server
    Sunday, June 14, 2009 5:55 PM
    Moderator