none
Can't install RIS / newly added compute node remains in a state of Configuring. RRS feed

  • Question

  • Hi everybody

     

    My head node DEXTER is allready in production (we also use it for computing) and runs fine. Now I wnat to add some compute nodes and I run into problems.

     

    DEXTER is part of our domain "FDY"; The domain controller is a Suse Linux Enterprise Server with Samba; A DNS Server is provided by the University;

    DEXTER is running Windows Server 2003 Enterprise R2 (Evaluation), because we need the SUA, which isn't available in ComputeClusterServer;

     

     

    I've two deployment problems:

     

    1st) I can't install RIS

     

    I've configured the network topology as "Compute nodes isolated on private network";

     

    I run the RIS Setup wizard, click through everything, and finally I got this two error messages:

     

    * Service connection point (SCP) was not updated because there was an error communicating with the domain controller. Unknown error (0x80005000)

    * Service connection point (SCP) was not updated because the fully qualified domain name (FQDN) of the computer was null. This can occur when the computer is unable to contact the domain controller during discovery.

     

    Where does this FQDN comes from? From my Domain controller, from my DNS server, or do i have to set it on the local machine?

     

    2nd) I want to do manual deployment, but the newly added compute node remains in a state of Configuring

     

    I manually installed Windows Server 2003 R2 on a node, and added the node to domain FDY, then I connected it to the private LAN of DEXTER, and run the "Add Nodes" - wizzard.

     

    Everything works fine, but finally the new node never comes byond the "Configuring"-State.

    The problem is exactly like it is described in the help, but this doesn't helps much:

    • The Configuring node state is an initial transition state, usually brief, shown during Compute Cluster Pack Setup, Compute nodes should automatically move from the Configuring state to the Pending for Approval state. If the node remains for any length of time in the Configuring state, this is typically an indication of a problem in the configuration phase of setup.

    I also tried the "All Nodes on public LAN" - configuration (of course I re-wired the LAN), but the problem stays the same;

     

     

     

     

     

     

    • Moved by Josh Barnard Thursday, March 26, 2009 12:28 AM (Moved from Windows HPC Server Developers - General to Windows HPC Server Deployment, Management, and Administration)
    Friday, February 8, 2008 9:32 AM

Answers

  • Great set of questions.

     

    SCP

     

    A Service Connection Point (SCP) is an entry in Active Directory that identifies a particular kind of server and the address for that server. For example, using SCPs you could query Active Directory to find all the Exchange Servers in a particular domain. Compute Cluster Server creates an SCP for the head node, allowing users to query Active Directory for all clusters on a particular network.

     

    I suspect the problem we’re encountering is that RIS can’t create a SCP on your Linux domain controller. While we may fail gracefully here RIS does not. I suspect this is because RIS servers need to be authorized to start up, in a similar way that Windows DCHP servers on a network need to be authorized. In short, I think this is a bug where Linux doesn’t support SCPs and authorization and RIS can’t start without success with both.

     

    Manual Deployment

     

    Did you install Compute Cluster Pack on new compute node?

     

    If you have I suspect this may be a another domain controller problem. Does your Linux domain controller work with Active Directory, that is, could you add a Windows Active Directory server as a peer or child of the Linux domain controller?

    • Marked as answer by Josh Barnard Thursday, March 26, 2009 12:27 AM
    Friday, February 8, 2008 8:01 PM