locked
This is Weird - Can't Enable user for OCS RRS feed

  • Question

  •  

    I have went through the install with little to no problems (certs are another topic).  I did all the Domain/Schema Prep and have the green check mark saying that its all completed.  But for some reason I can't Enable OCS on any user in my AD.  I have tried this on server servers with no luck.  I have tried in on the computer running OCS and my domain server with the OCS admin tools installed.

     

    My OCS Server is running 2003 R2 64bit.

     

    Has anyone ever experienced this?

     

    Thanks,
    Chris

    Thursday, October 18, 2007 8:58 PM

All replies

  • Did you start dsa.msc (Active Directory Users and Computers) on your OCS server and right clicked a user and selected Enable user for Office Communication Server?

     

    Deli

     

    Thursday, October 18, 2007 9:41 PM
  •  

    Yes, I did this and don't get the option.  Is there a way to rerun the schema and AD prep?
    Friday, October 19, 2007 4:38 PM
  • Try running ADUC's from the actually OCS server.  I don't get the option when I try to enable them from an AD DC but I do if I run dsa.msc from the OCS server?  Wierd...

    Friday, October 19, 2007 6:19 PM
  • Since you are running OCS on x64 based server, you need to open AD Users and Computers in 32 bit mode.

     

    Start > run > "dsa.msc -32"

     

    I think this must work as you said all AD steps were GREEN

     

    Good Luck

    Anuj...

    Friday, October 19, 2007 8:15 PM
  • Okay this is VERY weird and would someone please explain what it works this way.

     

    My AD server runs 2003 R2 64bit

    My OCS server run 2003 R2 64

     

    But to enable my users for OCS I have to run the AD MMC in 32bit.  Why?

     

    Thanks for your help, its running like you mention "dsa.msc -32"

     

    Chris

    Friday, October 19, 2007 8:58 PM
  • OCS is a 32 bit app so as AD.

     

    when u install OCS on x64 based server, then OCS runs under WOW64 subsystem

     

    Its not recommended to install OCS on a x64 based server as it as certain supportability issues.

     

    And BTW, if my post has resolved the issue, would you mind clicking on YES please.

     

    Thanks

    Anuj...

     

    Friday, October 19, 2007 9:15 PM
  • You need to run this command for x64 bit windows server that is running ocs

    mmc /32 dsa.msc

     

    And by the way AD does run native on Windows x64

     

    Deli

     

    Saturday, October 20, 2007 12:32 AM
  •  

    Thanks everyone for the help.

     

    Lastly.  I am just now rolling this out to my users (very early stages).  Would I be better to start over and run the 32bit version of Server 2003 and OCS?  The only reason I went with the 64bit version of the OS was to have the OS take advantage of the extra memory my server has in it.

     

    Chris

    Monday, October 22, 2007 1:04 PM
  • I'm having the same problem. Everything is green. Just about all validations were a success, but I still can't enable users. I've tried running ADUC in 32bit mode, still nothing.
    Thursday, February 19, 2009 7:58 PM
  • make sure you install the admin tools that come with OCS
    this enables you to have the right click functionality to enable and disable ocs users etc
    Tuesday, March 17, 2009 1:32 AM
  • The key to being able to enable the users is to have BOTH the OCS Admin tools and the Active Directory tools collocated.  For example, if you install the OCS Admin tools on a workstation that already HAS the Active Directory tools (Users and Computers, Sites, etc.) this will accomplish the purpose of being able to integrate the two toolsets.  The easiest way to determine if everything is set up properly is to open ADUC, right click on a user and not if you have additional features that are not native to ADUC alone.

    You should be able to enable the user for OCS by right clicking or selecting a number of users, then right clicking.  Or, you can double-click on a user and be presented with more information about that user and not the added tabs for OCS management of the user.


    Tuesday, March 17, 2009 1:49 AM