locked
Help! WHS thinks D: drive is missing! RRS feed

  • Question

  • This morning I noticed the network health was critical, so I logon to the console to take a look. The console was indicating that one of my drives was missing. This drive is the DATA drive of my primary hard disk (D: drive). However, when I RDP into the machine, D: drive was there and I was able to access the files there with no problems. I ran chkdsk on d: drive and found no problems.

    I rebooted a few times and this didn't fix the problem. There was no option to 'Remove' or 'Repair' this 'missing' drive, I guess it's because it belonged to the primary drive?

    What other options can I try now (registry tweak? Settings changed?) besides having to reinstall WHS? Thanks.
    Wednesday, January 27, 2010 4:29 PM

Answers

  • Hi,
    sorry, bad news, I would say. Since drive D: is critical due to the tombstones stored there, it cannot be removed via console, amd it's missing will affect server functionality heavily. Is there anything in the event log, which could explain why the drive did drop from the storage pool?
    I had the same one time, in that case the file system had a shot. What ever I tried, no chance to repair it. I also had finally to perform a server reinstall, which I usually avoid as long as possible.
    You could try to perform this reinstall to a new system disk keeping the old drive on side, or on the same drive.
    If you do not get a server reinstall offered, you will have to go the hard way as described in the FAQ How to recover data after server failure.
    Best greetings from Germany
    Olaf

    • Marked as answer by JohnDoe111 Thursday, January 28, 2010 5:04 PM
    Wednesday, January 27, 2010 8:51 PM
    Moderator