locked
Dynamics 2011 Installation failure RRS feed

  • Question

  • Hi all,

    Hope everyone is fine. 

    I am doing single computer installation. SQL Server (SSRS) and CRM on the same machine. 

    Here is my setup:

    Domain controllers              : Windows 2008 Enterprise SP2 (Primary Controller), Windows 2003 (Secondary Controller)

    Functional Level                 : Windows Server 2003 forest function level (highest) 

    Machine                             : Windows 2008 Enterprise 64 bit, successfully joined to domain

    Installation  account            : Member of domain admin group, local administrators group and SQL sysadmin.

    Service Account                 : Member of local administrator group and SQL sysadmin. 

    After installation I receive an error and log says,

    14:24:20|  Error| Installer Complete: OrganizationCreator - Error encountered
    14:24:20|  Error| Exception occured during Microsoft.Crm.Tools.Admin.OrganizationCreator: Action Microsoft.Crm.Tools.Admin.ProvisionBusinessAction failed.
    InnerException:
    System.Runtime.InteropServices.COMException (0x8007202B): A referral was returned from the server.

    I do not know what is the actual failure here. I have done extensive research to narrow down this  as Active Directory and DNS issue. Following solutions on the web I have also flushed my DNS cache, disabled UAC and bla bla.... 

    But, no success at all.

    Please anyone can make me fix it. Thanks in advance.


    Thursday, April 12, 2012 9:25 PM

All replies

  • Hi Masab,

    Often this is caused by inconsistences on Domain Controllers and it can be for so many reasons. I had the same error in CRM 4.0, after days trying to solve, i figured out  there was a Client PC on a remote site with the same name that one of my DC's. If you already has tried all on the forums and still don't get results,  I suggest get support from Microsoft Dynamics Team on the partner o customer Source

    https://mbs.microsoft.com/customersource/

    https://mbs.microsoft.com/partnerource/

    Friday, April 13, 2012 1:37 PM
  • Jimmy, can you please tell what actually happen in background when organisation is created and what resources on domain it requires to create it..?


    Friday, April 13, 2012 2:46 PM
  • Roughly, CRM makes a query towards DC's to validate privileges and create their security Group and adds the install account to this Groups, in this context is ecommended that the install account belongs to Domain Admin Group or at least have Read/Write privileges on CRM OU. To isolate the problem by force your CRM install to connect to your Principal DC, see the CRM IG to learn how to do this, see the topics "installing CRM from XML files"

    http://www.microsoft.com/download/en/details.aspx?id=3621

    I hope this help

    Regards

    Friday, April 13, 2012 3:56 PM
  • Roughly, CRM makes a query towards DC's to validate privileges and create their security Group and adds the install account to this Groups, in this context is ecommended that the install account belongs to Domain Admin Group or at least have Read/Write privileges on CRM OU. To isolate the problem by force your CRM install to connect to your Principal DC, see the CRM IG to learn how to do this, see the topics "installing CRM from XML files"

    http://www.microsoft.com/download/en/details.aspx?id=3621

    I hope this help

    Regards

    I am using domain admin account for installation and has full rights on CRM OU already. I can observe the newly created groups inside OU and can also see the CRM service account added to these group automatically by installation. 

    :(

    Friday, April 13, 2012 4:04 PM
  • I think, in this point you must open a support request form Microsoft Dynamics Team.

    Regards

    Friday, April 13, 2012 5:20 PM
  • Well your suggestion for support from Microsoft is the last option left.

    Is there any way to install CRM in 'Verbose' mode..? I will have a better way to point out the failure. 

    Friday, April 13, 2012 6:15 PM
  • CRM Installation always keep a full log of setup, this log is already in verbose mode, you can find on install Account Roaming folder

    %appdata%\Microsoft\MSCRM\Logs\crm50svrsetup.txt  , try to post the stack trace here

    Regards

    Friday, April 13, 2012 6:39 PM
  • Referring to my initial post, I have extracted the error from the log you mentioned.

    I meant to say that is there any way to find out what happens when the setup is executed, which files are being accessed and contributing to installation at OS/System level. 

    Friday, April 13, 2012 8:14 PM
  • As i far i know in, all my years working in CRM that's  bigger log you can get ussing CRM normal tools.
    Friday, April 13, 2012 8:41 PM