Error after applying rollup RRS feed

  • Question

  • Started recieving error: 'SystemUser' entity doesn't contain attribute with Name = 'issyncwithdirectory'. after applying update rollup 15 to our CRM server.   This error occurs whenever I attempt to disable a user.  Other symptoms of the problem: 1) I cannot view the User records, however I can manage their roles.  I cannot re-enable any already disabled users, nor can I create any new users. 

    I found another thread regarding this topic:  https://social.microsoft.com/Forums/en-US/465b0eec-b261-4eeb-b7de-4de67c5a61c8/unable-to-disable-users?forum=crm which suggested reapplying the UR and restarting the servers.   We tried this multiple times to no avail.  Still the same problem. 

    Does anyone have any thoughts about how else to troubleshoot and hopefully resolve this?

    EDIT: Further information, this is an on premise solution. 
    FURTHER EDIT/QUESTION: The description of this field indicates that this is an online only field, which would make it seem strange to me that it is present and causing a problem in my on-premise installation.  The simplistic person that resides in my head suggests that the easy solution might be to create the field as a boolean field and mark everyone "yes" and see what happens.  But I wonder if that wouldn't break things later.
    • Edited by MFrag Tuesday, November 18, 2014 7:53 PM
    Tuesday, November 18, 2014 7:35 PM