locked
Setting Anonomous and Integrated Access in IIS for IFD RRS feed

  • Question

  • Trying to set up IFD.  When I go into IIS and right click on CRM, I see Anonomous enabled, but no Integrated selection.  Where is it? 

    Friday, October 2, 2009 3:41 PM

Answers

  • Did you do an iisreset after setting the settings with ifdconfig tool?  If you are using windows 2008, right click on ifdconfig.exe and 'run as administrator', else you may have issues.

    Are you using an ssl certificate?  If not then specify http for ifd scheme.

    Ping deployment_name.domian.net and verify dns is setup properly and has been propagated ok.
    Alex Fagundes - www.PowerObjects.com
    Friday, October 2, 2009 5:15 PM

All replies

  • Hi,

    For setting up IFD, you should not have to change IIS settings.  Did you run the ifd config tool?
    http://support.microsoft.com/kb/948779


    Alex Fagundes - http://www.PowerObjects.com
    Friday, October 2, 2009 4:48 PM
  • Yes, but cannot seem to get it to work.  Our domain is hosted so I had the isp create a Host record deployment_name.domain.net.  In the IFD tool, I set the following:

    Authentication Strategy  IFD+On Premise
    IFD Internal Network address and Subnet Mask 192.168.1.6-255.255.255.0
    IFD Domain Scheme is HTTP
    IfD App Root Domain is domain.net the IfD SDK Root Domain is domain.net (tried domain.net:5555 but it did not seem to make any difference)
    Ad domain autoset to HTTP  crmserver:5555

    created a Host record in DNS for the deployment.  When I test using the IFD tool, it shows it is recognized.  Not sure if it matters, but our hosted domain.net is different than the internal server domain2.net. 

    When I try to connect from a computer outside the network it fails.  I do not even get the login screen.

    Friday, October 2, 2009 5:01 PM
  • Did you do an iisreset after setting the settings with ifdconfig tool?  If you are using windows 2008, right click on ifdconfig.exe and 'run as administrator', else you may have issues.

    Are you using an ssl certificate?  If not then specify http for ifd scheme.

    Ping deployment_name.domian.net and verify dns is setup properly and has been propagated ok.
    Alex Fagundes - www.PowerObjects.com
    Friday, October 2, 2009 5:15 PM
  • That helped clear some things up.  I was not running IFD tool as administrator so changes were not being reflected.  Also helped with the IIS reset.  Now when I try to log in from the outside using http://deployment_name.domain.net  I get the IIS7 screen, not the log in screen.

    Friday, October 2, 2009 7:03 PM
  • Make sure crm is the only site on your iis server if it is a dedicated site.  If you have the default web site with nothing it, stop the default site.  I woudl also check your 'crm web site' and make sure its ip binding is set to 'all ips' if this is a dedicated crm server.

    And if the above does not help, verify that http://deployment_name.domain.net  is going to an ip that is in your crm server.


    Alex Fagundes - www.PowerObjects.com
    Friday, October 2, 2009 7:46 PM
  • thanks for the help.  I was able to get things back to ground zero at least.  I do not have IFD running, but I can again get to it remotely using http://<ipaddress>:5555/deployment.  Will have to play with it again over the weekend.
    Friday, October 2, 2009 8:15 PM