locked
Windows 10 backup does not run RRS feed

  • Question

  • I have been pulling my hair out with this problem. 

    I have been running WHS 2011 for a number of years without problem.  This server backs up 6 computers and has been doing so flawlessly.  Starting last year when the Windows 10 Technical Preview came out, I added two new computers with the TP to test it with Windows 10.  For some reason, neither of these computers would run the backups automatically.  If I started them manually by going into the Task Scheduler, they would back up as they should.  Later after upgrading the TP a number of times, one of the computers started doing backups automatically, but the second would never do them.

    After Windows 10 came out officially, I upgraded one of my Windows 7 machines to Windows 10 and it did it's nightly backups as it should.  So I upgraded a second machine to Win10.  However, it will not backup.  So with this second machine, I then proceeded to do a clean install from CD.  After this install, I loaded the connector software and did a manual backup.  However after that backup, no nightly backups would run automatically.

    So now I have 5 Windows 10 computers; one brand new machine upgraded from Windows 8, two upgraded from Windows 7  and two Technical Preview machines.  All are backing up automatically except one upgraded from Windows 7 and one TP machine.

    The last piece of this puzzle is the Task Scheduler.  In each machine I have created a task to wake the computer and run a simple command then exit.  This appears to be where the failure happens.  The machines that will not do the nightly backup also will not wake from sleep to run the command.

    Any help would be greatly appreciated.

    Tuesday, October 20, 2015 2:11 PM

All replies

  • Hi,

    According to your description, my understanding is that specific Windows 10(upgraded from Windows 7 and Windows 10 TP) failed to be automatically backed up via WHS 2011.

    >In each machine I have created a task to wake the computer and run a simple command then exit.  This appears to be where the failure happens.  The machines that will not do the nightly backup also will not wake from sleep to run the command.
    It seems that the problematic Window 10 can’t be waked up by automatically beck up, nor task. 

    Is the Windows 10 in sleep, hibernation or hybrid sleep mode when this problem happened? 

    Tried to change/disable the mode and confirm that if it is a sleep/hibernation/hybrid sleep related problem.
     
    Check to see if Allow wake timers is enabled on windows 10:
    Open Control Panel – Power Options – select current used plan and click Change plan settings – Change advanced power settings – sleep – Allow wake timers – enable

    Besides, you may open Event Viewer and confirm that if related event has been logged. It might be helpful to narrow down this problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, October 22, 2015 6:58 AM
  • Hi Eve, thanks for responding to my message.

    First, as far as I know, my problems all are on desktop computers and that they all use hybrid sleep mode.  Not sure of a way to confirm exactly what mode of sleep is being used, but assume hybrid.

    Allow wake timers have been enabled on all machines.

    Machines exhibiting this problem do NOT wake for any timed event; not just WHS backup, but even Windows Update and other Microsoft specific scheduled tasks.  These machines DO NOT WAKE on a schedule.

    The two machines I'm having problem with right now are both Intel motherboards (DQ35JO and DQ965GF).  One is running Windows 10 Technical Preview and one is running Windows 10 Home and is licensed. 

    The Windows Home machine had been upgraded from Windows 7 and exhibited the same problems after the upgrade.  When it was running Windows 7, backups worked flawlessly.  After upgrading and experiencing the no wakeup problem, I reinstalled Windows 10 as a clean install from a Windows 10 CD.  I've reinstalled Windows 10 on this machine numerous times using differing install steps to see if that changes anything.  The latest install comprised on intalling Win10, and then immediately installing the WHS connector and then leaving it to see if it would backup.  It wouldn't!  I then loaded the chipset driver for this MB and waited to see if it would backup.  It wouldn't!  Finally I loaded the remaining device drivers for the MB and manually did a Windows Update to get the machine up to date and then waited another night to see if it would backup.  Again, it wouldn't!

    So this is a very plane jane system with no additional software loaded other than the WHS connector and it will not wake from sleep to perform scheduled tasks.

    When I log on to the computer, the nightly backup starts to run as long as at the time I log on it is within the backup window for WHS.  I've enabled task history and when viewed it shows an event id of 106 with a message of "Missed task start rejected".  The time stamp shows the time that the backup kicked off after I logged onto the computer.  It also shows that the old task has been deleted and a new task has been registered to happen during the next backup window.

    I checked the event logs and noticed two things of interest.  First, no events were logged between the time I put the computer to sleep yesterday and the time I woke the computer this morning.  NO EVENTS; machine never woke to do any scheduled tasks. 

    The second thing I did notice was that on putting the computer to sleep yesterday, the last event logged was event id 137 Kernel-Power which states "The systems firmware has changed the processor's memory type range registers (MTRRs) across a sleep state transitition (S4).  This can result in reduced resume performance".  I've seen this event on almost all my machines for many years and as usual, when searching for either a reason for fix, nothing every comes from MS so I've just lived with it.

    Anyway that's where things stand.  Nothing I can see will cause Windows 10 to wake from sleep to perform scheduled tasks even when the same machine running Windows 7 never had a problem.  Any help or suggestions you can offer will be appreciated and if you need further information, please ask.

    Thank you.

    Greg ...

    Thursday, October 22, 2015 1:55 PM
  • Eve, one further thing.  I have another system with an Intel DQ965GF motherboard running Windows 10 Technical Evaluation and it performs without problem.  Backups are done on schedule every night.  This was not always the case.  This was my first Technical Evaluation box and from the first few builds, nothing would wake this machine either.  Then all of a sudden after one of the TP updates (not even sure which one) everything started working correctly.   Settings for this machine are identical to the other DQ965GF machine with the exception of a few other programs loaded so I could test them (Office and iTunes to name a few).

    Thanks again.

    Greg ...

    Thursday, October 22, 2015 2:06 PM
  • Eve, thanks again for getting back to me.  It's always nice to think that somebody is listening when problems are happening!

    Anyway, I think I have finally found the answer to my problem.  As I mentioned in my reply, the problem is happening on two systems, both of which are using Intel motherboards.  In fact, I have 7 systems using Intel motherboards, 4 of which are running Windows 10.  Of those 4 systems, only 2 were experiencing this problem.   The motherboards are DG31PR, DQ35JO and DQ965GF and all are between 5 and 8 years old, but were running Windows 7 just fine.

    However, the BIOS settings for each of these boards was slightly different and the component that was causing the problem was HPET was enabled on some, but not all boards.  As it turns out, when I enabled HPET on the two failing systems, tasks scheduled in the Task Scheduler started working; WHS Backups and nightly updates.

    So I checked everywhere I could find to get more information about HPET and Windows 10, but NOTHING COULD BE FOUND.  Windows 10 does not specify that HPET should be enabled or disabled, and in Windows 7 the only thing I could see was that for some people running games (which I do not), it hurt or helped performance depending upon who you talked to.

    Well, I've enabled HPET on all my systems and am now happy.

    Greg ...

    Sunday, October 25, 2015 1:21 PM
  • Did you install the UEFI hotfix on your Windows Home Server?

    Best greetings from Germany
    Olaf

    Monday, October 26, 2015 3:20 PM
  • Yes Olaf, I have installed the UEFI hotfix on my server. 

    Greg ...

    Monday, October 26, 2015 4:36 PM
  • Hm, I never needed explicitely enable HPET or something else in the Bios of any of my machines to get client backup working.

    If you navigate to your Task Scheduler, do you find the task Backup in the task library under Microsoft/Windows/Windows Server? If so, can you launch it manually from there?

    Best greetings from Germany
    Olaf

    Wednesday, October 28, 2015 8:43 AM
  • Olaf, yes again.  The entry in the Task Scheduler is there and I can launch it manually and when I do so, it does run correctly.  In fact, that is the way I've been running the WHS backups for the past 10 months.  In addition, I had created a simple Task Scheduler job to do nothing but wake up the computer, start a command shell and then exit.  And that too did not work.  And lastly, not only did WHS backups not wake to run, nothing woke up the computer, including Windows Update so I had to run the updates daily to get Windows Defender changes.

    Once I enabled HPET in the BIOS, all timed events started working normally.

    The computers in question are not new!  In fact most of my test machines are older Core 2 Duo boxes circa 2008 to 2011 with Intel motherboards.  These machines originally came installed with Windows Vista and were never even certified for Windows 7 although I have been running Windows 7 very successfully on them for a number of years.

    When I looked up more information regarding HPET on the web, most of the things I found tended to talk about performance issues by either enabling or disabling HPET and most of these issues had to do with gaming which I do not do.  So never thought HPET was an issue for me as with Windows 7 (and Vista) everything worked perfectly.

    Greg ...

    Wednesday, October 28, 2015 1:44 PM
  • Hi Greg,

    thanks for your interesting detail information.

    This would raise the question, if there are any Bios updates available on the mainboard or computer makers site and if you did apply the latest update, the same goes for the chipset drivers.

    Best greetings from Germany
    Olaf

    Thursday, October 29, 2015 2:00 PM
  • Good morning Olaf (morning here anyway).

    The BIOS on all machines is the latest offered by Intel.  The same goes for the chipset drivers.

    My normal mode of operation is to install the OS.  After the OS has been installed but before any updates are applied, I install the chipset drivers, the NIC drivers, the video drivers and the sound drivers.  Only after this has been done, do I allow the system to connect to the network to download updates from MS.

    But when working to try and find out this HPET thing, I tried installing with and without Intel drivers to see if that made any difference.  I've installed Windows 10 from CD so many times now, I can do it in my sleep.

    But since changing the HPET in the BIOS everything has been working perfectly in Win10.  Haven't checked to see if Win7 still works with it turned on.  Maybe that's my next task!

    Greg ...

    Thursday, October 29, 2015 2:32 PM