locked
Remote access to console via Internet RRS feed

  • Question

  • I have just installed WHS, and I am trying to connect to the server via the internet. I can log onto the server and I can click on "Computers", then "Connect to your home server"

     

    Everything seems to work OK, I get an Active X downloaded, and then a message asking if I trust this computer. I then get "connecting to the server" for a while then I get a "The remote connection to the computer timed out. Please connect again"

     

    The server tests fine locally. Do I need to do something at the client end to make this work?

     

    Any help will be appreciated, as this is the major reason I wanted WHS.

     

     

    Tuesday, April 24, 2007 10:22 AM

Answers

  • Make sure that you have the ports forwarded properly and the Remote Desktop exception is set in the Windows Firewall on the server to allow connection from all computers on the internet. By default the firewall sets the Remote Desktop exception to only machines on the subnet. To change this logon to the server internally via Remote Desktop and then open Control Panel go to Windows Firewall, and then go to the exceptions tab and then click on Remote Desktop and then properties and then set the allow to All computers (Even those on the internet) and you should be set.
    Tuesday, April 24, 2007 3:44 PM
    Moderator

All replies

  • Have you forward the HTTPS (443, TCP) and the RDP-Proxy Port (4125, TCP)?

    Post:
    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1210849&SiteID=50

    I have this problem too.

    Tuesday, April 24, 2007 11:43 AM
  • I'm getting the time out error as well. Mine was happening before the CTP. I have a Belkin router wirelessly bridged to the exact one.  I also have my routers upnp enabled (default) and the 3 ports forwarded by TCP only. I can access via livenode or ip address but when i try to remote i get constant timeouts after 2 secs. I can remote at home but not outside network.

     

    Do we have to have static ip on WHS? Is this a bug, well has anyone filed a bug yet?

    Tuesday, April 24, 2007 3:24 PM
  • Make sure that you have the ports forwarded properly and the Remote Desktop exception is set in the Windows Firewall on the server to allow connection from all computers on the internet. By default the firewall sets the Remote Desktop exception to only machines on the subnet. To change this logon to the server internally via Remote Desktop and then open Control Panel go to Windows Firewall, and then go to the exceptions tab and then click on Remote Desktop and then properties and then set the allow to All computers (Even those on the internet) and you should be set.
    Tuesday, April 24, 2007 3:44 PM
    Moderator
  • I too am having the same issue. I have set up the ports on my router. But still get the time out. I do see event logs in the Home Server that the RDP sessions shows up.

    I see EVENT IDS 2049 2050 2055

    One event that shows up is:

     

    EVENT ID: 2049 Remote access status changed:  user 123456 LogOn . Currently logged on users: 123456

     

     

     

    Wednesday, April 25, 2007 2:09 PM
  • Let's hope the Scope issue gets sorted before launch, then. It should be set automatically if someone enables Remote Access for a user, given that this is a prerequisite! On the WHS settings dialog and Remote Access, the wizard gave my Remote Connection a tick, though I'd not been able to do so with Beta 2 (not tried with CTP yet).

    Wednesday, April 25, 2007 8:26 PM
  • Wow, over 123,000 users logged on, eh? I thought we were limited to 10
    Wednesday, April 25, 2007 8:27 PM
  • 123456 is just the ID not the number of users
    Thursday, April 26, 2007 12:59 PM
  • I am able to RDP when on my network.

    Will need to test the local site out.

     

    Thursday, April 26, 2007 1:01 PM
  • Have tried all the things listed, but still no joy. Am able to transfer files to and from the home server via the internet, and can connect to it over the net from a wireless hotstop, but not from my work location, or from my wifes work location.

     

    Im guessing that the corporate firewall is blocking some of the necessary ports. This kind of makes the remote desktop redundant, as im sure most corporations block the same ports.

     

    Is there no way to tunnel the remote desktop traffic via port 80 to make this work, like other products on the market do?

    Friday, April 27, 2007 7:12 AM
  • I'm in the same boat:  I can access WHS remotely through livenode, but I can't get any of the remote access links to work.  I have tried everything listed in this thread and also this one.  My workplace could be blocking outbound 4125, but I don't have any practical way of finding out that I know of (it's a big company).  I used ActivePorts to check the IP traffic and I see IExplorer sending out a SYS_SENT packet to 4125, but no reply and then the timeout.

    Is there any way to extend the timeout period?  I ask because sometimes have to reload the livenode link a couple of times before I can establish a connection.  I have blazing fast FiOS at home, but the work connection is slow and erratic on occasion.
    Friday, April 27, 2007 4:39 PM