table doing full sync RRS feed

  • Question

  • I have a weird problem with synching a local data cache. in particular, it is usually just one table, but that seems to change from one deployment to the next.

    Also, the sync takes a very, very long time.  This is happening during the gettingdeletes phase of the sync I think.   When it ever comes back, when I look at the equipment table..or whatever table it stalled on, it looks like the LastEditDate columns shows that every row on the sql server was updated to utc NOW(). 

    One time, it is the "equipment" table...another time it is the "equipmentattribute" table...what would cause this behavior?  even if I tell the sync provider to just "download only", it still does this. After all this, it gives me an error "Failed to execute the command "update command" for table "Equipment"

    this just seems flaky.


    Here are the references in my Vs2010 project:



    • Edited by Ge0rg3 Wednesday, January 22, 2014 6:23 PM
    Wednesday, January 22, 2014 5:36 PM

All replies

  • I updated the references to

    still the same thing is happening.


    Wednesday, January 22, 2014 6:51 PM
  • enable sync fx tracing to get more info
    Thursday, January 23, 2014 12:23 AM
  • the client the app is installed on isn't a domain computer, and the clock may be a few minutes different than the server it is connecting to. would that make a difference?


    Thursday, January 23, 2014 9:52 PM
  • by the way, June....I tried to turn on tracing but this wasn't revealing too much.   also, when the "insertcommand" for table "x" fails, this is disconcerting, since it is generated code.


    Thursday, January 23, 2014 9:57 PM
  • shouldnt matter. again if you enable tracing in verbose mode, you should get more info.
    Friday, January 24, 2014 12:35 AM
  • k.   i'll let you know how it turns out.



    Monday, January 27, 2014 3:27 PM