locked
VS2005 -> VS Orcas Beta 1 : Synchronization error ?? RRS feed

  • Question

  • Hi!

    I made an application with a local SQLCE Database that synchronize with a SQL 2005 Server throw a WebService!

    To do that, I used the generated script from Visual Studio Orcas Designer (MARCH CTP) and followed the tutorials of Rafik. The synchronization was well working!!!

    I developp my client on Visual Studio 2005 + SP1, and when I want to deploy my application I remark it was not possible to include the sqlce server in the prerequisites.... so I decided to install Visual Studio Orcas (BETA 1 this time...).

    And when I try a synchronization, I have the following error :

    Exception Message :
    Code Snippet

    "An error occurred when enumerating changes in the client database. Check the inner exception for more details."


    InnerException :
    Code Snippet

    {"The column name is not valid. [ Node name (if any) = ut0,Column name = __sysInsertTxBsn ]"}


    I changed nothing in code, neither on the client, nor on the server.... I've just uninstall Visual Studio 2005 SP1 and installed Visual Studio Orcas (Beta 1) on the client!

    If you have a solution to this problem, I will really appreciate it, because I worked on this application the last three months for my school-diploma and must return it on monday

    Thanks very much for help!!!

    ++
    • Moved by Max Wang_1983 Friday, April 22, 2011 10:49 PM forum consolidation (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Tuesday, May 15, 2007 3:34 PM

Answers

  • Re!

    I solve it.... not with the best solution I think, but it works .

    I just create a new local database with SQL Server Management Studio!

    @++
    Tuesday, May 15, 2007 4:46 PM

All replies

  • ohhh!

    I just see I can't access the sqlce database with the SQL Server Management Studio!

    It suggest me to compact/repair the database with command :
    Code Snippet

    run Compact / Repair


    Do you know how I can make it ?
    Tuesday, May 15, 2007 3:49 PM
  • Re!

    I solve it.... not with the best solution I think, but it works .

    I just create a new local database with SQL Server Management Studio!

    @++
    Tuesday, May 15, 2007 4:46 PM
  • You aren't the only one having problems with SSCE in Beta 1. See this thread: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1549967&SiteID=1.

     

    --rj

    Wednesday, May 16, 2007 4:34 PM