locked
Microsoft MT Error RRS feed

  • Question

  • Using MT within Wordfast, I keep getting the following message :

    

    Server error: TranslateApiException

    Method: Translate()

    Message: Cannot find active Azure Market Place Translator Subscription associated with the request credentials.

    Message id=2241.V2_Rest.Translate.2D5C938C

    What can I do to fix this problem?

    Thanks.

    Wednesday, October 17, 2012 2:34 PM

All replies

  • Hi Ewalin,

    This is the forum for Microsoft Translator.  Regarding your question, it’s best for you to ask Wordfast directly as they are the one who implemented Microsoft Translator plug-in inside Wordfast.  Thanks.  Takako (Microsoft Translator team)

    Thursday, October 18, 2012 11:04 AM
  • When an app (like Wordfast) uses the translation API, it needs credentials in the form of a ClientID and a Client Secret.

    If Wordfast give you the facility to configure your own, the details for getting them are here:

    http://blogs.msdn.com/b/translation/p/gettingstarted1.aspx

    Note that the service gives you up to 2 million characters for free each month, after which a paid subscription is necessary.

    If they don't allow you to configure your own, and you are still getting the problem, I would recommend getting in touch with their customer service.

    Monday, October 22, 2012 4:09 PM
  • Thank you for your reply.

    I did try to register my application as step 2 says.  But they require a Redirect URI which I don't have.

    Monday, October 22, 2012 5:12 PM
  • In that case, they would have to provide you with that information -- we don't have a requirement for a 'Redirect URI'. Check with Wordfast.

    Monday, October 22, 2012 5:51 PM
  • This is taken from step 2 web page.  Redirect URI is marked with a * which are Required fields.


    Monday, October 22, 2012 6:53 PM
  • Sorry, I wasn't clear :)

    The Redirect URI isn't necessary for --translator--.  For translator applications, such as the widget, you can put anything in here as it isn't checked.

    If WordFast needs this value, the redirect uri should be to a site that they provide, so I would recommend getting in contact with them for this value.

    Tuesday, October 23, 2012 2:35 PM
  • Thanks for your help.  Got it to work.
    Tuesday, October 30, 2012 5:48 PM