locked
OC Send a file RRS feed

  • Question

  • We are unable to send files internally from some users but not others.  There is no clear pattern, some users can send and receive files with windows firewall off, others can only send.

    I have read the other topics releated to this issue and with windows firewall off the ports would have no impact on sending files internally?

    OC 2007 R2 version 3.5.6907.0 and 3.5.6907.0 – tested

    Windows Firewall off
    Thanks

     

    Wednesday, September 30, 2009 1:54 PM

Answers

  • Another potential problem I've seen is if a user has VMware workstation installed on their PC the file transfers tend to fail. If you disable the extra NICs VMware creates in your Network Connections folder you should be able to send and receive successfully.
    Wednesday, September 30, 2009 5:24 PM

All replies

  • You are correct, if both clients are internal, there should be no need to open up ports on the external Firewall, and no involvement from the Edge Access server.  An internal file transfer involves setting a session up on an OCS Front-End and then there is a direction connection between Communicator clients to transfer the file.

     

    What error message (if any are the clients getting)?

     

    Here are a few things you can check and do:

     

    1) Are ports 6891-6901 available on the Communicator clients and the Front-End?

    Office Communicator, and the Front-End OCS server use Ports  6891-6901 for the File Transfer.  For the two Communicator clients experiencing the problem:

    - Could your internal network architecture be preventing them from talking directly to each other?

    - Is there any client-side port filtering on either client (Windows Firewall or Anti-Virus software)?

     

    2) Do you have File Transfer Filtering Enabled on the OCS server?

    In OCS 2007 R2, this setting is in OCS R2 Administrative Console in Front-End | Filtering Tools | Intelligent Instant Message Filter | File Transfer Filter

     

    3) Could file transfers be disabled on either client?

    File transfers can be disabled through a Group Policy setting (or registry setting). It is documented in the Microsoft Office Communications Server 2007 R2 Client Group Policy Documentation (here: http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=5D6F4B90-6980-430B-9F97-FFADBC07B7A9&displaylang=en).

     

    If all that fails, I would enable event logging in the Communicator client  (Options | General | Turn on Logging in Communicator), and check the event logs after a failed file transfer.

     

    Hope that helps,

    Curtis (www.insideocs.com)

     

    Wednesday, September 30, 2009 4:04 PM
  • Two more things:

    - if Forefront is installed on your OCS Server, I believe all file transfer activity goes through the OCS Front-End and Ports 6881-6901 need to be accessible on the Front-End.

    - the Communicator clients involved are not up-to-date. This likely is not the problem, but you always minimize the chance of issues if the Communicator clients are up-to-date. You can download and install the July 2009 Communicator R2 updates here: http://support.microsoft.com/kb/969695.

     
    Wednesday, September 30, 2009 4:11 PM
  • Another potential problem I've seen is if a user has VMware workstation installed on their PC the file transfers tend to fail. If you disable the extra NICs VMware creates in your Network Connections folder you should be able to send and receive successfully.
    Wednesday, September 30, 2009 5:24 PM
  • Thanks for the responses.  Disabling the VMware NIC's worked, but is not a viable solution. 

    Are there any plans to resolve this issue with future updates of OC 2007 R2?

    Thanks

    Keith

    Thursday, October 1, 2009 10:03 AM
  • Good call Tom!
    Thursday, October 1, 2009 3:03 PM
  • This issue existed in R1 as well and I'm unaware of plans to fix it, but I sure hope it gets resolved. I know it may not be an acceptable solution if you use the NAT functionality of VMware, but you can disable those NICs and still use bridged mode for a VM without any problems.

    When you view the trace with Wireshark you'll see MOC trying to connect the file transfer over the IP addresses assigned to the VMware NICs instead of the LAN or wireless connection. I've done some tinkering with the NIC binding order, but it didn't seem to make a difference.
    Thursday, October 1, 2009 4:02 PM