none
Can't debug speech workflow RRS feed

  • Question

  • I just got a new development machine at work.  I think I've set everything up properly, but I can't debug workflows.

     

    I get this error message in Visual Studio 2005 when I try:

     

    Unable to attach to the process. Debugging cannot continue. Unable to start debugging on the web server. The web server could not find the requested resource.

     

    I'm running Vista Business. My last machine was also running Vista and I don't remember running into anything like this setting up that machine.

     

    Has anyone else seen this?  Any ideas?

     

    Friday, May 9, 2008 10:09 PM

All replies

  • I had installed SQL Server 2008 (which also installed the .NET 3.5 framework and some VS2008 components). 

     

    This may be why, but I'm having this issue after having uninstalled all of this stuff.

     

    I don't want to have to reinstall Windows.

     

    Monday, May 12, 2008 2:32 PM
  • Unfortunately we don't know yet what is happening here.  What edition of VS2005 are you using? Standard, Pro or Team Suite?

    Monday, May 12, 2008 3:23 PM
  • Pro

     

    Monday, May 12, 2008 3:24 PM
  • Did you try running it as an admin?
    Monday, May 12, 2008 3:35 PM
  • Yes. I always run it as admin.

     

    Monday, May 12, 2008 3:37 PM
  • We are having the same problem. We are running a Vista Ultimate box. Everything in MSS 2007 worked fine until we installed VS2008 a few months ago. Took a break from MSS dev, now while back in VS2005 (Team Edition) w/MSS we get the "Unable to attach to the process" error when attempting to debug and cannot seem to resolve it. We have already developed several VS2008 / .NET 3.5 apps on this box and would prefer not to have to uninstall VS2008.
    Thursday, May 15, 2008 7:20 PM
  • My coworkers had a similar problem on their machines when they tried to run Speech Server apps. However, I was able to run/develop just fine. The only difference I have noticed between their machines and mine is that I have installed Visual Studio 2005 and Speech Server tools after I installed VS 2008. I am not sure if this makes any difference.

    Thursday, May 15, 2008 7:50 PM
  • In my case, it may not seem to make a difference. I did have VS2005 on first; however, just before I installed VS2008, I uninstalled VS2005 thinking MSS would work fine in 2008 - of course now I know it won't. So I uninstalled MSS, then re-installed VS2005 then MSS (and keeping VS2008) and now I have the debug problem. Perhaps technically I had VS2005 on first and perhaps the uninstall left some artifacts affecting this. Thanks much for the info.

     

    Thursday, May 15, 2008 8:29 PM
  • Just wondering if anyone has come up with a solution to this problem yet.  I'm having the same problem without VS2008 installed.  I have seen it after installing VS2008 and ended up reinstalling the OS.  I found after I installed .NET 3.0 SP1 after rebuilding Vista that I ended up with the same error.  I removed .NET 3.0 SP1 by using a restore point.  I am now having the problem again, cannot find a restore point that will allow me to debug without this error and don't want to reload Vista again!  I'm sure that it was caused by another Microsoft Update but I don't know which one.

    Any suggestions are appreciated.
    Sunday, June 22, 2008 8:07 PM
  • We opened a support case with Microsoft on this on May 16th and they acknowledged the issue. We have gotten a few emails from them since then saying they are continuing to work on the problem. We have not been informed of any resolution as of yet.

    Monday, June 23, 2008 12:26 PM
  • MS Support contacted us yesterday with a solution to this (we had a case open for it). No hotfixes required, just a MSS propogated typo in one of the IIS Mgr settings that needs manual correction. Let me know if you need the details. It's pretty buried.

    Thursday, July 17, 2008 3:40 PM
  •  

    Yes.  Can you provide details of how to correct this issue.

     

    Thanks.

     

    phburke@ctimessaging.com

    Tuesday, July 22, 2008 7:12 PM
  •  

    Can you send me the details? You can also post it here. Thanks in advance.

     

    hikmatbek@msn.com

    Tuesday, July 22, 2008 7:15 PM
  •  

    Can people who are having this problem check the following:

    Can you check 2 things:

    1: The speech server application pool Manage Pipeline has to be set to Classic not Integrated.

    2: The Handler mappings executable path in the script Map might have an extra backslash in it - you need to remove.  C:\Windows\Microsoft.NET\Framework\v2.0.50727\\aspnet_isapi.dll ( notice the extra slash)

     

     

    via: http://gotspeech.net/forums/permalink/5481/6247/ShowThread.aspx#6247

     

    Tuesday, July 22, 2008 7:18 PM
  • Ahmed has provided the fixes in the post/reply just above (thanks, Ahmed). These instructions corrected our problem.

     

    To elaborate one point of initial confusion for us - The Handler mappings mentioned in 2: can be found in your IIS 7.0 Manager. You must click on each individual MSS application under your Default Web Site, double-click the app's handler mappings and then navigate to the "*.speax" entry, then edit that property sheet to find the path with the double-backslash at the end. You must do this for each individual application you have under your Default Web Site. No one (that I know of) has found a global mechanism for fixing this path across all apps.

     

    There is also quite a lengthy thread on this very problem here: http://gotspeech.net/forums/thread/5481.aspx that might be helpful.

    Tuesday, July 22, 2008 8:26 PM