locked
Windows 7 Access denied to my user accounts on WHS RRS feed

  • Question

  • Hi There, wonder if anyone can help me. This is my second install and WHS is behaving very differently with user access. From the console I have made sure my password match both on my W7 machine and my home server. From the console I have given my user account full access to everything, however when I try and acess the user I created on my WHS console from Win7 I get access denied. Kind of a newbie so any help would be greatly appreciated.

    Just an FYI, I am able to acess the shared default folders, music, pictures etc (Can only read not write) but cannot access the user account I created. Please note my user name and pass on my Win7 machine are the same as the user and pass I created on my WHS console. Any help would  be greatly appreaciated, thanks.

     

    Tuesday, August 10, 2010 11:46 PM

All replies

  • Hi,

    we often have seen this kind of behavior, if either the guest account is enabled on the server or if the time zone (which on a fresh installed server usually is set to Pacific time), system time or date on client and server do not match.

    And after creating the user account on the server, did you reboot your client (or logout at least)?

    Finally the FAQ How to fix share access issues where user name and password are requested may help in a certain configuration.

    Best greetings from Germany
    Olaf

    Wednesday, August 11, 2010 8:28 AM
    Moderator
  • Olaf

     

    Thank you for taking the time to help me, very much appreciated. This can be frustrating trying to get the Shares to work. Ok here is what I have found and done. You were correct, the server did have Pacific time on it and the guest account enabled. I changed the server to the correct time zone and also disabled the guest account.

    I then rebooted the server and logged off on the client and logged back in, still was not able to access the user account amd the folders that I created under that account. Now I can tell you I think I broke the cardinal sin after trying mutiple things when I first re-installed WHS and could not acess that user account I created. I went into the actaul folder directories on the server to look at the shares and add certain groups such as administrator/s and gave them full permissions. I understand now that this is a big no no...(Hoping I did not further complicate things)

     

    Also my server and client have both the same user name and password so I do not think that is the issue, as a matter of a fact when I right clie on the WHS console icon in my tray on my client the update password is greyed out. I did update password yesterday on this and kept it on the server.. It said it was succesful and now it can't be updated..... Sorry if this is turning into a mess....

    Wednesday, August 11, 2010 12:23 PM
  • Hi,
    the problem with assigning permissions to folders on D:\Shares is, that the permissions on the real folder locations are not being updated that way.

    So if possible try to reassign the permissions through the console only.

    For updating the passwords you can always try to update the password via console instead of via icon in the properties of the user account.

    Best greetings from Germany
    Olaf

    Wednesday, August 11, 2010 9:49 PM
    Moderator
  • Thanks again Olaf

     

    Ok here is somthing that is happening that is very wierd. The moment I delete the user account everything is accessabile. Although when I boot up on the client the WHS console warns me that User name and passwords do not match.

    FYI. My client logon and password are the same as the user account I creat on my server. I tried this several times and sure enought each time I created this account on the server the files on the User account folder became inaccessable.

    Anyone that can help as I would like to keep my files serparated under my user name so only I can access????? Strange

    Thursday, August 12, 2010 11:53 PM
  • Thanks again Olaf

    Ok here is somthing that is happening that is very wierd. The moment I delete the user account everything is accessabile. Although when I boot up on the client the WHS console warns me that User name and passwords do not match.

    FYI. My client logon and password are the same as the user account I creat on my server. I tried this several times and sure enought each time I created this account on the server the files on the User account folder became inaccessable.

    Anyone that can help as I would like to keep my files serparated under my user name so only I can access????? Strange

    Your problem is most likely because you were changing the permissions on the folders (not the Console, which is the only way you should be changing them).  The best way to "reset" the permissions on the shares/folders is to do a Server Reinstallation.  Once it's complete, use only the Console to change permissions on the shares.
    Friday, August 13, 2010 1:34 AM
    Moderator
  • This totally helped me even though my wifes computer is Vista Home Premium.  She was having problems that I could not easily resolve on her computer so I created a new user "Darlene2" on the PC and on Windows Home Server and labeled her old "Darlene" account with a "DO NOT USE" so that she would always use the new user account.  Moved all files over to the new user account and all Windows problems with her older user name were instantly fixed which was great.  I left the old one setup for 30-45 days just to make sure all was good.  When the time came I deleted "Darlene" on the PC and renamed "Darlene2" to "Darlene".  She noticed that she still had to login to access the server though.  Your suggestion on the FAQ pointed me to the 'control userpasswords2' command which revealed that even though I renamed the account back to "Darlene", the PC internally still was using "Darlene2".  Problem solved, wife happy, thanks for the suggestions Olaf in Germany from Mike in Albany NY.
    Sunday, November 28, 2010 4:25 PM