locked
Unable to re-upload RDL file to CRM after opening the file in Visual Studio 2015 RRS feed

  • Question

  • I'm trying to make minor edits to a CRM report by downloading it, making edits in SSDT (using Visual Studio 2015 Integrated Shell in Windows 10 Pro), then uploading it back into CRM. When I upload it though, CRM returns a generic "Error Uploading Report" error. Any ideas on how to fix this? I tried to isolate the issue and discovered a few things:

    - The original file will upload with no issues.

    - If I take the original RDL file and make a copy of it (without opening it in VS), the copied file will upload successfully.

    - If I open the RDL file in VS and make NO changes but save it as a a file with a different name, the new file will fail to upload. 

    I tried uninstalling SSDT/VS completely, including all related files, and reinstalling it. That did not make a difference. Repairing did not work either.

    Help!

    Wednesday, March 1, 2017 7:13 PM

All replies

  • Hi Kate,

    Did you try comparing the two .rdl files (original file and the one opened in Visual Studio) using a file comparing tool. If you do you might be able to find what changes are done to the file when opened in Visual Studio.

    Thank you.


    Sachith Chandrasiri

    Monday, March 6, 2017 12:57 AM