locked
WHS software issue RRS feed

  • Question

  • I've been tearing my hair out with an issue with WHS which has appeared after I rebooted the server one evening. The problem is none of my files are accessible across the network or locally. In every case I get an error similar to file cannot be accessed by the system. I have about 4Gb of files on the server and none of them are accessible.

    If i open up the console I have a network critcial warning which is due to the backup service not running. If i try and start this manually for services it turns on and off immediately. Hardware monitor is all fine for system and hard drives as is a chkdsk which i ran on the system Within server storage one of the 4 hard drives says Not Added which is odd. If i click remove (as the only option available) it says there is not enough free space to move the file off. Based on this I added a new 1TB hard drive via USB and added it. I then tried to remove the old one and I got the same error message which is not possible as the HD i added is the same size as the one I'm removing and they system is only about 70% full anyway. The Server Storage is constantly trying to calculate sizes and has been fro the past 10 hours with no luck.

    I'm sunning WHS SP2 accorfing to System. Automatic updates are on. It was a nightmare getting WHS on the server but has been fine since. I had to slipstream the install as the harware has no graphics card so a reinstallation is not really an optoin and I don' wat to loose all my media.

    Any help gratefully received.

     

     

    Monday, August 1, 2011 9:03 PM

All replies

  • You can try the following, but I don't guarantee anything. When a drive is dropped from server storage, it often indicates some sort of hardware issue or data corruption on one of your disks. It can also be totally random, as far as I can tell ("random cosmic ray effect" :) ). So try this:

    • Add a drive sufficient to hold the contents of the "missing" drive" to server storage, as you've done. USB is acceptable in this case, but I recommend against using a USB drive in server storage in general.
    • Shut your server down.
    • Physically disconnect the "missing" drive from the server (pull data/power cables).
    • Boot your server.
    • Try removing the "missing" drive again.
    • If the removal succeeds, connect the drive to some other computer and copy what you find in <drive letter>:\DE\Shares\etc. to the server shares.
    • Clean the disk using e.g. diskpart or a partition manager of your choice.
    • Reinstall the disk in your server.
    • Add the disk to server storage.
    • Remove the USB drive from server storage.
    • Repair the backup database using the functionality in the console. You may lose some or all backups, for some or all computers, because the backup database isn't duplicated and some files may now be missing. You shouldn't attempt to recover any backup database files from the "missing" disk because this issue has existed for some time and files may not be consistent across disks.

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, August 2, 2011 12:39 PM
    Moderator
  • Thanks for the detailed reply.

     

    I got as far as removing the 'unadded' hard drive from WHS and physically and I aslo can see the files when i broswe this HD on antoher PC. My issue now is that I still can't access files on the other 3 hard drives. I still get

    "Teh file cannot be accessed by the system" no matter where I access it from. If I copy a new file to a share on the system it can be accessed even remotely. This makes me think it is something to do with security on all the current files. I've litterally made no config chages in the past year on the machine and all I did was a reboot.

    Any more ideas. I could pull all my files off each hard drive using the manner suggested and reinstall but I'd have to buy a new set of hard drives and it would take days to complete.

    Tuesday, August 2, 2011 8:16 PM
  • Did you actually remove the drive from server storage using the console? Did you encounter some error when you tried to do so?
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, August 2, 2011 8:36 PM
    Moderator