locked
Instant Messaging between OCS R2 and 2007 RRS feed

  • Question

  • We have OCS 2007 deployed and used in production for instant messaging and conferencing needs. We deployed R2 in a new OCS pool and migrated couple of test accounts. The test accounts can IM among themselves, but the IM between R2 and 2007 users is not going smoothly. When users from 2007 initiate a connection with user in R2 there is not issue, but it doesn't work when R2 user initiate the IM conversation. I get a very general error on IM The following message was not delivered to User More details (ID:504). Any suggestions ?

    Thanks
    Tuesday, February 10, 2009 3:00 AM

All replies

  • Based on the error code and description it appears that the R2 server is having problems connecting to an communicating with the existing OCS Front-End server(s).  Are you using a load-balanced Enterprise Edition deployment, or Director(s)? Is a firewall traversed between systems?  Some more details on your configuration would be helpful.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Tuesday, February 10, 2009 3:23 AM
    Moderator
  • Jeff,

    Thanks for your response. We are not using load balancer or director. In our OCS 2007 deployment we have one enterprise app/front end server, one CWA  and one web conf. edge server on DMZ and we created a new pool for OCS R2 deployment. We currently don't have an AV edge server. We have not added R2 pool to the existing edge server yet(probably tonite). Both pool are on same LAN and do not traverse the firewall. We have checked the certs on both pool and they are valid.  Does that give you an overview

    Do you know when an IM is sent from a user in one pool to a user in another pool if the IM traverses edge server or is it direct communication ?

    Thanks
    Varun
    BTW: We have used a few pointbridge blogs for our OCS2007 deployment...they have been really helpful

    Tuesday, February 10, 2009 2:58 PM