none
My forums threads

All replies

  • I take it back. Just discovered that the cool feature where you can expand a thread in the same page and post an answer (i.e. without a postback) doesn't work in "My forums threads"! <sigh> Back to the drawing board... :)

    http://sqlblog.com/blogs/jamie_thomson/ | @jamiet | About me
    Friday, March 12, 2010 2:08 PM
  •  
    I take it back. Just discovered that the cool feature where you can expand a thread in the same page and post an answer (i.e. without a postback) doesn't work in "My forums threads"!
     
     
    Explain?   I don't see any difference in functionality between  "My forums threads"  and  "My threads"   E.g. they both have the expcol (Expander-Collapser?) icon on each item.  
     
    I once had a problem that that icon wasn't being shown, e.g. omitted from the source for some reason, but it was only transitory.   You could use the  IE8 Developer Tools Find  (F12, Ctrl-b)  to see if that is your case too.
     
     
    HTH
     
    Robert Aldwinckle
    ---
    Saturday, March 13, 2010 12:31 AM
  • Hi Robert,
    Yes they both have the expand/collapse icon but it only works on "My threads"

    More info:
    If I go to "My Threads" (http://social.microsoft.com/Forums/en-US/user/threads?user=Jamie%20Thomson) I can click the "Show Thread"* toggle button and the thread expands to show all the posts in that thread without reloading the page.

    If I go to "My forums threads" that doesn't happen. The arrow changes to point downwards instead of upwards but the posts in the thread do not show up.

    Make sense?

    -Jamie

     

    *I have no idea if "Show thread" is the correct name of the buttor not, its jsut what I'm calling it. FYI Its the button next to a thread title with an arrow on it that points upward when a thread is collapsed and downward when it is expanded


    http://sqlblog.com/blogs/jamie_thomson/ | @jamiet | About me
    Monday, March 22, 2010 1:25 PM
  • Hi Robert,
    Yes they both have the expand/collapse icon but it only works on "My threads"

    More info:
    If I go to "My Threads" (http://social.microsoft.com/Forums/en-US/user/threads?user=Jamie%20Thomson) I can click the "Show Thread"* toggle button and the thread expands to show all the posts in that thread without reloading the page.

    If I go to "My forums threads" that doesn't happen. The arrow changes to point downwards instead of upwards but the posts in the thread do not show up.

    Make sense?

    -Jamie

     

    *I have no idea if "Show thread" is the correct name of the buttor not, its jsut what I'm calling it. FYI Its the button next to a thread title with an arrow on it that points upward when a thread is collapsed and downward when it is expanded


    http://sqlblog.com/blogs/jamie_thomson/ | @jamiet | About me
    Monday, March 22, 2010 1:25 PM
  • You were keen on us reading that message :)

    I use My Forum Threads on every pass except for the first one of the day when I go to individual forums.

    I see no difference between it and a normal forum in seeing the posts in a thread.

    My one problem with it is that whenever I open a post in order to edit or move it, on Submit I am not sent back to My Forum Threads but to the forum that post was in.

    But certainly otherwise I am seeing no difference in the handling. (Could it be you are not using flat threads - i.e. threads showing posts in order?)

     

     


    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Monday, March 22, 2010 5:50 PM
  • You were keen on us reading that message :)


     

    Just when I thought I had figured out why I was seeing duplicates using the bridge.  ; )

    Monday, March 22, 2010 8:34 PM
  • If I go to "My forums threads" that doesn't happen. The arrow changes to point downwards instead of upwards but the posts in the thread do not show up.


     

    The arrow is what I was referring to as  expcol.   Frequently it doesn't result in a display of the thread but it does (I would say always) show me the container that that non-shown thread would be in.   E.g. changed expcol icon and links  (view thread) (close thread).   When that happens I have to open the thread in its own window e.g. with Ctrl-Click in IE.  It seems to happen more often than not in some forums.   I don't know why.   Annoying.   Just one of the quirks of this forum software I guess.


    Robert
    ---

    Monday, March 22, 2010 8:59 PM
  • I think this problem may have to do with the branding. Posts form a "foreign" brand do not expand. See

    http://social.msdn.microsoft.com/Forums/en-US/reportabug/thread/0995c2cb-726a-4c11-8362-5e9f2e112efd

    This issue has been acknowledged as a bug by the forum team.

     

     


    David Wilkinson | Visual C++ MVP
    Tuesday, March 23, 2010 1:50 PM
  • I've been thinking that 'My Threads' can be better split to 'My Threads' (threads I started) and 'My Replies' - replies in the threads I participated.

    This may be quite helpful thing.


    Premature optimization is the root of all evil in programming. (c) by Donald Knuth

    Naomi Nosonovsky, Sr. Programmer-Analyst

    My blog
    • Proposed as answer by Teen geek Tuesday, March 23, 2010 2:29 PM
    Tuesday, March 23, 2010 2:10 PM
    Moderator
  • I think this problem may have to do with the branding. Posts form a "foreign" brand do not expand. See

    http://social.msdn.microsoft.com/Forums/en-US/reportabug/thread/0995c2cb-726a-4c11-8362-5e9f2e112efd

    This issue has been acknowledged as a bug by the forum team.

     

     


    David Wilkinson | Visual C++ MVP
    Excellent, thank you Dave. I'll go and my two-penneth over there.

    http://sqlblog.com/blogs/jamie_thomson/ | @jamiet | About me
    Tuesday, March 23, 2010 2:34 PM