locked
CRM 2013 - Unable to Export Queue Item Custom Relationships RRS feed

  • Question

  • Hi All,

    We've created a custom relationship (N:1) from Queue item to Site so that users can filter items by Site (and we also have business logic in plugins that uses this relationship), but we cannot import the solution to another server. What are we doing wrong?

    When trying to deploy the solution to another server we get errors during the dependency calculation step. The errors refer to a missing attribute, which is the Site lookup filed that appears on the Queue item (queueitem) form.

    Looking at the customization.xml file, I cannot find the EntityRelationship element for the Queue Item to Site relationship, which is where the field element would be describing the lookup attribute.

    Both Site and Queueitem are included in the solution and all customizations have been published. Solution is unmanaged. I've tried this on 2 separate CRM instances with the same results. All servers are RU 3 and SP1.

    Does this sound like a bug, or are we doing something wrong?

    Thanks!

    Elie Wildman


    • Edited by Elie W Tuesday, October 14, 2014 11:41 AM
    Tuesday, October 14, 2014 10:19 AM

All replies

  • Hi Elie,

    Any answer to this problem? We have the exact same situation. I have got a relationship with Queue item and that works well in the existing environment but when I try to export and import the solution to new environment it fails with the entityrelationshipmapping.

    Thanks

    Maulik Adhia

    Friday, November 14, 2014 12:34 PM
  • We are encountering the same issue.  Any word from Microsoft on why customer relationships against the QueueItem entity are not being included the exported solution?  This happens for both managed and unmanaged solutions.
    Wednesday, January 14, 2015 8:19 PM
  • I have not tried this specific issue, however Queue Item relationships appear to be half-baked or broken in CRM 2015 as well...  I needed something specific out of a queue item entity and it did not work, so I tried a few other related things and found this. 

    If you create a Queue Item to Case 1:N relationship (as an example), it looks like you

    - Cannot add Cases folder to the Queue Item form's Navigation area

    - Cannot select a Queue Item record in the Queue Item lookup field on the Case form - the lookup window search just does not return any records even though there are some in the system.

    If anyone has any insights on the mystery, it would be greatly appreciated. 

    Sergei

    Tuesday, January 20, 2015 10:20 PM