locked
Access WHS through Web RRS feed

  • Question

  • Is there any way say my family or friends could access shared files on my WHS over the internet? If so, could someone please tell me how this can be configured. Thanks in advance!
    Wednesday, March 7, 2007 3:04 AM

Answers

  • Yes, this can be done. There are several steps, and you will have to know something about your home network.

    First, enabling access to WHS for a user:
    1. start WHS Console
    2. Find the user you want to permit to access WHS remotely
    3. click Properties for this user.
    4. Check Enable remote access for this user in the dialog that pops up, if it's not already checked.
    5. Click Apply, then OK.
    The user is now permitted to access WHS remotely. You can test this in your browser, while you're home, by going to the URL http://server/home (substitute the computer name of your server if different). Click on the Log In button, and enter the user name and password for the user you enabled for remote access above. You should see the WHS remote access page with two or three tabs at the top:Home, Shared Folders, and Computers. (Computers is only present if using Internet Explorer.)

    The second step is to configure your router to permit access to your WHS from the Internet. I can't give step by step instructions, because every router is different. However, you will need to determine the IP address of your WHS, you will have to set your router to forward thhree TCP ports to that IP address. The ports are 80 (HTTP protocol), 443 (SSL protocol), and 4125 (RDP over RWW protocol). Once that is done, you will need to find out the external IP address that your router gets from your broadband provider. The external IP address of your router is usually available in the administration screens. Once all that is taken care of, you can test locally by going to the URL http://WHS.ip.ad.dr/home (substituting your router's external IP address for WHS.ip.ad.dr) You should be able to see the same screens as above.

    A couple of notes about the process: you can't enable remote access for the Guest user. This is a security measure. Your internet service provider may have technical measures in place which keep this from working; there's little you can do to fix this if it's the case.

    If you have problems with any of this, please don't hesitate to come back and ask more questions.

    (Edit: I see someone else answered while I was typing, and you've got it working. Great!)
    Wednesday, March 7, 2007 3:40 AM
    Moderator
  • Assuming you haven't used up your limit of 10 users on the WHS box, you can do the following:

    1. Open the Windows Home Server Console

    2. Go to the User Accounts page

    3. Click "Add" to add a user account

    4. Give the user a unique name.  Make sure the "Enable Remote Access For This User" checkbox is checked.

    5. Finish the user addition wizard

    6. Give the remote login instructions (username/password) to the user(s) you wish to grant access to.  Don't give out the administrator password, though.  Also be sure to password-protect your connected machines if you don't want your friends or family burowing into your machines.

    You should be good to go after this. 

     

    Good luck!

     

    Todd in Cheesecurdistan

    Wednesday, March 7, 2007 3:29 AM

All replies

  • Assuming you haven't used up your limit of 10 users on the WHS box, you can do the following:

    1. Open the Windows Home Server Console

    2. Go to the User Accounts page

    3. Click "Add" to add a user account

    4. Give the user a unique name.  Make sure the "Enable Remote Access For This User" checkbox is checked.

    5. Finish the user addition wizard

    6. Give the remote login instructions (username/password) to the user(s) you wish to grant access to.  Don't give out the administrator password, though.  Also be sure to password-protect your connected machines if you don't want your friends or family burowing into your machines.

    You should be good to go after this. 

     

    Good luck!

     

    Todd in Cheesecurdistan

    Wednesday, March 7, 2007 3:29 AM
  • Thanks, I really didnt know if it was that easy or not.

    Worked perfect.
    Wednesday, March 7, 2007 3:36 AM
  • Yes, this can be done. There are several steps, and you will have to know something about your home network.

    First, enabling access to WHS for a user:
    1. start WHS Console
    2. Find the user you want to permit to access WHS remotely
    3. click Properties for this user.
    4. Check Enable remote access for this user in the dialog that pops up, if it's not already checked.
    5. Click Apply, then OK.
    The user is now permitted to access WHS remotely. You can test this in your browser, while you're home, by going to the URL http://server/home (substitute the computer name of your server if different). Click on the Log In button, and enter the user name and password for the user you enabled for remote access above. You should see the WHS remote access page with two or three tabs at the top:Home, Shared Folders, and Computers. (Computers is only present if using Internet Explorer.)

    The second step is to configure your router to permit access to your WHS from the Internet. I can't give step by step instructions, because every router is different. However, you will need to determine the IP address of your WHS, you will have to set your router to forward thhree TCP ports to that IP address. The ports are 80 (HTTP protocol), 443 (SSL protocol), and 4125 (RDP over RWW protocol). Once that is done, you will need to find out the external IP address that your router gets from your broadband provider. The external IP address of your router is usually available in the administration screens. Once all that is taken care of, you can test locally by going to the URL http://WHS.ip.ad.dr/home (substituting your router's external IP address for WHS.ip.ad.dr) You should be able to see the same screens as above.

    A couple of notes about the process: you can't enable remote access for the Guest user. This is a security measure. Your internet service provider may have technical measures in place which keep this from working; there's little you can do to fix this if it's the case.

    If you have problems with any of this, please don't hesitate to come back and ask more questions.

    (Edit: I see someone else answered while I was typing, and you've got it working. Great!)
    Wednesday, March 7, 2007 3:40 AM
    Moderator
  • Well I THOUGHT I had it working right, it does on my end when i go to the external IP, opened all the ports, gave permissions, etc. Now, I just had a associate try to log on from his home over the external IP and the account i set for him, with no luck. What could be the problem here? Is it just inevitable that it wont work or is there a solution? Thanks in advance.
    Wednesday, March 7, 2007 5:35 AM
  • Could your friend access the log on page? If he couldn't visit the website at all, it's likely a network problem. Another post in the forum mentioned port blocked across ISP providers. Could this be your case?

    If he could access the logon page but couldn't log on, please check the user property from the server Admin Console and make sure "Remote Access" is enabled. Did he see any error message when trying to log on?

     

    Wednesday, March 7, 2007 6:39 AM
  • Well OK, He has gotten into the remote access, the problem was and he's not to savvy at stuff like this, was a certificate error, I notice it says "Server name on certificate is incorrect" .. New question. How do i go about in fixing this error so this certificate error wont pop up? Thanks in advance!
    Wednesday, March 7, 2007 10:22 PM
  •  

    When the certificate warning pops up, please just proceed and click "Continue to this website (not recommended)."

    This problem will be solved at final release.

    Thursday, March 8, 2007 3:17 AM
  •  Fan Z wrote:

     This problem will be solved at final release.

    How is this going to work? Am I going to be able to get a real SSL certificate from VeriSign onto my WHS box? If so, how is the typical non-geek who is the target audience going to get such a certificate? Last time I checked, these things were kind of expensive and not so friendly to get. Is MS foing something else? Will it still work with non-IE browsers?

    Thursday, March 8, 2007 4:27 PM
  •  smithsa wrote:
     Fan Z wrote:

     This problem will be solved at final release.

    How is this going to work? Am I going to be able to get a real SSL certificate from VeriSign onto my WHS box? If so, how is the typical non-geek who is the target audience going to get such a certificate? Last time I checked, these things were kind of expensive and not so friendly to get. Is MS foing something else? Will it still work with non-IE browsers?

    It probably doesn't come from VeriSign, but I can't disclose more details at this time.

    Friday, March 9, 2007 4:40 AM
  • Hello from Germany!
    I have remote access to my new WHS over the web with a vista-machine, but got, while trying login as "Administrator", the message:
    To protect the security of your home network, you cannot log on remotely by using the Administrator user account. To administer your home network remotely, log on with your own user account. Then click the Console button on the Computers tab to connect to the Windows Home Server Console.

    Well, I did so and logged as an user with remote-access-rights, but cannot find any "
    Console button on the Computers tab to connect to the Windows Home Server Console." - I only see "Home - Computers - Shared folders" , but no way to get full Administration-Rights for full administer the WHS over the web.

    Do you have a tipp?

    Thanks and greetings,
    ee

    !!!  ***** Edit: Oh, there are to much tomatoes on my eyes! ...below "Computers" now I found the tab! - :-)

    No problems at the moment and no help needed, until tomorrow, I think! :-)
    Greetings,
    ee
    ****************




     
    Monday, November 12, 2007 7:20 AM
  • I'm using the final OEM release, and the certificate warning is still there.  But you can just click on through.

    Monday, November 12, 2007 2:15 PM
  • Ken,
    I want to thank-you for the info regarding remote login to the server. I was able to login no problem. I am still  having trouble with remote login from this method:  https://username.homeserver.com. Your info was a big help.
    Again, thanks!
    Wednesday, November 14, 2007 2:29 AM