locked
Debug Window does do Recognition & how to change speakers? RRS feed

  • Question

  • Hi, I am new to MSS, and have the following two questions:

    1. I created the Survey Tutorial application, and ran it in a debugging mode. In the "Voice Response Debugging Window", I was able to type texts, or load a pre-recorded waveform audio as input. But I wasn't able to use "start recording" button feature to capture the audio stream I speak to the system. When I speak to the system, the "submit" button never got enabled. Is there something I was missing?

    2. MSS is able to change languages. But does anyone know how to change speaker voices? For example, US English Language pack comes with a female voice (Jill) and a male voice (Tom). When i go to VS2005 Options->Speech Application SDK ->Languages and Speech Engines, and change the voice from Jill to Tom. It still always uses Jill voice.

    My MMS is installed under Vista, and have no idea if we have the same two problems in Windows Server2003.

    Thanks in advance
    Thursday, March 20, 2008 3:15 PM

All replies

  • 1. Is your microphone properly configured?

     

    2. You can specify the prefered voice in SSML via the voice tag (http://www.w3.org/TR/speech-synthesis/#S3.2.1). You can also use the StartVoice and EndVoice methods on the PromptBuilder object for the prompt you want to change the voice on.

     

    Friday, March 21, 2008 12:03 AM
  • Ahmed, thank you for your reply.

    1. Yes. But it still doesn't work. I am sure the mic works fine with Windows Sound Recorder. But is there any additional things that I need to do for MSS configuration? or under VS 2005?

     

    2. Yes. things got solved.

     

    Thanks

    Jie

    Friday, March 21, 2008 2:13 PM
  • Are you saying that the start recording button is disabled or when you click the button the submit button isn't enabled?

     

    If it's the latter it's because when you click start recording, the aduio is being streamed to the engine in real time so it's being submitted as you speak.

    Tuesday, March 25, 2008 12:10 AM