locked
Slow loading forms and aspx pages RRS feed

  • Question

  • Internally, CRM 4.0 deployed, and everything runs fast on my computer and some other users' computers.
    However, for some users, it takes forever to load aspx pages, and forms load even slower, sometimes takes like 30 seconds to open a form.
    I never had this issue on my computer, and I'm assuming this is problem on their local machines. However, this is happening on several of them.
    I tried adding crm to trusted sites in intranet zone. I unchecked protected mode on all zones (they are all vista users).
    I even reduced some privileges on their security role so it can be a little faster.

    The speed improved a bit, but still seems unusually slow at times.
    Outlook speed is ridiculously slow, and I'm just trying to fix the speed on the browser for now.
    Any ideas what could be causing this?

    Much appreciated.
    Monday, August 24, 2009 7:58 PM

Answers

  • Donna, What do you mean by IE settings for 'Checking for New Pages is set to Automatic'? Where do you set this?

    Go to Tools, Internet Options, and Settings on the General tab.  You'll find the option listed on that page. 
    Best Regards, Donna
    Wednesday, August 26, 2009 12:25 PM

All replies

  • Speed can be negatively affected by third-party toolbars, such as google, yahoo, or even Microsoft tooolbars.  Turn off any extra toolbars and other IE add-ons, clear your temporary internet files, and see if that helps.
    Monday, August 24, 2009 8:43 PM
    Moderator
  • In addition to Joel's list, here are a few more items to check:

    ensure Virus protection is not scanning the CRM Web pages on those user's machine
    IE settings for Checking for New Pages is set to Automatic and not everytime the user hits the page and the file size is within the recommended limits like (250 mb)

    For Outlook, look at their ost file size, if it is large it will slow things down considerably.  You can also check their Sync folders to see if there are unresolved issues.  Do the users have enough RAM to run the programs they are running?  Depending on what they are doing, you might need a 1 or 2 gb.

    There are also some performance enhancements in Update Rollup 5 so you may want to consider installing the Update if you have not already.


    Best Regards, Donna
    Monday, August 24, 2009 8:59 PM
  • Have you installed RU5 and cleared your IE cache yet?  RU5 has a few significant form tweaks in it that fix form loading times.

    http://blogs.msdn.com/crm/archive/2009/07/22/microsoft-dynamics-crm-customized-entity-form-performance.aspx

    || Aaron Elder - Dynamics CRM MVP || http://www.ascentium.com/blog/crm
    Tuesday, August 25, 2009 5:16 PM
  • Thank you for the responses.
    I know that google toolbar conflicts with CRM for Outlook, (or at least it used to), and also cleared temp files every time my users asked me for help.
    This could be a problem with our network too.
    Donna, What do you mean by IE settings for 'Checking for New Pages is set to Automatic'? Where do you set this?

    I also tried Update Rollup 5, but no luck there...

    Thanks again for suggestions!
    Tuesday, August 25, 2009 11:19 PM
  • Donna, What do you mean by IE settings for 'Checking for New Pages is set to Automatic'? Where do you set this?

    Go to Tools, Internet Options, and Settings on the General tab.  You'll find the option listed on that page. 
    Best Regards, Donna
    Wednesday, August 26, 2009 12:25 PM