locked
SyncToy 2.1 (upgraded) goes haywire, CPU seems ready to melt down RRS feed

  • Question

  • SyncToy 2.1 goes haywire, driving CPU usage to 100% and triggering the CPU cooling fan to run like crazy until I shut SyncToy down.

    I upgraded from 2.0 yesterday. Right before installing 2.1 I ran all folder pairs, not just once but twice. I did the 2.1 install. Then I ran all folder pairs. Watching the pathnames on the status line, I noticed that it had stopped on one path. Then the CPU fan came on. Then the CPU fan started running like crazy - very loud. Not being used to the sound, it took me several moments to figure out what the sound really was. To confirm, I hit CTRL-Alt-Del - and CPU usage was at a solid 100%! I freaked out and stopped SyncToy. The CPU fan stopped within a second afterwards.

    Tried again, same scenario. SyncToy seemed to pause at various folders, all the while the CPU fan ran louder and louder until it hit top speed. CPU usage confirmed at 100%. I shut it down.

    Tried it again, same scenario.

    A little voice was telling me I shouldn't upgrade so soon after the release, but I didn't listen. I don't want my CPU to melt, so I'm giving up on this thing and trying to figure out how to downgrade back to 2.0. Is it possible?

    I have an HP m7367c desktop with a Pentium D CPU at 3 GHz with 4GB RAM. I'm running XP Media Center Edition Version 2002, Service Pack 3. The drives involved are internal SATA-150s, syncing to external USB drives. I'm not syncing the whole drives, just some top level folders.
    Sunday, November 15, 2009 6:33 PM

All replies

  • More testing:

    I tried again, with a single folder pair instead of Run all. Same result: Got to a certain folder (with only two files in it), paused there, CPU fan went crazy. Tried with a different pair. Same result.

    Deteled the first pair and recreated it. Same result.

    I was doing a "synchronize." Tried it again with "echo" and "contribute" - same result.

    I am definitely going to uninstall
    Sunday, November 15, 2009 9:27 PM
  • I removed SyncToy 2.1 in the following order (all x86):
      SyncToy 2.1
      Microsoft Sync Framework 2.0 Provider Services
      Microsoft Sync Framework 2.0 Core Components
      Microsoft Sync Framework Services v1.0
      Microsoft Sync Framework Runtime v1.0

    When I got to the last one, the progress bar froze at 85%, and the CPU fan was running medium. CPU usage averaged 53%. I killed the process. It still disappear from Add/Remove list. Am now going to reboot.
    Sunday, November 15, 2009 10:06 PM
  • Being a glutton for punishment, I reinstalled 2.1 (without first installing 2.0). Interestingly, the folder pairs I had set up previously still appeared.

    When I ran the first folder pair, it hung on the same folder as before, but CPU did not go beyond 54%. I waited a minute or two and stopped the scan.

    When I ran the next folder pair, CPU usage climbed quickly to 100%, the CPU fan went on full speed, it seemed to hang on a certain folder.  I stopped the scan.

    I give up on 2.1 and will uninstall it again.

    I may reinstall 2.0. Maybe, maybe not.
    Sunday, November 15, 2009 10:25 PM
  • I have uninstalled 2.1, rebooted, and installed 2.0. Having same problems. I guess that's the end of my relationship with SyncToy in any way, shape, or form.

    It goes to show, "If it ain't broke, don't fix it."
    Sunday, November 15, 2009 10:41 PM
  • Hi Michael,
        With your description, I think the problem is there are some special folder/files, which SyncToy will hang on it while doing sync, we never met this before. Did you synced folders which may have files being used? Even no, would you please help to take a look when you run preview and watching the preview UI, see the info at the bottom of Preview UI, what files is scaning when the hang up happening? This will help me narrow down your problem.

    For "the folder pairs I had set up previously still appeared", it is by design for users' convenient after upgrade or reinstall, if you want to clear it, you can go to
    C:\Users\[useraccount]\AppData\Local\Microsoft\SyncToy\2.0, delete SyncToyDirPairs.bin and all of the other files.

    Thanks,
    Ping
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, November 19, 2009 3:20 AM
  • I had nothing else running, no other windows. I had five different folder pairs, each a complex directory tree. I did a Run All under 2.0. Then I upgraded and did a Run All under 2.1, and started seeing problems. After having it hang during the Run All, I started running each folder pair individually. It hung on the first pair at the same point. I shut the process down, then restarted on the second pair. It eventually hung again. I am not anxious to overheat my machine in order to get a full list of the problem folders.

    But I DO remember the path where it hung on the FIRST folder pair.

    Now that I look at it - it happens to be (alphabetically) the LAST folder at the second level within in the LAST folder at the first level below the root of the folder pair. The folder contains nothing more than two photoshop files, which haven't been edited in a long time. But if the algorithm is to go through the folders alphabetically, this particular folder would have been the last one checked during the compare phase. That suggests to me that it might have completed the compare phase, and had entered some kind of compute-intensive phase -- but had given me no indication of the new phase on the status line. I was seeing only a static "Comparing" and the pathname. When this compute phase took so long (and heated up my processor), I assumed the machine was hung. (It may have been hung or not -- I am just speculating the possibilities.)

    It was VERY alarming to have the CPU fan loudly go full blast while nothing is happening -- confirmed by 100% metered usage. VERY alarming.

    It would seem that you have a separate user input task (waiting on the cancel button) scheduled at a higher priority than the main task. I was able to Cancel even though the processor was racing.

    If the second phase is indeed compute-intensive, may there should be a limit of say 50% of CPU on the main task, to leave some headroom and prevent overheating.

    I hope this helps.

    Thursday, November 19, 2009 6:02 AM
  • I'm running Windows Vista Ultimate 64bit on a Core i7 920 with 12GB of DDR3 low latency RAM and using SyncToy 2.0 64Bit. The motherboard is an EVGA X58 SLI. I am copying my data from multiple internal SATA drives to one external eSATA drive. All are connected using the AHCI protocol for maximum performance. SyncToy 2.0 currently is peaking at about 2.5GB of RAM for this transfer. It has slowly ramped up through the copy of 6GB of data. It averages around 1.5GB - 2.0GB of RAM.

    I have always had the issue of my CPU being maxed out when moving a large amount of data using SyncToy 2.0. This happened on my old system (WinXP Pro SP3 32bit) as well which had a Core2Duo CPU. I am currently at copying 17,070 files and appear to be about 80% done.

    The directory that I am backing up is a standalone directory on a different drive. Specifically it is my Steam games directory.

    This also happens when I back up another drive that is 100% data. I exclude the recycle bin and the System Volume Information directories so there are no files whatsoever to be locked. I also get no errors when copying the files. I can do a full defrag on the drive using either Windows defrag or Raxco Perfectdisk without any complaints about files being locked.

    Strangely this does not happen when using WinSCP's command line options to initiate an rsync session with my FreeNAS box. It is essentially the same thing as SyncToy 2.0, but for network backup.
    Friday, November 20, 2009 3:31 AM
  • Where I said "Comparing..." in the above post, I actually meant "Looking for changes in...".

    I reinstalled 2.1 and tried a Sync on a the Documents and Settings folder. CPU was all over the board. About midway through the "Looking for changes" phase I had to hold my breath as CPU hit 100% and the fan kicked in full blast for about a minute. But I stuck it out. It seemed to me that the "Copying" phase was much slower than when I was running 2.0.
    Saturday, November 21, 2009 3:32 AM
  • Updated information for my post above.

    Some usage statistics:

    3,142,444 K RAM Max
    Idled at 2,673,508 RAM
    6GB of data transferred
    20,000 files or so

    ========================================

    From a fresh start
    28,168 K RAM
    delete 32 folders
    delete 614 files
    overwrite 465 files
    rename 0 files
    new 142
    create folder 31

    Maxed out CPU just after pressing the run button.
    RAM is at 3,834,496 at peak and at end of run.
    CPU continues to run after sync is complete.

    Memory returned to 93,972K when sync was done.

    ========================================

    From a fresh start
    Delete 3 folders
    delete 61 files
    overwrite 280 files
    rename 1
    new 967
    create folder 181

    CPU maxed out when starting to copy files. CPU usage went down after a large 13GB file started to transfer.
    Memory usage right now is 51,484 K
    Memory never went over 56,388 K
    Ended sync at 55,032 K
    Closed sync window and now uses 54,964 K

    UAC is on. DAP is on for all programs and windows components.

    One core of my 8 is often used when doing a preview.

    My guess is that SyncToy abuses the CPU when copying multiple files. It appears to have no issue when copying one huge file.

    I will say that it appears to be very multi-thread aware.
    Sunday, November 22, 2009 4:13 AM
  • Hello,

    I am having similar issues.  SyncToy 2.1 running on Windows Vista Ultimate, synching from the local hard disk onto a WD Passport USB hard drive.  In about 25% of synchronisation episodes, SyncToy hangs during the file transfer stage.

    As far as CPU is concerned, SyncToy ALWAYS drives the CPU at !00% utilisation (fan on full) during the file transfer stage, AND CONTINUES TO DO SO on completion until the application is closed.

    Wednesday, May 5, 2010 9:04 PM
  • >Got to a certain folder (with only two files in it), paused there, CPU fan went crazy.

    Same here. XP + ST 2.1. The remote drive is a WD 1To ethernet NAS. Moreover, ST, after long hours of doing nothing else than moving at the speed of a snail, proposes hundred of updates of never-changing files. It's crazy and not useable.


    Schneider Electric Industries France
    Saturday, June 26, 2010 8:53 PM
  • By MHO SyncToy has flaw in multithreading. To avoid the problem of 99% CPU load and 15 GB of ram used ( in my case on i7 with 16 Gb of ram ) just start Task Manager, go to the process, right-click and Set Affinity, give the process no more then two cores - lets say CPU 0 and CPU 1 - and everything will calm down to normal.

    I use SyncToy for half an year and I am happy with it. This is the only minor glitch. I sync two of my laptop HDDs to external HDD during work and have no problem - more then 300 GB of information.
    • Proposed as answer by Ognyan Saturday, February 16, 2013 1:18 PM
    Saturday, February 16, 2013 1:17 PM