none
WHS stopped accepting RDP after installing Visual C++ Express 2008 :( RRS feed

  • Question

  • Hi all!

    I was bored at work yesterday and wanted to try a quick code change on a personal programming project. We aren't supposed to install that on the work computer so I remote desktoped to the Windows Home Server box to install Visual C++ Express 2008.  In the middle of setup, Remote Desktop screen went blank, followed by a disconnect. I went home and couldn't remote desktoped in either. Connected a monitor to the home server and it seems to be working fine. Gave it a reboot and it still won't let remote desktops thru.

    I looked at the event viewer - nothing about Remote Desktop seems to be there.
    I looked at the system services - the three RDP were on manual. I tried to manually start those but I still can't Remote Desktop to it.
    I uninstalled Visual C++ and the MS SQL 2008 stuff that it installed, no luck.
    I checked the Windows firewall - RDP is in the Exceptions list
    I checked the Home Server Console - the router is set up and the web stuff works
    I checked the router (Linksys WRT54G) - it's still giving the usual IP address  (192.168.1.100) to the home server and none of the rules got changed.

    Anyone know what I might be able to try?
    -Dat
    Tuesday, February 17, 2009 3:23 PM

Answers

  • You should be able to use the server reinstallation mode of Windows Home Server setup to avoid data loss.
    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by kariya21Moderator Thursday, February 19, 2009 4:22 AM
    • Marked as answer by DatAsian Thursday, February 19, 2009 3:06 PM
    Wednesday, February 18, 2009 12:41 PM
    Moderator

All replies

  • I would take a look at the Terminal Services Configuration Manager: Start/Control Panel/Administrative Tools/Terminal Services Configuration. It's possible that somehow the installation of Visual Studio changed something here. I'm travelling and without desktop access to WHS, but most likely someone here will be able to help if you need to tweak something.

    Probably the simplest answer overall is just remembering that WHS is not a desktop operating system. :)

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, February 17, 2009 3:56 PM
    Moderator
  • Hi,
    maybe you run into the same problem, which other people experienced with NVidia video drivers.
    If so, the solution provided in this thread could help you.
    Best greetings from Germany
    Olaf
    Tuesday, February 17, 2009 6:34 PM
    Moderator
  • I tried the registry key and it did not do anything yet. I also checked the Termal Services Configuration and Manager utilties but it seems to be ok. I may have to look into backing up the data and reformatting

    -Dat
    Wednesday, February 18, 2009 7:11 AM
  • You should be able to use the server reinstallation mode of Windows Home Server setup to avoid data loss.
    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by kariya21Moderator Thursday, February 19, 2009 4:22 AM
    • Marked as answer by DatAsian Thursday, February 19, 2009 3:06 PM
    Wednesday, February 18, 2009 12:41 PM
    Moderator
  • The server reinstallation did the trick. It just took a really good deal of time. Thanks :)
    -Dat
    Thursday, February 19, 2009 3:06 PM