locked
Changing Ports on WHS2011 RRS feed

  • Question

  • Hi All,

    I have yet to find an solution to this problem.  I've searched everywhere on the net (including this forum) and have tried many instructions with no success. I have WHS2011 server sitting on my network, along with another server running Microsoft Small Business Server 2008.  Given both servers use the same SSL port (443) for remote access, I'd like to configure the WHS2011 to use a custom port, like 4443, for SSL remote access.  I tried changing the SSL port in IIS under binding properties, etc., with no success.  Also tried configuring my Sonicwall router to Port Forward 4443 to 443 to the WHS2011 ip address, but remote access via webpage and Windows Phone Connector still does not.  Also tried entering the url as https://customename.homeserver.com:4443 with no success.

    Is there a proper, working solution to this problem?  Kindly advise, thank you!

    Ringo

    Friday, October 21, 2011 4:21 PM

All replies

  • There's certainly no supported way to change the ports used by your server, and I'm pretty sure that it's not possible at all with the current version. In the case of the Windows Phone 7 connector, the ports used are hardwired into the phone app; in the case of the remote access features of the server, they're wired into the web applications that Microsoft has provided. As a result, changing the ports in IIS manager won't have the desired effect.

    If you're using SBS, why do you need Windows Home Server's remote access as well?


    I'm not on the WHS team, I just post a lot. :)
    Friday, October 21, 2011 5:51 PM
    Moderator
  • Hi Ken,

    Thank you for the response. I use both SBS and Home Server for different purposes.  For Home Server, I love the phone app as well as remote access webpage to all my media files. SBS does not have this feature, but does have MS Exchange and Sharepoint which I love (and which Home Server doesnt have).  I guess I will try messing with SBS's port settings and keep Home Server in default mode.

    Thanks again,

    Ringo

    Saturday, October 22, 2011 11:13 AM