locked
How do i change the Bindings in crm 2011 using C# API RRS feed

  • Question

  • Hey guys, can any one tell me how do i change the below settings using CRM 2011 SDK API??

    Thursday, January 3, 2013 5:08 AM

Answers

  • actually when passing the external domain url  you need to start with https:// , unlike others which directly start with hostname.domain.com

    this thing is nowhere documented on the internet, atleast i didnt find it. I faced this issue earlier.

    Hope this helps, remember the url of external domain should be like https://hostname.domain.com

    • Marked as answer by SyedHaroon Tuesday, April 16, 2013 9:38 AM
    Tuesday, April 16, 2013 9:37 AM

All replies

  • Hi,

    Check the class ServerConnection and take a look in this microsoft article:

    http://msdn.microsoft.com/en-us/library/gg309393.aspx

    Hope this helps.

    If i answered your question, please mark the response as an answer and also vote as helpful.


    Pedro Azevedo Crm Specialist 4.0\2011

    Thursday, January 3, 2013 9:39 AM
  • I don't think the ServerConnection class will help. Instead, you'll need to use the DeploymentService and probably the IfdSettings

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Thursday, January 3, 2013 5:04 PM
    Moderator
  • hey can you help me out here 

    after configuring the CRM Server for Claims based Authentication, im running the follwing code..  it executes but it doesn't add the  external url and after i run this command im not even able to manually enter teh external url since teh next button is disabled.. am i missing any thing??

     IfdSettings ifdSettings = new IfdSettings();
                    ifdSettings.Enabled = true;
                    ifdSettings.IntranetAccessEnabled = true;
                    ifdSettings.WebApplicationRootDomain = "" + shortDomain + ":444";
                    ifdSettings.OrganizationWebServiceRootDomain = "" + shortDomain + ":444";
                    ifdSettings.DiscoveryWebServiceRootDomain = "" + shortHostName + "dev." + shortDomain + ":444";
                    ifdSettings.ExternalDomain = "" + shortHostName + "auth." + shortDomain + ":444";
                    service.Update(ifdSettings);

    Friday, January 4, 2013 8:45 AM
  • actually when passing the external domain url  you need to start with https:// , unlike others which directly start with hostname.domain.com

    this thing is nowhere documented on the internet, atleast i didnt find it. I faced this issue earlier.

    Hope this helps, remember the url of external domain should be like https://hostname.domain.com

    • Marked as answer by SyedHaroon Tuesday, April 16, 2013 9:38 AM
    Tuesday, April 16, 2013 9:37 AM
  • Thanks blue.. that is what all i needed.
    Tuesday, April 16, 2013 9:39 AM