none
Package not compatible with netcoreapp RRS feed

  • Question

  • I recently installed Visual Studio 2017. I migrated the existing project which created in Visual Studio 2015. It got migrated without any errors. But when I build the solution I get 100+ errors stating Package Microsoft.AspNetCore.... is not compatible with netcoreapp...

    There are more than 100 items listed like this. I tried renaming the sdk value global.json, removing sdk value in global.json, repair, uninstall & reinstalling Visual Studio 2017. But none of them work.

    The same project was working fine in Visual Studio 2015. All issues started after migrating to Visual Studio 2017.

    Please let me know how to fix this?

    • Moved by 宝宝徐 Wednesday, May 3, 2017 2:57 AM
    Friday, April 28, 2017 7:49 PM

All replies

  • Hi Lohi1611,

    Thank you for posting in MSDN forum.

    This forum is about .Net Framework Setup and Servicing, from your description, this issue is much related to the project migrating, I suggest you could post in

    https://forums.asp.net/1255.aspx/1?ASP+NET+Core to get a better professional support.

    Thank you for your understanding and cooperation.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    • Edited by 宝宝徐 Tuesday, May 2, 2017 6:12 AM
    Tuesday, May 2, 2017 6:11 AM