locked
SharePoint CRM Web Part - Error On Page RRS feed

  • Question

  • Hi,

    I have CRM running from within a Web Part in SharePoint. When I click on links within CRM (in the web part) I get an error in the bottom left hand starus bar of the browser - 'Error On Page', as a result the CRM links do not work. When I navigate off the SharePoint page I get a CRM 'Microsoft Dynamic CRM has Encountered a problem' - clicking on the 'View the data what will be sent to Microsoft' on the error dialog gives me the Error Message below.

    If I use CRM 'standalone', that is navigate directly to the CRM link and not through a SharePoint a web part, the links withing CRM work fine and give no errors.

    System Info: CRM Version: 4.0.7333.3, Sharepoint: 2007 (3), Windows Server 2003 R2 (Service Pack 2), Internet Explorer: 7.0.5730.13

    Any help would be great, Many thanks!

    Thomas

    ______________________________________________________

    ************* Error Message *****************:

    Microsoft Dynamics CRM Error Report Contents

    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
     <Message>&#39;top.stage.location&#39; is null or not an object</Message>
     <Line>290</Line>
     <URL>/TestProject&#47;_root&#47;left.aspx&#63;area&#61;Workplace&#38;group&#61;MyWork&#38;subarea&#61;nav_activities</URL>
     <PageURL>/TestProject&#47;_root&#47;left.aspx&#63;area&#61;Workplace&#38;group&#61;MyWork&#38;subarea&#61;nav_activities</PageURL>
     <Function>loadHomePage&#40;sAreaId, sGroupId, sSubAreaId&#41;</Function>
     <CallStack>
       <Function>loadHomePage&#40;sAreaId, sGroupId, sSubAreaId&#41;</Function>
     </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
     <BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.2&#59; .NET CLR 1.1.4322&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.648&#59; .NET CLR 3.5.21022&#41;</BrowserUserAgent>
     <BrowserLanguage>en-us</BrowserLanguage>
     <SystemLanguage>en-us</SystemLanguage>
     <UserLanguage>en-us</UserLanguage>
     <ScreenResolution>1280x1024</ScreenResolution>
     <ClientName>Web</ClientName>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>6153</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>6153</UserCulture>
        <OrgID>&#123;A63EA1F8-6F17-4957-A4B9-5C2E5C79F405&#125;</OrgID>
        <UserID>&#123;49984B07-F3A3-E111-A444-005056840028&#125;</UserID>
        <CRMVersion>4.0.7333.3</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>

    <CrmScriptErrorReport>
      <ReportVersion>1.0</ReportVersion>
      <ScriptErrorDetails>
     <Message>&#39;top.stage.location&#39; is null or not an object</Message>
     <Line>290</Line>
     <URL>/TestProject&#47;_root&#47;left.aspx&#63;area&#61;Workplace&#38;group&#61;MyWork&#38;subarea&#61;nav_activities</URL>
     <PageURL>/TestProject&#47;_root&#47;left.aspx&#63;area&#61;Workplace&#38;group&#61;MyWork&#38;subarea&#61;nav_activities</PageURL>
     <Function>loadHomePage&#40;sAreaId, sGroupId, sSubAreaId&#41;</Function>
     <CallStack>
       <Function>loadHomePage&#40;sAreaId, sGroupId, sSubAreaId&#41;</Function>
     </CallStack>
      </ScriptErrorDetails>
      <ClientInformation>
     <BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.2&#59; .NET CLR 1.1.4322&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.648&#59; .NET CLR 3.5.21022&#41;</BrowserUserAgent>
     <BrowserLanguage>en-us</BrowserLanguage>
     <SystemLanguage>en-us</SystemLanguage>
     <UserLanguage>en-us</UserLanguage>
     <ScreenResolution>1280x1024</ScreenResolution>
     <ClientName>Web</ClientName>
      </ClientInformation>
      <ServerInformation>
        <OrgLanguage>1033</OrgLanguage>
        <OrgCulture>6153</OrgCulture>
        <UserLanguage>1033</UserLanguage>
        <UserCulture>6153</UserCulture>
        <OrgID>&#123;A63EA1F8-6F17-4957-A4B9-5C2E5C79F405&#125;</OrgID>
        <UserID>&#123;49984B07-F3A3-E111-A444-005056840028&#125;</UserID>
        <CRMVersion>4.0.7333.3</CRMVersion>
      </ServerInformation>
    </CrmScriptErrorReport>

     

    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    Monday, May 28, 2012 4:15 PM