locked
Office Communications Server Evaluation *No Management Console* *Unable to enable users* RRS feed

  • Question

  • thank you for your time.

    hardware:
    HP 64BIT machine/4GIGS RAM

    software:
    Windows Server 2008 Standard Edition 64BIT

    Roles: Domain Controller
    DHCP
    IIS7

    Exchange 2007 SP1 64BIT

    Action:
    Installed Office Communications Server 2007 64BIT executable downloaded from Microsoft.com download section. The MSI is a (1) file executable. You open the executable and it installs with little to no questions or options. No errors reported after installation. Server rebooted after software installation.

    Alpha testing Office Communications server on this newly formatted machine. Installed all software new and fresh from server 08 to exchange 07 SP1.

    Now that OCS is installed we cannot figure out how to access the management console to ADD or enable users. We mouse over to administration and then AD users and RIGHT CLICK a user but there is no option to enable users for OCS. In administrative tools there is no option or selection for OCS console. We have looked everywhere and cannot find where to configure and administer OCS 2007.

    Some documents are indicating OCS management console is not included in standard installation and it needs to be added after intial OCS installation. But the evaluation is a single EXE installer and reopening it after install does not give us any options for installing additional tools or software.

    And why would MS not include a management console to configure and admin OCS by default?

    A couple posts mention you have to run AD users snapin/console, DSA.msc with a -32 switch... which sounds very odd since my SERVER OS is 64BIT and OCS is 64BIT.

    please shed some light on the subject
    Tuesday, March 17, 2009 10:20 PM

All replies

  • Starting with R2 you'll need to install the OCS Management console manually, see this blog post for more details:
    http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=54

    The discussions you've read about the 32-bit switch were applicable to the original OCS 2007 release which was 32-bit only, R2 is 64-bit only and you'll just need to install the package.  Once installed you can enable users in either the console or by using the Communications tab found in ADUC (on the same machine with the console installed).


    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Tuesday, March 17, 2009 10:29 PM
    Moderator
  • Thank you for your help. Sometimes it feels like when it comes to alpha or beta testing a product from microsoft your on your own.

    I actually found the blog your referring to but we cannot access the mentioned 'R2 Deployment Wizard and choose the Administrative Tools task on the right hand side'.

    Where is this R2 deployment wizard? All we have is the single EXE file which is the OCS R2 which was downloaded from MS here:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=67A3DE72-7DBD-4E0B-92A5-29D0B46009A7&DisplayLang=en

    In the blog there is a screenshot from OCS and we have not seen this screen..... we ran the OCS server installer and it installed without splash screens, options or errors.

    And in the blog it mentions directories where these admin tools may;

    \Setup\amd64\Setup\admintools.msi

    But this appears as directories on the CD/DVD installer of OCS R2... and NOT our downloaded single EXE file.

    Please help
    Tuesday, March 17, 2009 10:43 PM
  • OK!

    In waiting I searched the server for all 'AdminTools' files. And then I found my OCS local install directory.

    Tried to run both 'AdminTools'

    (1) said it was for 32 bit systems only..
    (1) said it required COREOCS files to be ran first.

    So I browsed around and found DEPLOYWIZ or something names similar and BANG! The wizard page loaded up.... then I selected 'Administrative Tools' then ERROR.

    Error says it needed C++ redistributed installed, and I selected another file that prompted me earlier to install C++, so I ran that file again, which triggered C++ installation. Ok, game on.

    ERROR.... it says it needs .NET 3.5 installed, so it asks to install. Ok, game on.

    Says it installing.... will update with progress.

    Arrrg. I dont know if it's us but this wizard DID NOT POP up when installing OCS... and the console should automatically install on the local machine you install OCS on by default... even if you admin from another box.... this is rather frustrating
    Tuesday, March 17, 2009 10:53 PM
  • Ok.... after pulling up the wizard it has come to our attention we should have used this wizard first before installing the actual OCS R2 application... appears there is much setup to complete before actually installing the server application..

    We are disappointed the single EXE did not execute to the Wizard but rather the OCS core installation directly..

    We are continuing down the checklists and steps in the wizard... but we have a feeling the install and data may not work or there will be conflicts due to the installation steps not being completed in order..standby
    Wednesday, March 18, 2009 12:02 AM
  • Hi there,

    Sorry - i too have this issue.

    Our 2007 R2 was a migration from standard OCS 2007.  so the current users stayed put.

    I have however had to reinstall and now have no users enabled - and no way to enable users.

    OCS 2007 R2 says there are 0 users in the database.

    AD Users & Computers has no task options for enabling OCS.

    The OCS 2007 R2 console - shows users and unassigned users as empty.

    what gives?


    IT Manager
    Tuesday, May 26, 2009 12:42 AM
  • Hi Kyle,

    Not sure how you migrated from RTM to R2, but the normal process is to install R2 on a separate server (is 64-bit and RTM was 32-bit) and move users. In order to admin the R2 system (and the users) you need to have domain admin tools (i.e. dsa.msc / AD domain services tools) installed on the OCS 2007 R2 server (or any 64-bit admin machine) before installing the admintools.msi from the OCS setup\amd64\setup directory (or from deployse.exe/deployee.exe), as it extends AD Users and Computers to have the extra OCS tabs and right-click menu options. Or the admintools.msi from the support\i386 directory can be installed on a 32-bit machine, again with the Domain services tools already loaded.

    If you don't have the CD, when you run the file you have downloaded, it extracts onto your harddrive so you should have the same file structure.

    Hope this helps - if not, give us a bit more info on what you've done so far, what is installed on what machine and in which order and we'll try to help! :-)

    Cheers,
    Tim
    Tuesday, May 26, 2009 10:18 AM