locked
Security resets on reboot RRS feed

  • Question

  • Everytime I have to reboot the server the security on the shared folders changes. I have to log on to the server as admin, open each shared folder, go to properties, security tab, advanced button, check the two checkboxes to copy security settings to decendents. 
    Why do I have to do this every time? How can I maintain the prefered level of security without having to have it reset? Thanks!
    Wednesday, October 15, 2008 5:20 AM

Answers

  • Wingnet said:

    I mean I can't use the shared folders - I get message (for example) "Windows cannot access \\SERVER\shares\Music. Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve the problem, click Diagnose."


    When I open Diagnose it says "You do not have permission to access the file "\\SERVER\shares\Music". Ask the server administrator to give you permission to access the file "\\SERVER\shares\Music".

    When I further click it shows the console setting possibilities, however I have already given full control to everyone. So what am I missing here?

    Thanks!




    It sounds to me like the username and password on your client don't match what's on the server.  It's possible the user friendly name and the actual logon names are different (which would make it appear like the names are the same when in fact, they aren't).  Please read Ken's FAQ post regarding this issue and see if it helps.
    • Marked as answer by Wingnet Thursday, October 16, 2008 4:43 AM
    Thursday, October 16, 2008 4:08 AM
    Moderator

All replies

  • Hello,
    you should not set the security in the file system, since it does not truly reflect the underlying files and folders, which may be spread over multiple drives and are only marked by tombstones on D:\shares. Security settings are to be done in the Windows Home Server Console on the Shared Folders section. Double click the shared folder you wish to alter the security and change the user permissions on the related tab as needed.

    Best greetings from Germany
    Olaf
    Wednesday, October 15, 2008 6:37 AM
    Moderator
  • Thanks for the answer Olaf. 

    My problem is that when I go into the Console as you say I give full user access to all users except Guest.  When I logon to my PC I use the same userid and password as one with full access. Nevertheless my security is still taken away. Is there something else I need to do? 

    -John
    Thursday, October 16, 2008 1:48 AM
  • Wingnet said:

    Thanks for the answer Olaf. 


    My problem is that when I go into the Console as you say I give full user access to all users except Guest.  When I logon to my PC I use the same userid and password as one with full access. Nevertheless my security is still taken away. Is there something else I need to do? 

    -John




    When you say it's "still taken away", what do you mean exactly?  Are you getting an error message when you try to connect to the shares?  If so, exactly what does it say?
    Thursday, October 16, 2008 2:05 AM
    Moderator
  • I mean I can't use the shared folders - I get message (for example) "Windows cannot access \\SERVER\shares\Music. Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve the problem, click Diagnose."

    When I open Diagnose it says "You do not have permission to access the file "\\SERVER\shares\Music". Ask the server administrator to give you permission to access the file "\\SERVER\shares\Music".

    When I further click it shows the console setting possibilities, however I have already given full control to everyone. So what am I missing here?

    Thanks!


    Thursday, October 16, 2008 3:43 AM
  • Wingnet said:

    I mean I can't use the shared folders - I get message (for example) "Windows cannot access \\SERVER\shares\Music. Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve the problem, click Diagnose."


    When I open Diagnose it says "You do not have permission to access the file "\\SERVER\shares\Music". Ask the server administrator to give you permission to access the file "\\SERVER\shares\Music".

    When I further click it shows the console setting possibilities, however I have already given full control to everyone. So what am I missing here?

    Thanks!




    It sounds to me like the username and password on your client don't match what's on the server.  It's possible the user friendly name and the actual logon names are different (which would make it appear like the names are the same when in fact, they aren't).  Please read Ken's FAQ post regarding this issue and see if it helps.
    • Marked as answer by Wingnet Thursday, October 16, 2008 4:43 AM
    Thursday, October 16, 2008 4:08 AM
    Moderator
  • Kariya -
    You've helped me again. I thought I did this long ago but there was a difference between my user name and display name. Every thing that never quite worked now works like a charm! Ken's note is concise and helpful.

    Many thanks!

    Thursday, October 16, 2008 4:43 AM