none
HpcPortal doesn't work after enabling

    Question

  • There was an error when running the install script:

    PS C:\Program Files\Microsoft HPC Pack 2016\Bin> Set-HPCWebPortal.ps1 -enable -Certificate $thumb
    No port was specified. Port 443 will be used.
    Installation of IIS is in progress...
    Allowing the Microsoft HPC Pack Web Portal to use different authentication to the remainder of IIS
    Unlocking Anonymous, Basic, and Windows authentication
    Unlocked section "system.webServer/security/authentication/anonymousAuthentication" at configuration path "MACHINE/WEBROOT/APPHOST".
    Unlocked section "system.webServer/security/authentication/basicAuthentication" at configuration path "MACHINE/WEBROOT/APPHOST".
    Unlocked section "system.webServer/security/authentication/windowsAuthentication" at configuration path "MACHINE/WEBROOT/APPHOST".
    Installing the Microsoft HPC Web Portal in IIS
    APP object "Default Web Site/HpcPortal" added
    VDIR object "Default Web Site/HpcPortal" added
    Enabling port 443 bindings
    Enabling HTTPS only at the application level
    APP object "Default Web Site/HpcPortal" changed
    Requiring SSL for the application
    Applied configuration changes to section "system.webServer/security/access" for "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal" at configuration commit path "MACHINE/WEBROOT/APPHOST"
    Creating a new application pool
    APPPOOL object "HpcPortalAppPool" added
    Associating the network service identity to the application pool
    Applied configuration changes to section "system.applicationHost/applicationPools" for "MACHINE/WEBROOT/APPHOST" at configuration commit path "MACHINE/WEBROOT/APPHOST"
    Associating the application to the new application pool
    APP object "Default Web Site/HpcPortal" changed
    Remove Negotiate provider and use pure NTLM provider for windowsAuthentication
    
    ERROR ( message:Cannot find requested collection element. )
    
    Adding x-content-type-options:nosniff header
    Applied configuration changes to section "system.webServer/httpProtocol" for "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal" at configuration commit path "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal"
    Restarting IIS
    
    Attempting stop...
    Internet services successfully stopped
    Attempting start...
    Internet services successfully restarted

    Trying to access the portal then results in an authorization error.


    Looks like the authentication module, the .NET 4.6 module and the ASP.NET 4.6 modules/features all weren't enabled.


    
    • Edited by dhirschfeld Friday, January 12, 2018 5:18 AM
    Friday, January 12, 2018 5:12 AM

All replies

  • Note: These are the exact same issues I reported with the preview release

    https://social.microsoft.com/Forums/en-US/2b172640-534f-499b-ae6e-65554025af5a/microsoft-hpc-2016-update-1-preview-is-available?forum=windowshpcitpros


    Friday, January 12, 2018 5:21 AM
  • Hi,

    The error message

    ERROR ( message:Cannot find requested collection element. )

    is expected if you are not enabling HPCPortal for the first time. As negotiate provider is already removed in previous setup of HPCPortal, it can not be find in the collection returned any more.

    For the authorization error, how does the error look like? How do you access hpc portal?

    Thanks,
    Zihao

    Monday, January 15, 2018 5:10 AM
  • The error was observed when enabling the HpcPortal for the 1st time on a clean 2016 VM.

    I think the negotiate provider couldn't be removed because the Windows Authorisation *Feature* wasn't even installed.

    i.e. after running the script none of the below were installed.

    Web-Windows-Auth

    NET-Framework-45-ASPNET

    Web-Asp-Net45

    To get the portal to run I had to install the above WindowsFeatures.

    Monday, January 15, 2018 5:18 AM
  • Trying the dsim command manually (afterwards) results in an error:

    Deployment Image Servicing and Management tool
    Version: 10.0.14393.0

    Image Version: 10.0.14393.0

    Enabling feature(s)
    [==========================100.0%==========================]

    Error: 0x800f081f

    The source files could not be found.
    Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.

    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

    Looking at the log file I see the below errors:


    2018-01-15 15:57:50, Info                  DISM   DISM Package Manager: PID=9972 TID=9140 Initiating Changes on Package with values: 5, 7 - CDISMPackage::Internal_ChangePackageState
    2018-01-15 15:57:50, Info                  DISM   DISM Package Manager: PID=9972 TID=9140 CBS session options=0x40100! - CDISMPackageManager::Internal_Finalize
    2018-01-15 15:57:51, Info                  DISM   DISM Package Manager: PID=9972 TID=9828  Error in operation: source for package or file not found, ResolveSource() unsuccessful. (CBS HRESULT=0x800f081f) - CCbsConUIHandler::Error
    2018-01-15 15:57:51, Error                 DISM   DISM Package Manager: PID=9972 TID=9140 Failed finalizing changes. - CDISMPackageManager::Internal_Finalize(hr:0x800f081f)
    2018-01-15 15:57:51, Error                 DISM   DISM Package Manager: PID=9972 TID=9140 The source files could not be found; their location must be specified using the /source option to restore the feature. - GetCbsErrorMsg
    2018-01-15 15:57:51, Error                 DISM   DISM Package Manager: PID=9972 TID=9140 Failed processing package changes with session options - CDISMPackageManager::ProcessChangesWithOptions(hr:0x800f081f)
    2018-01-15 15:57:51, Error                 DISM   DISM Package Manager: PID=9972 TID=9140 Failed ProcessChanges. - CPackageManagerCLIHandler::Private_ProcessFeatureChange(hr:0x800f081f)
    2018-01-15 15:57:51, Error                 DISM   DISM Package Manager: PID=9972 TID=9140 Failed while processing command enable-feature. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x800f081f)
    2018-01-15 15:57:51, Info                  DISM   DISM Package Manager: PID=9972 TID=9140 Further logs for online package and feature related operations can be found at %WINDIR%\logs\CBS\cbs.log - CPackageManagerCLIHandler::ExecuteCmdLine

    I don't have internet access on the machine - is that something that is required?

    Monday, January 15, 2018 6:07 AM
  • Hi,

    This error should be no fatal. If the feature is not installed, it's OK to fail on removing it. But if you are interested please share the result of following powershell

    $FullSite= "'Default Web Site/HpcPortal'"
    Invoke-Expression "$Env:SystemRoot\system32\inetsrv\APPCMD.EXE list config $FullSite /section:windowsAuthentication"


    Also, the three windows feature should be installed during set-hpcwebportal. Here is what I get from a clean 2016 vm in Azure

    Windows PowerShell
    Copyright (C) 2016 Microsoft Corporation. All rights reserved.
    
    PS C:\Program Files\Microsoft HPC Pack 2016> Get-WindowsFeature -Name "Web-Windows-Auth","NET-Framework-45-ASPNET","Web-Asp-Net45"
    
    Display Name                                            Name                       Install State
    ------------                                            ----                       -------------
                [ ] Windows Authentication                  Web-Windows-Auth               Available
                [ ] ASP.NET 4.6                             Web-Asp-Net45                  Available
        [ ] ASP.NET 4.6                                     NET-Framework-45-ASPNET        Available
    
    
    PS C:\Program Files\Microsoft HPC Pack 2016> Set-HPCWebPortal.ps1 -enable
    No port was specified. Port 443 will be used.
    Installation of IIS is in progress...
    Allowing the Microsoft HPC Pack Web Portal to use different authentication to the remainder of IIS
    Unlocking Anonymous, Basic, and Windows authentication
    Unlocked section "system.webServer/security/authentication/anonymousAuthentication" at configuration path "MACHINE/WEBROOT/APPHOST".
    Unlocked section "system.webServer/security/authentication/basicAuthentication" at configuration path "MACHINE/WEBROOT/APPHOST".
    Unlocked section "system.webServer/security/authentication/windowsAuthentication" at configuration path "MACHINE/WEBROOT/APPHOST".
    Installing the Microsoft HPC Web Portal in IIS
    APP object "Default Web Site/HpcPortal" added
    VDIR object "Default Web Site/HpcPortal" added
    Enabling port 443 bindings
    Enabling HTTPS only at the application level
    APP object "Default Web Site/HpcPortal" changed
    Requiring SSL for the application
    Applied configuration changes to section "system.webServer/security/access" for "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal" at configuration commit path "MACHINE/WEBROOT/APPHOST"
    Creating a new application pool
    APPPOOL object "HpcPortalAppPool" added
    Associating the network service identity to the application pool
    Applied configuration changes to section "system.applicationHost/applicationPools" for "MACHINE/WEBROOT/APPHOST" at configuration commit path "MACHINE/WEBROOT/APPHOST"
    Associating the application to the new application pool
    APP object "Default Web Site/HpcPortal" changed
    Remove Negotiate provider and use pure NTLM provider for windowsAuthentication
    Applied configuration changes to section "system.webServer/security/authentication/windowsAuthentication" for "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal" at configuration commit path "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal"
    Adding x-content-type-options:nosniff header
    Applied configuration changes to section "system.webServer/httpProtocol" for "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal" at configuration commit path "MACHINE/WEBROOT/APPHOST/Default Web Site/HpcPortal"
    Restarting IIS
    
    Attempting stop...
    Internet services successfully stopped
    Attempting start...
    Internet services successfully restarted
    PS C:\Program Files\Microsoft HPC Pack 2016> Get-WindowsFeature -Name "Web-Windows-Auth","NET-Framework-45-ASPNET","Web-Asp-Net45"
    
    Display Name                                            Name                       Install State
    ------------                                            ----                       -------------
                [X] Windows Authentication                  Web-Windows-Auth               Installed
                [X] ASP.NET 4.6                             Web-Asp-Net45                  Installed
        [X] ASP.NET 4.6                                     NET-Framework-45-ASPNET        Installed
    
    
    PS C:\Program Files\Microsoft HPC Pack 2016>

    Maybe there is some error that fails the windows feature installation during set-hpcwebportal? May I ask did you run this script in an elevated window? Is there any error event log in the mean time?

    Thanks,
    Zihao


    Monday, January 15, 2018 6:23 AM
  • Hi,

    From the content of doc http://go.microsoft.com/fwlink/?LinkId=243077, yes you would need internet access for dism by default. If you need offline installation ability, the Source option can help you.

    Thanks,
    Zihao

    Monday, January 15, 2018 6:37 AM
  • Since not having internet access results in an almost silent failure and borked installation perhaps that requirement should be spelt out in the docs with a large DANGER admonition.

    Install/Add-WindowsFeature seems to work fine without internet access so maybe the script could also be updated to use those?

    Monday, January 15, 2018 10:56 PM
  • The result of

    $FullSite= "'Default Web Site/HpcPortal'"
    Invoke-Expression "$Env:SystemRoot\system32\inetsrv\APPCMD.EXE list config $FullSite /section:windowsAuthentication"

    is below:

    <system.webServer>
      <security>
        <authentication>
          <windowsAuthentication enabled="true" authPersistNonNTLM="true">
            <providers>
              <add value="NTLM" />
            </providers>
            <extendedProtection>
            </extendedProtection>
          </windowsAuthentication>
        </authentication>
      </security>
    </system.webServer>

    There's obviously something still wrong with my install as the REST api keeps hanging for ages before returning a 500 error. This can be fixed by restarting the HPC Web Service on the head node but then it starts hanging again.

    Tuesday, January 16, 2018 2:04 AM
  • Hi,

    The result of powershell you gave has no problem. Negotiate provider has already been removed. It's OK to ignore this error message.
    Adding a note about dism needs internet can be a good advice, thanks. While IIS can only be installed by dism or Enable-WindowsOptionalFeature, if you need to install IIS offline, please consider using the Source option.

    Here lists all the features enabled by set-hpcwebportal, please check if all of them are installed, and then check if HpcPortal is working again.

    IIS-WebServerRole
    IIS-WebServer
    IIS-CommonHttpFeatures
    IIS-StaticContent
    IIS-DefaultDocument
    IIS-HttpErrors
    IIS-HttpRedirect
    WAS-NetFxEnvironment
    IIS-ApplicationDevelopment
    IIS-ISAPIExtensions
    IIS-ISAPIFilter
    IIS-RequestFiltering
    IIS-HttpLogging
    IIS-LoggingLibraries
    IIS-HttpTracing
    IIS-CustomLogging
    IIS-Security
    IIS-BasicAuthentication
    IIS-WindowsAuthentication
    IIS-HttpCompressionStatic
    IIS-HttpCompressionDynamic
    IIS-ManagementScriptingTools
    IIS-Metabase
    IIS-WMICompatibility
    IIS-LegacyScripts
    IIS-NetFxExtensibility
    IIS-ASPNET
    IIS-ManagementConsole
    IIS-ASPNET45

    Thanks,
    Zihao

    Tuesday, January 16, 2018 5:32 AM
  • It seems the culprit is NetFx3 (required for WAS-NEtFxEnvironment). DSIM doesn't want to install that particular feature though installing the other features seems to work fine

    PS C:\> dism.EXE /online /enable-feature /featurename:NetFx3

    Deployment Image Servicing and Management tool
    Version: 10.0.14393.0

    Image Version: 10.0.14393.0

    Enabling feature(s)
    [==========================100.0%==========================]

    Error: 0x800f081f

    The source files could not be found.
    Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft
    .com/fwlink/?LinkId=243077.

    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

    ...though it appears others also fail.

    • Edited by dhirschfeld Tuesday, January 16, 2018 6:35 AM
    Tuesday, January 16, 2018 6:34 AM
  • So, because the NET-Framework-Core WindowsFeature was Removed it had to be enabled by providing the source:

    http://www.dell.com/support/article/au/en/audhs1/sln293419/unable-to-install-net-framework-35-features-using-server-manager?lang=en

    It would certainly have been very helpful if the DSIM command didn't fail silently - e.g. check the returncode and provide a meaningful error message if it failed.

    In any case, I think that wraps up this thread. Thanks for your help tracking it down...

    -Dave

    Wednesday, January 17, 2018 3:07 AM
  • Hi,

    You are welcome.

    And also thank you for your advice. We have created work items to investigate and implement the changes you suggested.

    Thanks,
    Zihao

    Thursday, January 18, 2018 1:48 AM