locked
Windows Server 2008 fails to start Software Licensing service - system error 1278 RRS feed

  • Question

  • Could anyone help with the following issue?

    After Windows Server 2008 updates and server restart it fails to start Software Licensing service:
    When I open cmd.exe as Administrator and net start slsvc it fails to start:
    C:\Windows\system32>net start slsvc
    System error 1278 has occurred.
    Windows cannot open this program because tampered with or become corrupted.

    Diagnostic Report (1.9.0027.0):
    -----------------------------------------

    Windows Validation Data-->
    Validation Status: Genuine
    Validation Code: 0
    Cached Online Validation Code: N/A, hr = 0x80070426
    Windows Product Key: *****-*****-3X2YQ-YCY4H-M249D
    Windows Product Key Hash: l/zd1P3+cfEcX2iYB1ueUH4puzk=
    Windows Product ID: 92579-082-2500777-76258
    Windows Product ID Type: 1
    Windows License Type: KMS Client
    Windows OS version: 6.0.6002.2.00030510.2.0.017
    ID: {8D693ADB-F4D7-4924-ADC0-18BB81B471F9}(3)
    Is Admin: Yes
    TestCab: 0x0
    LegitcheckControl ActiveX: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows (R) Web Server 2008
    Architecture: 0x00000009
    Build lab: 6002.vistasp2_gdr.120402-0336
    TTS Error: M:20120825192922216-
    Validation Diagnostic: 
    Resolution Status: N/A

    Vista WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    Windows XP Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 109 N/A
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\Program Files (x86)\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Disabled
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Disabled
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Disabled
    Script ActiveX controls marked as safe for scripting: Disabled

    File Scan Data-->
    File Mismatch: C:\Windows\system32\Slsvc.exe[6.0.6002.18005], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\linkinfo.dll[Hr = 0x80070002]

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{8D693ADB-F4D7-4924-ADC0-18BB81B471F9}</UGUID><Version>1.9.0027.0</Version><OS>6.0.6002.2.00030510.2.0.017</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-M249D</PKey><PID>92579-082-2500777-76258</PID><PIDType>1</PIDType><SID>S-1-5-21-4134912836-189804590-112939760</SID><SYSTEM><Manufacturer>FUJITSU</Manufacturer><Model>PRIMERGY RX100 S6             </Model></SYSTEM><BIOS><Manufacturer>FUJITSU // Phoenix Technologies Ltd.</Manufacturer><Version>6.00 Rev. 1.16.2863.A1          </Version><SMBIOSVersion major="2" minor="6"/><Date>20100622000000.000000+000</Date></BIOS><HWID>ED303507018400FE</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>  

    Spsys.log Content: U1BMRwEAAAAAAQAACAAAAKJzVgUAAAAAYWECAGD6///gGzCaMoPNAZWnLvbizrpQQvBAlB2zeltmk5gWMJsSyzYS8bYcl6+/5N9x52Vl/Wt5lCz1fphkqVZbYNfuwTJ+ElkeJz0IHzH0e9SYmKEyRx1aW5g4QBhgZFrwLWush7yuovJpCAsbMTOQ1ifb1stzrqx+w3WNaAwzkNYn29bLc66sfsN1jWgMM5DWJ9vWy3OurH7DdY1oDDOQ1ifb1stzrqx+w3WNaAwzkNYn29bLc66sfsN1jWgMM5DWJ9vWy3OurH7DdY1oDDOQ1ifb1stzrqx+w3WNaAwzkNYn29bLc66sfsN1jWgMM5DWJ9vWy3OurH7DdY1oDDOQ1ifb1stzrqx+w3WNaAw=

    Licensing Data-->
    Software Licensing service is not running.

    Windows Activation Technologies-->
    N/A

    HWID Data-->
    HWID Hash Current: NAAAAAEAAgACAAEAAgAAAAAAAwABAAEA6GE6rhU/FF/mdma20LsIjvL0d/aUvfx6rFZ2Vg==

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes, but no SLIC table
    Windows marker version: N/A
    OEMID and OEMTableID Consistent: N/A
    BIOS Information: 
      ACPI Table Name OEMID Value OEMTableID Value
      APIC PTLTD APIC  
      FACP FTS   D2863/Ax
      HPET PTLTD HPETTBL 
      BOOT PTLTD $SBFTBL$
      MCFG PTLTD  MCFG  
      TCPA Phoeni x      
      EINJ PTL   WHEAPTL 
      HEST PTL   WHEAPTL 
      BERT PTL   WHEAPTL 
      SSDT wheaos wheaosc
      ERST PTL   WHEAPTL 
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SSDT wheaos wheaosc
      SPCR PTLTD $UCRTBL$
      DMAR Intel OEMDMAR 

    Details about Windows 2008 Error Code 1278:
    System error code 1278 means "Windows cannot open this program because the license enforcement system has been tampered with or become corrupted." This error code may also display as "ERROR_ACCESS_DISABLED_WEBBLADE_TAMPER" or as the value 0x4FE.

    • Edited by MKubaitis Wednesday, August 29, 2012 3:40 AM
    Tuesday, August 28, 2012 9:57 PM

Answers

  • Thanks for details. Primary disk in RAID-1 array got bad sectors which caused an above issue. 
    When disk is replaced I'll try to run SFC /SCANNOW command.
    Thursday, August 30, 2012 6:25 AM

All replies

  • Your problem appears to be that the Software Licensing Service is not running. and it must, if Vista is not to complain.

     Have you been using any form of Registry Cleaner??

    First check that the Service is set to start Automatically –

    Click on Start,

     in the Search box, type

    SERVICES.MSC

    and hit the Enter key.

    Accept the UAC prompt, then look in the listing for the Software Licensing Service – right-click on it and select Properties.

    Make sure that it’s set to Automatic, and click Apply

     

     Once that’s properly set, Start the service – how long before it appears to stop again? Is there anything in the Event Viewer to indicate why it stopped? – is there an error message?

     

     Please run the following commands in an Elevated (Admin) Command Prompt Window, and post the results. 

     

    net start slsvc

    sc qc slsvc

    sc queryex slsvc

    sc qprivs slsvc

    sc qsidtype slsvc

    sc sdshow slsvc

     

      Here are some instructions to make life easier :)

    1) To open an Elevated Command Prompt Window (the CP window), click on Start, All Programs, Accessories – then right-click on Command Prompt, and select Run as Administrator. Accept the UAC prompt. 

    2) To run the commands easier, highlight the block of commands, and right-click on the highlight – select Copy. In the CP Windows, click on the black/white icon at top left – select Paste. The commands will run but may not complete the last command, so hit the Enter Key once. 

    3) To copy the results... click on the Black/White icon in the top left, and select Edit... 'Select All', and hit the Enter key - then use Ctrl+V or r-click+Paste to paste it into your response.     


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Wednesday, August 29, 2012 9:56 AM
    Moderator
  • Forget that - it's fairly obvious why the service isn't running...

    File Mismatch: C:\Windows\system32\Slsvc.exe[6.0.6002.18005], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\linkinfo.dll[Hr = 0x80070002]

    Start with CHKDSK C: /R  and follow up with SFC /SCANNOW

    post a new MGADiag report and we'll see if that got anywhere.

    please also upload the CBS.log file produced to your SkyDrive public folder, and post a link.


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Wednesday, August 29, 2012 10:01 AM
    Moderator
  • Thanks for details. Primary disk in RAID-1 array got bad sectors which caused an above issue. 
    When disk is replaced I'll try to run SFC /SCANNOW command.
    Thursday, August 30, 2012 6:25 AM
  • Glad we found it quickly!

    Good luck with the rebuild.


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Thursday, August 30, 2012 12:46 PM
    Moderator
  • Results: SFC /SCANNOW fixed corrupted files and it solved licensing service issue.
    • Edited by MKubaitis Friday, August 31, 2012 1:41 AM
    Friday, August 31, 2012 1:39 AM
  • That was quick :)

    Please post a new MGADiag report so we can sign off on it.


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Friday, August 31, 2012 10:12 AM
    Moderator