locked
WHS and USB connection problems RRS feed

  • Question

  • I tried installing a USB external disk the other day, (I was watching the install using the remote desktop connection), and my WHS machine briefly complained about some drivers.  Sorry can't remember the actual message, because I figured as per any other windows PC I have ever had all I would have to do is reboot the machine and try the install process again. However after the reboot, I plugged in the external drive once more and WHS didn't acknowledge that anything had been plugged in.

    If I now going to the system option from the control panel, and look at the device manager under the branch named other devices, there is a sub branch named unknown device, both of which have a ? next to them. I have tried deleting this item and seeing if any changes are made after a reboot, but I have made no progress.

    I have also tried plugging in other USB devices such as a memory stick, but my WHS installation now seems to ignore all devices.

    Any suggestions?

    Friday, May 15, 2009 8:43 AM

All replies

  • You can try uninstalling all USB controllers / hubs  from device management window, then reboot. This should normally reinstall appropriate drivers for USB controllers / hubs.
    Friday, May 15, 2009 3:19 PM
    Moderator
  • I tried that but it didn't work. All USB items uninstalled, machine rebooted tried reattaching the USB disk and no recognition of the unit at all, but all the USB branches reinstated on the device manager tree prior to that point...
    Saturday, May 16, 2009 9:32 AM
  • Hmm. could be hardware failure or some driver issue, nothing logical I can think of for you to try. I guess you have tried all available USB ports (front and back)?
    Saturday, May 16, 2009 6:15 PM
    Moderator