locked
Wgatray.exe uses 100% cpu RRS feed

  • Question

  • Hi,

    My PC has been running fine and had been validated as genuine without problems. 

    However, as from yesterday morning after logon nothing would run - any app, including things like notepad or IE would show up as a process but not actually do anything. I tried a system restore from safe mode back to sunday but no help.

    While looking through the processes I noticed that wgatray.exe was running at 50% (dual core cpu) and that one other random process was also running at 50%. If I kill wgatray the system would momentarily come to life and the stalled apps would draw a window or show a dialogue box and then wgatray would kick in again and all would come to a grinding halt again, with wgatray and another, different process taking 50% each.

    I left my PC running and after about 20 mins it finally came to life and wgatray dissapeared as a process. I have now been able to get my PC running by removing WGA - but I want to re-install WGA but don't want to hit this problem again. Would anyone be able to tell me if this is this a known issue, and is there a work around?

    Thanks for any help!

    Thursday, March 1, 2007 9:35 AM

Answers

  • Hi Darin,

    I have managed to resolve the problem - it appears that some component of the WGA files must have been damaged, as I did a Ghost restore back to a week ago and all is now well. It seems strange that a system restore didn't help, but hey...

    This is what my diganostic returns now:

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Detailed Status: N/A
    Windows Product Key: *****-*****-
    Windows Product Key Hash: MJXoN4RCRfzHNF/dk1CtJGtA1fs=
    Windows Product ID: 76477-OEM-2166841-40706
    Windows Product ID Type: 3
    Windows License Type: OEM System Builder
    Windows OS version: 5.1.2600.2.00010300.2.0.hom
    ID: d71199ca-59ef-4990-a79e-e63e0030bc69
    Is Admin: Yes
    AutoDial: Yes
    Registry: 0x0
    WGA Version: Registered, 1.5.723.1
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: 0
    File Exists: Yes
    Version: 1.5.554.0
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    But thanks for the fast response.

    Regards

    Stabby

    Monday, March 5, 2007 5:46 PM

All replies

  • Hello,

     

    Look. The WGAtray.exe is the program for Windows Genuine Advantage that program checks if your Windows version is ok so iff it is not a copy,

    Mostly that thing is in a Update of windows just check if he is downloading that program if he does you can just cancel it your computer don't really need it...

    I'm 14 and I do even understand this :P

    Thursday, March 1, 2007 5:43 PM
  • Hi Staberinde,

    In order to recieve the best support, we request all users initially run the Genuine Diagnostics tool to try and identify the issue you may be having.

    Download and run the utility at this link http://go.microsoft.com/fwlink/?linkid=52012 , then click the Windows tab, Copy to Clipboard, then paste the report into a response message in this thread.

    Step 2 is tell us about the COA. Tell us:
    1. What edition of Windows XP is it for, Home, Pro, or Media Center?
    2. Does it read "OEM Software" or "OEM Product" in black lettering?
    3. Or, does it have the computer manufacturer's name in black lettering?
    4. DO NOT post the Product Key.

    Thank you,
    Darin Smith
    WGA Forum Program Manager

    --------------------------------------------------------

    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.
    --------------------------------------------------------

    Thursday, March 1, 2007 7:58 PM
  • Hi Darin,

    I have managed to resolve the problem - it appears that some component of the WGA files must have been damaged, as I did a Ghost restore back to a week ago and all is now well. It seems strange that a system restore didn't help, but hey...

    This is what my diganostic returns now:

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Detailed Status: N/A
    Windows Product Key: *****-*****-
    Windows Product Key Hash: MJXoN4RCRfzHNF/dk1CtJGtA1fs=
    Windows Product ID: 76477-OEM-2166841-40706
    Windows Product ID Type: 3
    Windows License Type: OEM System Builder
    Windows OS version: 5.1.2600.2.00010300.2.0.hom
    ID: d71199ca-59ef-4990-a79e-e63e0030bc69
    Is Admin: Yes
    AutoDial: Yes
    Registry: 0x0
    WGA Version: Registered, 1.5.723.1
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: 0
    File Exists: Yes
    Version: 1.5.554.0
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    But thanks for the fast response.

    Regards

    Stabby

    Monday, March 5, 2007 5:46 PM
  •  Darkhell wrote:

    Hello,

     

    Look. The WGAtray.exe is the program for Windows Genuine Advantage that program checks if your Windows version is ok so iff it is not a copy,

    Mostly that thing is in a Update of windows just check if he is downloading that program if he does you can just cancel it your computer don't really need it...

    I'm 14 and I do even understand this :P

    I'm 46 and have been in IT for twice the time you have been on this planet - if you can't say something useful then SHUTUP. I have forgotten more about windows than you will ever know. I did not ask what WGAtray.exe was designed to do - I know that already, fool.

    If you bothered to read my post instead of trying to be a smartarse you will have notice that I mentioned that every time I tried to cancel it it just re-started itself.

    Monday, March 5, 2007 5:48 PM
  • I am having the same problem, this process is taking up all of my CPU time.  I cannot do anything on the computer.  Is it looking for something in particular, or just having issues in general.  Tried doing a System Restore, but of course that doesn't take care of the problem.  I can't even get to the site that MS gives for diagnostics.  What is another course of action?

     

    Thanx 

    Wednesday, March 28, 2007 3:33 PM
  • I am also having the same problem with the CPU being occupied 100% by the wgatray.exe application.  Tried shutting it down, it does so momentarily and restarts back up.  Help please.

    Here is the diagnostics report:

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Detailed Status: N/A
    Windows Product Key: (removed for here)
    Windows Product Key Hash: (removed for here)
    Windows Product ID: 55274-OEM-2211906-00102
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 5.1.2600.2.00010100.2.0.pro
    ID: 04a8f5e1-e082-46ee-a353-6273e42adc42
    Is Admin: Yes
    AutoDial: No
    Registry: 0x0
    WGA Version: Registered, 1.7.18.5
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: 0
    File Exists: Yes
    Version: 1.7.18.5
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Data-->
    Office Status: 100 Genuine
    OGA Version: Failed to retrieve file version. - 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-3178-80070002_B4D0AA8B-530-645

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\PROGRA~1\MOZILL~1\FIREFOX.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->
    File Mismatch: c:\windows\system32\oembios.bin
    File Mismatch: c:\windows\system32\oembios.dat
    File Mismatch: c:\windows\system32\oembios.sig

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>04a8f5e1-e082-46ee-a353-6273e42adc42</UGUID><Version>1.7.0012.0</Version><OS>5.1.2600.2.00010100.2.0.pro</OS><PKey>*****-*****-*****-*****-YD4YT</PKey><PID>55274-OEM-2211906-00102</PID><PIDType>2</PIDType><SID>S-1-5-21-4257004516-1896913581-2299459618</SID><SYSTEM><Manufacturer>Dell Computer Corporation</Manufacturer><Model>Inspiron 8600                   </Model></SYSTEM><BIOS><Manufacturer>Dell Computer Corporation</Manufacturer><Version>A14</Version><SMBIOSVersion major="2" minor="3"/><Date>20050630000000.000000+000</Date><SLPBIOS>Dell System,Dell Computer,Dell System,Dell System</SLPBIOS></BIOS><HWID>C8E83407018400EC</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>1</iJoin><SBID><stat>2</stat><msppid></msppid><name>Dell Computer Corporation</name><model>Dell INSPIRON 8600</model></SBID><OEM/></MachineData>      <Software><Office><Result>100</Result><Products><Product GUID="{903A0409-6000-11D3-8CFE-0150048383C9}"><LegitResult>100</LegitResult><Name>Microsoft Office Project Standard 2003</Name><Ver>11</Ver><Val>AF2C6A861DD500</Val><Hash>cb8T0qaBjXWDa4yA0yNx9mmTe7M=</Hash><Pid>72076-640-3754306-55760</Pid><PidType>14</PidType></Product></Products></Office></Software></GenuineResults> 

    Thank you,

    --Deanr14
    Thursday, March 29, 2007 10:01 PM
  • I have use windows search program found the program. Then i push ctrl ald del search for the wga.exe close it delete the file in directory problem solve for the time.

    1 - First hit try to delete the file
    2 - Then close the wga.exe you got 5 sec or it wil not be remove or it will restart the wga.exe
    3 - do step 1 and 2 if not work

    easy

    Thursday, April 16, 2009 9:42 PM