locked
\\HOME-SERVER is not accessible ... A device attached to the system is not functioning. (from Windows7) RRS feed

  • Question

  • I'm using Windows 7 professional 64bit. My network server is WHS V1, fully patched.

    I was advised to post this request for help in this forum, although it looks like a W7 problem to me.


    I have a desktop shortcut to \\HOME-SERVER on my W7 machine. (as created when the WHS connector was installed).

    All of a sudden it stopped working.
    I get the message 
    \\HOME-SERVER is not accessible. You might not ...
    A device attached to the system is not functioning.


    I found that from the command line  net view \\HOME-SEVER gives (and typing this into an explorer address bar fails)
    System Error 31 has occurred.
    A device attached to the system is not functioning.

    And that net view \\HOME-SERVER\Music gives (but typing this into an explorer address bar works!)
    System Error 53 has occurred.
    The network path was not found.

    However net view 192.168.1.99 (my server address) correctly lists the share names on the server (and entering \\192.168.1.99 into and explorer address bar works).

    I did a system restore on the W7 machineto before the problem first occurred to rule out any changes to the system.

    The problem still occurred.

    I have also rebooted WHS, W7, and Router.


    This means that my Sync Centre does not show any of my sync partnerships.

    Can anyone suggest the setting or service that need to be fixed to solve the System Error 31 issue?

    and get Sync and the shared folder shortcut to work?

    tia



    • Edited by skiwier Sunday, March 4, 2012 1:17 AM
    Sunday, March 4, 2012 1:16 AM

All replies

  • Hi.

    Not an expert on Home Server, but have one here, I would suggest first that you disable your Firewall on your Win7 machine and see if you can connect then.    If that is no good try opening the Network sharing center click the Full network map and see if your Servers name appears, I suspect it will not, hence you need to check your Server , make sure its connected to the network (ping its IP address)  check its IP address and its Cat5 connection.

    If all is well I would restart the Server and check again.   Hope this helps.


    Peyia1 ID

    Monday, March 5, 2012 5:40 PM
  • Thankyou for your goodwill answer.

    As you will see from my original posting I have tried all those things.

    To confirm.

    When I try your suggestion to do a network map the window opens, than hangs, (cursor turns to circle, title bar says "Not Responding") and it never draws the map or completes its response.

    I can ping the server. The server still does backups from the laptop! I can remote desktop to the server. The WHS Console still works! 

    But Sync does not, nor does the desktop shortcut.

    I can still see the server using a previously set up drive mapping. (eg drive M:)

    I have rebooted everything (more than once!).

    I am not using a wired connection, I am using wireless.

    I use Windows Firewall (and Avast).

    I tried your suggestion of turning the firewall off. I still could not connect thru my desktop shared folder shortcut, and the network map hangs again.

    thanks

    Sunday, March 11, 2012 9:38 AM
  • Hi Skiwier.

    Just some other things to try....

    Avast has its own Firewall, so using Windows means you have two running, decide which you require and disable one of them, I use the Avast in my WHS machine, but windows in my W7 machine.

    I have copied a sceen dump of my Advanced Settings, found in the Network Sharing Center, this may help show up the Network Map.

    Also check that Server and W7 are in the same Workgroup, or you will never get then to connect.

    You can change the advnced settings as you wish, but for the present I suggest you make then the same as they work for me.

    If you do get to create the map, I suggest you delete the original shortcuts and setup new ones, browse the network and create a new Network shortcut.

    Also do you have the W7 User name setup on the Server as a normal User?

    Maybe worth putting the Laptop alongside the Server and connecting wired, so that eliminates the Wireless setup from the problem.

    Hope you get there.


    Peyia1 ID


    Ignore the dog, he is no use in faulting anyway Ha!
    • Edited by Pcpeteuk Sunday, March 11, 2012 5:15 PM Forgot the image
    Sunday, March 11, 2012 10:03 AM
  • Hi,

    try to use Remote Desktop to your home server, login as Administrator with the console password and try to run \\home-server from here.

    Does it fail too?

    In this case its not a client firewall or networking problem, but you may have a problem with the storage pool (i.e. one of the data disks failed, a folder corrupted or something like that).

    Check also the servers event log for any disk related issues in the System and Application logs.

    Firewall issues can quickly be validated by disabling the firewall for a short time in Control Panel. (Or do you use a 3rd party firewall?)

    Is your client multihomed (means using multiple network cards like wired and wireless)?  If so, try to disable the currently unused.

    Another issue could be something with name resolution.

    What do you get on the client, if you open a command prompt, run nslookup and enter your servers name? Does it point to the expected internal address or to something ourside of your LAN?

    Last question: On the server and on the client, do time, date and timezone match? (Although the message is usually different, if this is a problem.)

    Best greetings from Germany
    Olaf

    Tuesday, March 13, 2012 10:26 AM
    Moderator