locked
Translations import failed. RRS feed

  • Question

  • Hi All,

    I am working on some addon and need to show the label for multiple language (e g: German).

    and I have requirement like need to do programmatically. so I have written a small console app where it will export the translation file for the solution and extracting using some zip API, and reading the translation.xml file and  adding the German text using the base English text available in the same row of translation.xml file, and zip it again.

    The above task is working perfect. but unfortunately I couldn't able to import it back to CRM, i am getting error like translation file is invalid or does not confirm the translation schema.

    and I have exported translation file for the same solution manually and compared with programmatically created one, everything is same, there is no bit difference at all. yet I am not able to import it.

    Finally I have copied the complete XML content of manually exported file and pasted to the programmatically created one. still no luck, getting the same error.

    If I import the manually exported translation means it is fine.

    Finally I have replaced with manually exported file then it is fine.

    Is there any problem in translating programmatically, I means saving translations.xml.

    Sorry may be this is but bigger and confusing.

    please any one help me solve this issue.

    Thanks in advance.

    Veeresh

    Tuesday, October 21, 2014 1:12 PM

All replies

  • Is it possible the translations you are doing programmatically are using an invalid character set?
    Thursday, October 23, 2014 9:00 PM