none
Cannot run SyncToy RRS feed

  • Question

  • Suddenly, SyncToy has stopped working.  I keep getting an error message, "Exception during preview: Retrieving the COM class factory for component with CLSID {C201C012-4D72-B9C5-341D48630630}failed due to the following error: 80040154.

    Thursday, February 17, 2011 5:54 AM

All replies

  • I have the same error too and have not been able to use SyncToy for the last couple of months.  Tried reinstalling but doesn't help.  Any advice will be very much appreciated.
    Sunday, April 10, 2011 2:03 AM
  • I found a similar post (http://social.microsoft.com/Forums/en-US/synctoy/thread/34e7f016-b231-4046-9703-242b117065d4) with a similar solution:

    1. Remove Microsoft Sync Framework 2.0 Core Components and Microsoft Sync Framework 2.0 Provider Services. It could be just one is the culprit, I didn't test.

    2. Reinstall Synctoy 2.1, which will automatically reinstall these two components.

    3. My installation works again!

    • Edited by LaRocque Tuesday, April 19, 2011 3:21 AM Found solution
    • Proposed as answer by LaRocque Tuesday, April 19, 2011 3:21 AM
    Tuesday, April 19, 2011 3:13 AM