locked
How to sync "My Documents" between two Windows 7 machines RRS feed

  • Question

  • The My Documents folder (C:\Users\XXXXXX\Documents) doesn't have the option to be added to Live Mesh in Windows 7.  When I right click on it in the explorer, the "Add folder to Live Mesh..." option isn't there.

    This folder does not contain the desktop folder in Win 7, so I don't see why it can't be sync'd across machines.  It doesn't appear to be marked as a system folder either.  It makes no difference whether I have this included in the "Documents" library structure or not.

    Ideas?

    Thanks.

    Wednesday, March 11, 2009 2:46 PM

Answers

  • Hi,

    One question to get started: Are any of the folders within your Documents folder already Live Mesh folders?  Since Live Mesh does not currently allow one Live Mesh folder to be inside another, if any subfolders are already part of your Mesh, the option to add the master folder to the mesh will not be available.

    Thanks,

    Ben.
    Wednesday, March 11, 2009 4:16 PM
  • C:\Users\Username\My Documents can be added to Live Mesh. If you select Documents in the folder tree of Windows Explorer you will not see the option to add the folder to Live Mesh but if you select the My Documents folder in the details pane you should see this option.
    Jim
    Wednesday, March 11, 2009 6:47 PM
    Moderator

All replies

  • Hi,

    One question to get started: Are any of the folders within your Documents folder already Live Mesh folders?  Since Live Mesh does not currently allow one Live Mesh folder to be inside another, if any subfolders are already part of your Mesh, the option to add the master folder to the mesh will not be available.

    Thanks,

    Ben.
    Wednesday, March 11, 2009 4:16 PM
  • I don't have access to a Windows 7 machine right now, but are you pointing to the "Library" or the actual folder in Explorer?
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Wednesday, March 11, 2009 4:19 PM
    Moderator
  • C:\Users\Username\My Documents can be added to Live Mesh. If you select Documents in the folder tree of Windows Explorer you will not see the option to add the folder to Live Mesh but if you select the My Documents folder in the details pane you should see this option.
    Jim
    Wednesday, March 11, 2009 6:47 PM
    Moderator
  • I'll confirm both Ben's and Jim's replies. I checked last night and if there is already a sub-folder made into a Live Mesh folder, the top level folder cannot be added to the Mesh, too. And, Jim is correct in that you will get the option in the details pane.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Thursday, March 12, 2009 3:15 PM
    Moderator
  • It was in fact the subfolder culprit.  I had done some preliminary testing with a subfolder under Documents, and I removed it from Mesh, but apparently MOE wasn't convinced.  Deleting the folder solved the problem.

    Kind regards all!
    Thursday, March 12, 2009 5:10 PM
  • Excellent, thanks for confirming Ben's suspicions.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Thursday, March 12, 2009 5:21 PM
    Moderator
  • I tried to also sync 2 windows 7 machines but ran into problems.

    I successfully synced My Documents from machine 1 to the Live Desktop, in a folder called Roland's Documents.

    On Machine 2 I went to the greyed out Roland's Documents on the Local Desktop, selected Synchronize With This Computer and browsed to the local My Documents Folder. Once the syncing started I noticed in Explorer that it was syncing to a new blue subfolder called Roland's Documents in the local My Documents folder of Machine 2. I first thought these may be placeholder folders/files, until I noticed some actual docx files appearing. I interrupted the sync because I believe I would have ended up with 2 copies of all my Documents
    - 1 copy in My Documents
    - another copy in My Documents/Roland's Documents

    Can you help me figure out how to correct/avoid this situation?
    Tuesday, November 24, 2009 4:47 AM
  • Hmmm, I have just moved to Windows 7 and am having similar problems being unable to select the root of My Documents folder to be synced to live mesh.

    My old PC is about to die and had MY docs synced fine with Windows XP. I thought the cause might be a name conflict. I deleted all traces of the Live mesh folder and yet still My docs  will not give the option to sync. There are no other live mesh folders so it is not the sub folder issue. 

    Maybe it will clear eventually but right now is a head scratcher. Any clues out there?
    Thursday, December 10, 2009 9:09 PM
  • When you are trying to set this up are you following the path defined by Jim in his answer above?

    "C:\Users\Username\My Documents can be added to Live Mesh. If you select Documents in the folder tree of Windows Explorer you will not see the option to add the folder to Live Mesh but if you select the My Documents folder in the details pane you should see this option."

    -steve
    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Friday, December 11, 2009 2:46 PM
    Moderator
  • Yeah using the correct path. So in this particular user I see all the other directories, contacts, desktop etc.

    Every folder other than desktop and My Docs is available for share.  I can drill into My docs and share folders inside it, but right now I have none shared. So stumped for now.

    I suppose from this above "It was in fact the subfolder culprit.  I had done some preliminary testing with a subfolder under Documents, and I removed it from Mesh, but apparently MOE wasn't convinced.  Deleting the folder solved the problem." there is a possibility at some point in the distant past on the old machine there was a sub folder shared. However it isn't on the live desktop and the only prior share was the My Documents folder on the old machine. As of right now there are no folders shared at all.
    Saturday, December 12, 2009 2:43 PM
  • Ok so finally resolved it, although it still doesn't make much sense. I made a new directory called Docs and copied all files and folders from My documents to it, so the new folder was basically a new my docs at the same level. I them deleted the My Documents folder. The new folder synced to live mesh fine. Then I noticed that the My Documents folder was back again, and when I right clicked I could sync it..... hmmmm.... So I copied all the files and folders back to it and I have my solution. The only other variable was taking My documents out of the documents library, so I am not 100% what it was that fixed it, deleting or removing from the library. Either way something to try if you have the same problem. The folder icon still isn't highlighted blue but it is syncing and has live mesh options so happy days :-)
    Sunday, December 13, 2009 3:18 PM
  • Thanks for sharing your experience, CWobbles. I suspect that it may have been a leftover reference to the old subfolder relationship, but it's hard to say. At least it is now working.
    -steve
    ~ Microsoft MVP Windows Live ~ Windows Live OneCare| Live Mesh|MS Security Essentials Forums Moderator ~
    Monday, December 14, 2009 2:00 PM
    Moderator