locked
Solution With Id Does not Exist! RRS feed

  • Question

  • Hello!

    Could you please help me ASAP with this error?

    Solution With Id .. Does not Exist!

    CRM2011, trying to delete solution...

    Thanks a lot!

    Saturday, May 26, 2012 6:16 PM

All replies

  • is it a managed or unmanaged solution

    Ben Hosking
    Check out my CRM Blog
    Linked-In Profile
    Follow Me on Twitter!

    Monday, May 28, 2012 10:59 AM
  • Does this issue repro consistently?  Can you ensure that the solution still exists in the system by doing a solutions' grid refresh?  Also, if you can turn on server error level tracing and post the exception that would be useful.

    Thanks,

    Brandon

    Thursday, June 7, 2012 10:15 PM
  • Hello, it's managed solution... I think, the problem is with rights. I'm not sure. But I have full admin system rights.
    Wednesday, June 20, 2012 2:42 PM
  • Ok, I'll do that. Yes, solution is still exists and do what it should do. But I have to remove it.
    Wednesday, June 20, 2012 2:43 PM
  • Is this on premises or online?  If you are working in an online environment it would be best to contact Microsoft Support.  If you are working on your own on premises environment then can you turn on tracing and post the server exception?

    Thanks,

    Brandon

    Thursday, June 21, 2012 9:34 PM
  • We continue to have the exact same error with an on-premise install of a managed solution for a client of ours and Microsoft's has no idea why. We also got the same error - exactly - on an online install of the same managed solution and after three weeks of waiting, they indicated they increased the SQL timeout and lo and behold it finally worked. That was after migrating the customer to a brand new site just so they could continue to use the system. We added SQL timeout registry changes to the on-premise install and still get the same error. Unfortunately, Microsoft says we have to open an incident ticket to get it solved when they apparently know why. This is the same exact error and now having to do the same thing for this client and move to a new site and migrate all their data.  Does anybody have any insight before we spend many more hours fixing another clients setup.  

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: solution With Id = ebe77276-351b-431c-95d2-daa0b042fc64 Does Not ExistDetail:
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147220969</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>solution With Id = ebe77276-351b-431c-95d2-daa0b042fc64 Does Not Exist</Message>
      <Timestamp>2012-09-18T13:06:44.0060653Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText i:nil="true" />
    </OrganizationServiceFault>



    • Edited by hbhickman Tuesday, September 18, 2012 1:18 PM
    Tuesday, September 18, 2012 1:18 PM
  • Was there a resolution to this?

    I have an online CRM.  A managed solution was removed and another is still installed.  When trying to import a new version of the installed solution it gived the error as described here.

    I assume there is some reference still in the database to the removed solution.  Can't see an obvious way to locate the reference and remove it.  I do know the entity that the import fails on but not sure how to proceed.

    G

    Tuesday, October 30, 2012 10:51 PM