locked
Activating Windows 8 N RTM RRS feed

  • Question

  • Hi there

    I downloaded Windows 8 N RTM (UK) x64 from MSDN subscribers downloads area. I entered the licence key during install and the OS installed fine. Now it keeps asking me to activate windows and the control panel is showing no existing licence key. Clicking in the "Activate" button that appears in the full screen "Activate Windows" message takes me to the "metro" control panel with no activation options. Going to the Action center windows activation screen has an activate button that does nothing when clicked. Above the button is a message that says "Windows cannot be activated right now. Try activating Windows later..." It has said this for 2 weeks now. How can I activate Windows?

    I found a thread that suggested I used slmgr.vbs /ipk "PRODUCT-KEY" on the command line but this gives an error about a non-core version of Windows. I've tried two different keys for the product edition that I downloaded with no success.

    • Moved by Mike Kinsman Wednesday, September 5, 2012 2:42 PM off topic (From:MSDN Subscriptions Feedback)
    Wednesday, September 5, 2012 8:57 AM

Answers

All replies

  • Dear RW_Software,

    Please answer the following.

    1. Which edition you have downloaded and installed - please provide the ISO name from MSDN Page.

    2. If you have your internet connection active. The product should have automatically activated as soon as you connected to the network.

    3. Please post the screenshot of the error message.

    Regards,
    prathaprabhu

    Wednesday, September 5, 2012 9:16 AM
  • 1.  <label id="filenameLabel">en-gb_windows_8_n_x64_dvd_915799.iso</label>

    2. My internet connection is active. I wouldn't be here otherwise :)

    3. Here is the screenshot. The activate button is unresponsive.

     

    Wednesday, September 5, 2012 9:21 AM
  • Dear RW_Software,

    To change the Windows 8 product key and activate - please follow these steps.

      • Launch the Start Menu and type in command prompt or cmd so that it shows up on your start menu search list. Right click on the Command Prompt shortcut and select Run As Administrator.
      • At the administrator command prompt, type in "slmgr.vbs -ipk <insert your product key here>"
        slmgr.vbs -ipk 00000-00000-00000-00000-00000
      • To activate windows after changing the key, run "slmgr.vbs -ato"
      • http://www.youtube.com/watch?v=ryZqMN5ToPE - watch this video to understand better.

    http://blogs.msdn.com/b/timart/archive/2012/08/29/activate-windows-8-enterprise-without-slui-dns-name-does-not-exist.aspx

    or

    Type "Slui 3" to open the Activation window which will allow you to change the product key.

    I have also asked you to post the "error message" when you try to activate Windows 8.

    Regards,
    prathaprabhu


    • Edited by prathaprabhu Wednesday, September 5, 2012 10:06 AM
    Wednesday, September 5, 2012 10:05 AM
  • This is what I get when I try to use the slmgr.vbs script

    I get the same error if I use a key from the MSDN site too

    Wednesday, September 5, 2012 10:09 AM
  • Dear RW_Software,

    Have you tried the other steps to change the product key? Also to display the error text run the command as mentioned in the dialog box.

    run 'slui.exe 0x2a 0x80070426'

    Also make sure that the Activation Service is running. You can check this by entering this command
    run 'services.msc'

    Regards,
    prathaprabhu

    Wednesday, September 5, 2012 11:06 AM
  • slmgr.vbs -ato shows the same error dialog as above.

    slui.exe 0x2a 0x80070426 appears to do nothing even if run immediately after the previous command

    Slui 3 alos appears to do nothing

    I've run services but can find no mention of activation in the list. What is the name of the service and how can I start it if it is not listed?

    Wednesday, September 5, 2012 11:36 AM
  • It is SPP Notification Service.

    Regards,
    prathaprabhu

    Wednesday, September 5, 2012 11:52 AM
  • Not even in the list of services available

    Wednesday, September 5, 2012 12:06 PM
  • I have now installed Windows 8 Pro N (UK) Edition - en-gb_windows_8_n_x64_dvd_915799.iso on VMware 9. Everything worked fine. I don't see any activation issues i can see the Change product key options. Here is the screenshots. I would appreciate if you could tell me which product key you have used during installation and how long it's been since you have installed Windows 8 Pro N.


    • Edited by prathaprabhu Wednesday, September 5, 2012 1:38 PM
    Wednesday, September 5, 2012 1:37 PM
  • Is it sensible to post my product key on a public forum?

    I installed no longer than a week or two ago and have generated a second key to see if that was the issue but the screens I see are very different:

    Wednesday, September 5, 2012 1:54 PM
  • I didn't asked you to post the product key. I mean there are default product keys which can be used to install Windows 8.

    During your initial installation did you manage to activate the Windows successfully with the first product key you have generated from your subscription? Also try the following if the licensing file is corrupted you may experience the above issue.

    1. Right click on Command Prompt and select Run As Administrator
    2. Type sfc /scannow - press Enter
    3. You may be asked for your installation media if files are found to be missing or corrupt

    Recreate the Licensing Store 
        1. Click Start button.
        2. Type: CMD.exe into the 'Search programs and files' field
        3. Right-Click on CMD.exe and select Run as Administrator
        4. Type: net stop sppsvc   (It may ask you if you are sure, select yes.
        Note: the Software Protection service may not be running, this is ok.
        5. Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform
        6. Type: rename tokens.dat tokens.bar
        7. Type: cd %windir%\system32
        8. Type: net start sppsvc
        9. Type: slui.exe
        10. After a couple of seconds Windows Activation dialog will appear. You may be asked to re-activate and/or re-enter your product key or Activation may occur automatically.

    Regards,
    prathaprabhu

    • Edited by prathaprabhu Wednesday, September 5, 2012 2:12 PM
    Wednesday, September 5, 2012 2:06 PM
  • Yes. I entered the product key generated from the msdn subscribers downloads page and the install continued. Sorry, I'm not aware of "default" product keys
    Wednesday, September 5, 2012 2:10 PM
  • Can you try the above steps and let me know

    Regards,
    prathaprabhu

    Wednesday, September 5, 2012 2:18 PM
  • Guys,

    This entire thread is off topic here.  It's a Windows 8 question, and this is the forum for MSDN Subscriptions. RW_Software, please post this question over here: http://social.technet.microsoft.com/Forums/en-US/w8itproinstall/threads

    or here: http://answers.microsoft.com/en-us/windows/forum/windows_install

    Unfortunately your post is off topic here, in the TechNet Site Feedback forum, because it is not Feedback about the TechNet Website or Subscription.

    You may want to try asking your question at http://answers.microsoft.com.

     For more information about where to post your question please see this thread: http://social.technet.microsoft.com/Forums/en-US/tnfeedback/thread/24ee65e4-0f35-403c-9bf7-41333cd13cb5

    Moving to off topic.       

    Thanks, Mike


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Wednesday, September 5, 2012 2:42 PM
  • The first step produced this:

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection found corrupt files but was unable to fix some
    of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
    example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
    supported in offline servicing scenarios.

    Uploaded file to http://www.rwscripts.com/CBS.log

    The second set of steps failed at step 5

    5. Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform

    The directory was not found

    Wednesday, September 5, 2012 2:52 PM
  • Then you will have to reinstall your Windows. Your system must be affected with a Virus / Trojan. If not you must have used a Loader / Activator.

    Regards,
    prathaprabhu

    Wednesday, September 5, 2012 5:34 PM
  • :( That is bad news. I find it unlikely that I have a virus after only a week unless the Windows security software is incredibly poor. I haven't had a virus for years. I certainly haven't used a loader or activator. No need to when I have a MSDN subscription. It must be a problem with the original install but I didn't get any errors.

    I'll wait a while to see if anyone else can offer a suggestion that doesn't involve reinstalling Windows as I've just set up all my desktop software and it will take a while to set all that up yet again.

    Wednesday, September 5, 2012 6:36 PM
  • darn it, replied with the wrong account!

    I would hesitate to accept that conclusion RW.  Perhaps your installation is corrupt, or you have a virus, but its not likely, and I'd like to see that conclusion be reached by the experts in the Windows 8 Setup forum I linked above.

    I've moved this post to the off topic section, because it was off topic, so it wont be seen by many people.   

    highly suggest you re-post your question, with accompanying screenshots and all of the detail you've provided here in this forum:http://social.technet.microsoft.com/Forums/en-US/w8itproinstall/threads

    Thanks,
    Mike


    MSDN and TechNet Subscriptions Support
    Read the Subscriptions Blog!

    Wednesday, September 5, 2012 7:15 PM
    • Edited by RWSoftware Wednesday, September 5, 2012 9:00 PM
    • Marked as answer by RWSoftware Wednesday, April 3, 2013 8:53 PM
    Wednesday, September 5, 2012 9:00 PM