locked
Help - Cut Myself Off from WHS RRS feed

  • Question

  • There's an old saying, "Just when you think you've made something idiotproof, they come along and invent a better idiot."

    Can someone bail me out of a real mess?:

    I decided it would be a good thing to apply the monthly Windows updates to my WHS machine.  I haven't regularly done this so I connected to my Asus Mini Server via remote desktop for the first time in a few weeks.  For some reason, I couldn't connect to any outside sites with Internet Explorer, only my networked computers.  Ping behaved identically from a Command Prompt.

    So it seemed reasonable to disable and re-enable the network adaptor before going to the extreme of rebooting the box.  Thus I did so, and as my finger left the keyboard it suddenly hit me that I'd done something of world-class stupidity.

    So here I am, with a box that has no user interface aside from the ability to remote desktop from other machines, and it's now sitting with no functional network adapter because there's no way to re-enable it.  The box has no video card, so even if a USB keyboard worked - and I imagine it would - there's no way to see what I would be doing.

    Am I doomed?  How in the world do I get myself out of this one?!

    Art

    Thursday, April 15, 2010 1:12 AM

Answers

All replies

  • Hi Art,

    If the box has no way to connect a monitor to it you will have to perform a server recovery to regain access to the server. Your server's manufacturer should have included instructions on how to perform the recovery, and there is an option to recover yet preserve any data on the server.

    Hope that helps!

    -Tom


    http://www.tomontech.com
    Thursday, April 15, 2010 1:28 AM
    Moderator
  • Thank you, Tom.  Alas, it appears that the recovery technique involves a recovery DVD loaded on another machine on the network and which communicates with the WHS machine via networking.  Even the hard reset (the usual recessed paper-clip button on the WHS machine) seems to involve the necessity of a user-interface to confirm and to direct the full recovery  - which also clears all backups.

    I wonder if one of those USB network adaptors would work with WHS, essentially a version of Server 2003, and install without user intervention.  They're cheap on eBay.

    I haven't waxed myself into a corner this well in a long time.

    Art

     

    Thursday, April 15, 2010 2:00 AM
  • I don't have an Asus home server, but the recovery shouldn't require a user interface; after all, the OEM servers arerequiredto be headless. And there should be two recovery options: server recovery and factory reset, or names to that effect. Server recovery should preserve your data, minus those items on the system partition (users, installed add-ins, anything you did in remote desktop).

    Edit: start with Page 96 of the manual you should have received with your server. It lays out the procedure for you.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, April 15, 2010 4:07 AM
    Moderator
  • Is it possible to use an usb-vga adapter without installing any drivers, only using builtin 2k3 drivers?
    I can't try this myself as my whs is not headless.

    Thursday, April 15, 2010 7:07 AM
  • First thing I would do is get out the manual. It might have instructions about doing a server reinstall without a remote connection. Or the instructions might have a lot of pictures on doing a reinstall. You might be able to see what keys to hit based on following the pictures in the manual.

    If that fails I would e-bay an older common NIC like 3com 3c905b. I think it's a good bet that server 2003 will recognize that NIC and autoinstall it.  You might try hooking up a keyboard for the bootup with the new NIC. Then just hit the enter key from time to time which should trigger the NEXT button if the "found new hardware" wizard runs. After about 5 minutes give it a reboot and then see if you can get in.  You might try pinging by name to see if you can get the IP address.

    Another idea. I did a google search for USB video cards and found a few for around 60 - 100 dollars. You could probably use one of those with a monitor keyboard and mouse.

    I'll keep thinking as I'm sure there's another way.

     

     

     

    Thursday, April 15, 2010 7:53 AM
  • Ken, thank you but the procedure (page 99 of my manual) indicates that the recovery DVD is to be inserted into one of the networked computers - as the Asus has no peripherals - and once again processed via the network interface.  I do have a USB DVD device for one of the X-series Thinkpads, which I just connected and hope that the blinking front-panel lights indicate that it was correctly detected and installed.  But getting through the multiple dialog boxes with no visibility is going to be iffy at best.

    I have an open technical support issue with Asus at this time. 

    Art

    Thursday, April 15, 2010 2:36 PM
  • For "MyAvatar": The machine has no peripheral slots - it's a VERY small box.  I'd pondered the USB video card possibility, and agree that it might be a potential way out.  The USB Nics I see on eBay seem to never mention Server 2003, but if I knew one worked then it might be the lowest-cost potential solution.

    Art

    Thursday, April 15, 2010 2:58 PM
  • This is the Asus TS Mini we're talking about, right?

    The network interface should only be disabled in Windows. If it's not (if it's disabled in the BIOS as a result of your change), you've "bricked" your server unless Asus can help you through re-enabling it in the BIOS without a monitor. We can't help you with that.

    The recovery CD that Asus supplied will only work from a client computer. It is not possible to recover your server by using a DVD drive connected directly to the server, as the recovery process works outside of Windows, and re3quires a network connection.

    Please read the instructions for a recovery carefully, and follow them closely.


    I'm not on the WHS team, I just post a lot. :)
    Thursday, April 15, 2010 2:58 PM
    Moderator
  • Everyone: Thank you, I think I got it!

    I found a "blind" cookbook set of instructions at http://www.mediasmartserver.net/wiki/index.php/How_to_fix_a_disabled_network_interface

    and it worked.  This is one mistake I probably won't make again.

    I appreciate everyone's interest in this debacle.

    As an aside, the original problem (no access beyond my network) remains, and it appears not to be a firewall issue, but I guess we'll just live with no Windows updates.

    Art

    Thursday, April 15, 2010 3:20 PM
  • That's great. Glad you got it fixed.

    I kind of recommend you pursue the recovery scenario a bit farther, though, because you don't have a very good understanding of it from what I can tell. :)


    I'm not on the WHS team, I just post a lot. :)
    Thursday, April 15, 2010 3:28 PM
    Moderator
  • Thank you, Ken.   Yes, I don't pretend to have a great familiarity with the recovery process, but there's no question that it is documented as as being conducted from one of the other computers on the network via the network interface to the WHS box. 

    My immediate thought is that the single NIC is the weak link in the system, and that I might be well advised to purchase a USB NIC in the absence of any peripheral slots on this tiny box.

    Whatever answer I get from Asus might be very interesting.  I don't know how to cancel a support request, having virtually never needed to deal with a manufacturer, so I think I'll just see what happens.

    Art

    Thursday, April 15, 2010 3:42 PM
  • My point is that you disabled the network interface in Windows. Putting the server into recovery mode doesn't boot Windows. Problem solved.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, April 15, 2010 6:41 PM
    Moderator