locked
Problem with CRM 3.0 and DNS settings RRS feed

  • Question

  •  

    Hi guys, I have a problem over here.

    I am running Microsoft Dynamics CRM 3.0 on a Windows 2003 Server R2. Currently, our email and website are still hosted by a 3rd party and will probably still be for a while more. As such, I actually named the domain for my server as xxxxx.com, thinking that one day in future, we will use our own DNS server for hosting.

    Right now, my DNS settings under TCP/IP properties are such that the first DNS server to address for any client PC is our router (192.168.0.1) followed by our server (192.168.0.20). When I do this, none of the PCs can access the web client for CRM 3.0. Only when I switch the order of the two DNS servers while I be able to access the CRM web client on any client PC. However, with this new setup, they cannot access webmail, because our domain xxxxx.com is actually registered and points to existing 3rd party nameservers, i.e. our hosting company. My colleagues can only access webmail when the order of the the two DNS servers are: 1st = router, 2nd = our server.

    My question is: Is there any setting somewhere that I can use to solve the above problem? I certainly do not want to have to re-install Windows Server just to rename the domain as xxxxx.local.

    Thanks for any advice!
    Monday, January 14, 2008 3:23 AM

Answers

  • One solution is to have users connect to the CRM server by IP address, not domain name, and hence remove DNS from the equation altogether. Note that you'd also have to use Deployment Manager to change the Reporting Server URL to use the IP address.

     

    An alternative would be to configure your server (.20) to forward DNS requests to the router, and set clients to use the .20 server as the primary DNS server. This should allow users to connect to both CRM and web mail

     

    And a 3rd option would be to use host headers on the CRM web site, but I've never been much of a fan of this

    Monday, January 14, 2008 9:59 AM
    Moderator

All replies

  • Dear,

     

    Multiple names can point to the save ip in a typical ad domain this is happens for most servers. That cann't be a problem. You may want to check you dns settings on the client, check if they point to the correct server.

     And check if nslookup does return the correct ip. If this is the case you should be able ping the name.

    Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

    Monday, January 14, 2008 9:11 AM
    Moderator
  • One solution is to have users connect to the CRM server by IP address, not domain name, and hence remove DNS from the equation altogether. Note that you'd also have to use Deployment Manager to change the Reporting Server URL to use the IP address.

     

    An alternative would be to configure your server (.20) to forward DNS requests to the router, and set clients to use the .20 server as the primary DNS server. This should allow users to connect to both CRM and web mail

     

    And a 3rd option would be to use host headers on the CRM web site, but I've never been much of a fan of this

    Monday, January 14, 2008 9:59 AM
    Moderator
  •  

    Let's start from basics. I presume that your server is a member of an active directory domain and that it or another server(s) are active directory domain controllers.

     

    If you have active directory, then somewhere there must be a DNS server that hosts records the active directory domain. Normally that would be DNS on a windows server on your network (192.168.0.20 in your case?).

     

    The fact that you have used xxxx.com doesn't matter, it just complicates things a little. So your DNS server hosts records for the xxxx.com domain.

     

    On the rest of your network, all client computers and servers that are members of the domain must have their DNS server set to the IP address of the windows server that is running the DNS service for your domain and not the router; in your case 192.168.0.20.

     

    The DNS server on your server should be configured to forward all DNS requests that it can't answer to your router.

     

    Now, because your AD domain is called xxxx.com you will have a problem accessing resources that are on the Internet from within your own network.

     

    Let's see why:

     

    For your webmail (let's say the address is webmail.xxxx.com) when your users try to access it from home say their PC will use their ISP to try to resolve the address. The request will end up at the third party or whoever hosts your DNS and will resolve correctly. However, when they try to do this inside your network (using the configuration I describe above) the request ends up at your DNS server. Now, your DNS server thinks it is authorative for the xxxx.com zone, so looks in its table and finds no record for webmail and returns not found. Because it is authorative it is does not forward the request on and so your users get a cannot be found error message. So the answer is for you to manually add an A record to your internal DNS server for  webmail (in effect duplicating the entry at your hosting company) - just remember to change the IP address if you ever change your hosting company.

     

    Do the same for any other external resources that end with .xxxx.com and you should be able to access crm and webmail from inside your network with the above configuration.

     

    It would have been a lot simpler if your internal domain was called xxxx.local as their would then be no confusion.

     

    Hope this helps.

     

    By the way, I think using host headers is fine.

     

     

    Monday, January 14, 2008 12:17 PM
    Moderator
  • Oh I see!

     

    Thank you so much both of you! Just from this thread alone, I have picked up some rather useful tricks. I will go and add in the A record now.

     

    Many thanks again!

    Thursday, January 24, 2008 3:04 AM