locked
Windows 7 Client Backup Consistently Fails RRS feed

  • Question

  • Hello,

    I've been operating a Home Server 2011 for over six months now, and have been able to resolve client backup issues on all except one of the 4 Windows machines on my network. No problem at all with installation of any connectors.

    I'm just getting killed trying to get the last machine to back up.

    The problem machine is a Windows 7 Professional 64-bit with SP1, running an i7-920, Asus P6T7 machine, with 6GB, running stock settings (no OC).

    The server is up-to-date WHS 2011, 64-bit, with 8GB ram, i7, and a 2T drive partitioned C: (60GB) and D: (1.75TB), having 1.3 TB free.

    So this Windows 7 client consistently gets to 1%, hangs there, and eventually reports "Unsuccessful". Have run chkdsk /r on all client and server disks. I've been all over this site and the internet attempting to find a fix, and/or understand what the following reports from the Event Logs may mean.

    The following messages are immediately generated anytime a client backup begins, either manually or automatically:

    -------------

    Client's Application Log:

    Faulting application name: SharedServiceHost.exe, version: 6.1.1839.0, time stamp: 0x4d38a956

    Faulting module name: WSSDriverCapture.DLL, version: 6.1.8800.16385, time stamp: 0x4d6ed346

    Exception code: 0xc0000025

    Fault offset: 0x000000000000a317

    Faulting process id: 0x11e8

    Faulting application start time: 0x01ccf762219ab08d

    Faulting application path: C:\Program Files\Windows Server\Bin\SharedServiceHost.exe

    Faulting module path: C:\Program Files\Windows Server\Bin\WSSDriverCapture.DLL

    Report Id: 14a36cc7-6356-11e1-8313-90e6ba0d5ed6

    System Log:

    The Windows Server Client Computer Backup Provider Service service terminated unexpectedly.  It has done this 2 time(s).  The following corrective action will be taken in 30000 milliseconds: Restart the service.

    Windows Server Log:

    Backup job 2 started on SPECTRALSERVER.

    Unexpected error 0x800401f3 from CLSIDFromString: Invalid class string

    Process SharedServiceHost failed at d:\wssg_src\hsbs_colorado\backup\pc\client\drivercapture\lib\drivercapturelib.cpp(268).

    ----------

    I'm really thrown by these references to WSSDriverCapture.DLL. Initially, I expected these might be indicative of a bad or missing device driver on the system. I've done a through investigation of the machine's drivers, and find them all to be up-to-date and present. Honestly, I can't find any references to drivecapturelib or wssdrivercapture.dll, so can't be entirely sure that's the issue. Seems like it though.

    Importantly, I do have two nearly identical P6T7 machines here, by the way. Both have Nvidia GPU's. The one that is backing up perfectly was built more recently, has a i7-950, and newer GPUS's.  This older build of the two, however, reliably fails, always generating the entries above. That the two were built at different times does leave room for a driver difference, but both sets of drivers do appear to be up to date.

    I'm thinking the problem is local to the Client computer, since on the Server's Dashboard I can see the process starting and appropriate files modified in Server's ServerFolders location. Removal of the Connector software from the client and the client from the server's database removes the ServerFolder files. Re-installation of the Connector and attempt to back it up bring them all back. I've also compared the C:/Program Files/Microsoft/Windows Server/logs entries as best I can on the two clients and they seem pretty much the same. No references to the error found in the error logs.

    In the Server's logs, there appear to be no relevant entries or errors at all except some Audit Failures in the Security Log, which appear to be same when either machine starts a backup.

    I've tried reinstalling the Connector numerous times with no change in behavior. Server and client OS are all up to date.

    Any clues would be outstanding!

    Thanks!

    Rich




    • Edited by Rich Irwin Saturday, March 3, 2012 4:18 AM Add more detail
    Thursday, March 1, 2012 5:23 AM

All replies

  • Is the disk you are trying to back up on the failing client computer the boot disk, or some other disk? 

    FYI, WHS cannot back up dynamic client disks or client disks with GPT partitions, and will fail with similar symptoms.

    Have you run a CHKDSK on the failing client computer?

    You might want to check the System event log on the client computer to see if you have any disk-related or volume shadow copy error conditions... 

    Tuesday, March 6, 2012 1:45 PM
  • Hello Gary, thanks so very much for your consideration.

    Good questions, all. The disk on the client, p6t7 computer is the NTFS boot disk, 249GB in size (123GB free), type "basic", partition style "MBR". Just a plain vanilla volume, same as on the other p6t7 client that backs up just fine.

    I've repeatedly performed chkdsk /f on the partition since this started. Nothing is ever reported. Delving into this more, I set up a second NTFS partition sized at 260MB (essentially free), and also performed chkdisk on that new partition also.

    Selecting either of these partitions for backup gives exactly the same messages on the client's Application and System logs (given above). This occurs 100% of the time, immediately.

    I can find no error within VSS and the service appears to be running quite normally. I've used VSSAdmin to examine the writers and find no errors or anything irregular there. Both of the partitions have ample space for shadow copies.

    I'd really appreciate any advice as I've been grasping at straws. I know something's seriously wrong, but the diagnostic messages (above) just lead me to a dead end.

    I find nothing at all on WSSdrivercapture. Anybody know why this might pop up? The message "Process SharedServiceHost failed at:

    d:\wssg_src\hsbs_colorado\backup\pc\client\drivercapture\lib\drivercapturelib.cpp(268),"

    is referring to a failure on the server's disk, which may be a reference to where the backup is stored. I can't glean anything else from the message.

    The only major difference between these two machines is the use of Norton Internet Security on the failing computer and Norton Antivirus on the one that backups up perfectly. If I disable the NIS firewall, still get the same errors. If leave it off and remove/reinstall the Connector, still get the same messages. That should have allowed the installation to set up Windows Firewall properly, but still the backups fail exactly the same way. That result doesn't seem to implicate NIS, but I suppose my next step is to uninstall NIS it and reinstall the Connector yet again. 

    Any suggestions/advice greatly appreciated!

    Thanks,

    Rich




    • Edited by Rich Irwin Thursday, March 8, 2012 5:38 PM grammar
    Thursday, March 8, 2012 5:26 AM
  • I have a similar problem in my home network Rich...

    I upgraded my Home Server to 2011 a few months back.

    We have 2 Windows 7 ASUS laptops that suddenly stopped working with backups. I can connect to everything fine on the server, but when I get downstairs in the morning the backups failed.

    I'd like to preface this by saying I have 3 OTHER systems backing up just fine, but they are all Windows XP SP3 desktops so I know the server is working, it is just the clients.

    My error message says:"backup did not complete because a problem interrupted the connection to the server", and usually occurs within minutes after I manually initiate the backup. It does it hard-wired to the network or wireless.

    Like you, I've done the check disk and everything appears fine. These ASUS laptops are new and came with Windows 7 Home (64-bit) installed, and I've had the issue since day one when they arrived in the boxes. All Windows and Server updates are done automatically.

    Update: I was reading through some of the stuff on Windows 7 Home and upgraded to Professional...initiated the backup and still the same thing...gets to about 10% complete and fails with same message above. Going to try geoperkins suggestion and see what happens...


    Joe Raymond


    Sunday, March 11, 2012 2:56 PM
  • Have you tried just running a backup initiated from the client? As if it was not in a WHS2011 environment at all? (I have Windows 7 Ultimate and backing up to a network location is an available option; not sure of other editions of Windows however).

    1. Create a share on a different client machine in your network with appropriate permissions.

    2. Control Panel > Backup and Restore > selection options in wizard to use the network location.  Start the backup process on the failing client to that network share.

    See what happens. It might offer a clue as to what is going on...?  When you do figure this out, please post your solution.

    Sunday, March 11, 2012 4:09 PM
  • Hello Joe and Geoperkins,

    I've seen a lot of symptoms and reasons posted about client backup failures, but I've NEVER seen anyone write about a failure from module WSSDrivercapture.dll.

    Joe, your machine's failure seems much different from mine, in that at least yours gets started (10% before failing). Unless your client's Application logs show this crazy error involving drivercapture, the failure is likely for other reasons. For example, make sure VSS is started and working (no VSS errors in Client's system logs), that at least 10% free spaces is available in each partition to be backed up, and that plenty of space is availabe on the volume where the backups will reside. Lots of possibilities without seeing those logs.

    Geoperkins, yes, I can backup the entire computer using a non-WHS 2011 Backup from Control Panel. In fact, I can backup just fine to the WHS server. No problems with that, it's just not the way things should be. I should be able to back up all my W7 computers in automated fashion using WHS 2011.

    Again, the WHS Server's Windows Server log ALWAYS gives the same error:

    Process SharedServiceHost failed at d:\wssg_src\hsbs_colorado\backup\pc\client\drivercapture\lib\drivercapturelib.cpp(268).

    I can't even find a reference to "drivercapture", which seems amazing. I've tried all kinds of things but no help so far...

    Thanks for theour suggestion!

    Rich



    • Edited by Rich Irwin Monday, March 12, 2012 5:17 AM
    Monday, March 12, 2012 2:22 AM
  • Hello Rich! I do also have the problem with my W7 64-bit computer. It won't go further than 1 % and then it fails. I have been i contact with Microsoft support but they said that they could't fix it at the moment. I tried with an laptop with W7 32-bit and it worked. So something is really strange here... Please fix this Microsoft!!

    Friday, June 1, 2012 1:30 PM
  • This issue is so frustrating

    One of the main reasons I have a WHS is for the backup and to have this occur on multiple clients and not backing up my data is sending me crazy

    MS: Please respond to when a fix will be available !!

    Currently my WHS is not 'fit for purpose' and therefore you are not keeping up your end of the contract here :(

    Thursday, June 21, 2012 1:09 PM
  • Hello Angel,

    I'm using WHS 2011 and backup on five other client systems with absoutely no problem. On the whole, this has been a very effective solution for me.

    This particular computer, which has a working twin, has a specific problem for which there has been absoutely no suggestion. The symptom is the backup failure with the error:

    "Faulting module name: WSSDriverCapture.DLL, version: 6.1.8800.16385, time stamp: 0x4d6ed346".

    I can find no information anywhere about WSSDriverCapture.DLL, even. I have to manually backup this particular computer, naturally, that works just fine.

    So, this particular system is a very specific problem for which I have no solution. Probably there's an installed driver on it somewhere that cannot be registerred. I've been through the drivers and can't find the problem. That doesn't mean there isn't one, however. At some point I'll just rebuild Windows. Probably that will fix it.....

    Rich


    Rich

    Thursday, June 21, 2012 2:27 PM
  • I had the same problem with a new Ultrabook.  Backups by WHS consistently failed at 1%.  I spent a day searching everywhere without finding a fix.

    It turns out to be a Micro$oft design feature.  The new Ultrabook uses the -- Micro$oft mandated -- UEFI/GPT technology.  That technology is, however, NOT supported by Windows Home Server 2011.  Therefore, WHS 2011 will not run automated backups of the Ultrabook.  The fix is to upgrade from WHS 2011 to Windows Server Essentials 2012 that does support UEFI/GPT technology.  Unless a WHS 2011 patch appears soon, I can see a Linux Home Server riding to the rescue sometime this Spring.


    • Edited by 1 BigGuy Wednesday, December 26, 2012 8:23 PM
    Wednesday, December 26, 2012 8:22 PM
  • Hello Rich,

    The problem maybe related to one or more drivers in the client machine that have an invalid ClassGUID.

    The function CLSIDFromString is called from the library C:\Program Files\Windows Server\Bin\WSSDriverCapture.dll which is loaded in to memory when the backup of the client computer starts.

    This library has a function that copies (or captures) specific drivers (Network, Disk, Printers,etc) into a folder named something like "Drivers for Client Restore" in the client machine for restoring when necessary.

    For this purpose, the function iterates through the registry to find out the drivers that belongs to specific classes of interest (Disk, iSCSI, Networking, Display, etc)

    Inside the registry, each device is identified by a ClassGUID. If the ClassGUID has bad format, the CLSIDFromString function fails and returns an error and for some bug in the connector, the client backup process is killed and the backup fails.

    Therefore, to fix it,  start by finding any device below the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum branch in the  registry with an invalid ClassGUID (ie: ClassGUID in blank or invalid format) in the key value and reinstall the driver (or uninstall it from the Control Panel if you no longer use it).

    In my case I was able to fix the problem by uninstalling a USB serial port driver that had an invalid ClassGUID (ClassGUID="") and now the client machine backup finishes without problem.

    Hope this helps,

    keywords: error, windows home server, 2011, whs2011, CLSIDFromString, SharedServiceHost.exe, 0x800401f3, Invalid class string


    • Proposed as answer by marcello_wpb Wednesday, June 22, 2016 11:18 PM
    • Edited by marcello_wpb Thursday, June 23, 2016 12:14 AM
    Wednesday, June 22, 2016 11:10 PM
  • Hi Marcello,

    you have just revived an allmost 4 years old thread, therefor I do not think, that the OPs still have the issue or even use WHS.

    In the meantime there have been lots of updates and hotfixes, mainly also the UEFI hotfix for Windows Home Server 2011.

    Best greetings from Germany
    Olaf

    Thursday, July 7, 2016 8:31 AM