Distribution Group Expansion in OCS 2007 RRS feed

  • Question


    Everything about my Communication Server implementation is working perfectly, EXCEPT for distribution group expansion on external clients.  I am getting the following message when I try and expand:


    Cannot connect to the distribution group service because the server name used in the distribution group service address is incorrect.  Contact your system administration with this information.


    I reiterate that everything else works.  I am using TLS and have the reverse proxy setup through a Cisco ASA firewall.  DNS obviously works because the external client can connect and chat without issue.  Please Help!

    Friday, October 19, 2007 9:24 PM

All replies

  • Jeffrey,


    DG expansion happens on your FE (internal) server.  You need to publish this out to the internet (preferably via reverse proxy) for your users to be able to expand the DGs.  You also need this for external address book and web conferencing content downloads for external users.


    Tuesday, October 23, 2007 4:05 AM
  • I believe that I am doing reverse proxy.  I'm translating an external address (that has correct cert DNS) to the internal address of my server.  If reverse proxy wasn't working then I wouldn't be able to get to the server from the outside.  I do not have an ISA server. I have a Cisco ASA firewall that is doing the translation.  I can connect to the ext/service.asmx site from outside my network.  Communicator just will not expand the group.  Any thoughts?

    Tuesday, October 23, 2007 1:29 PM
  • Did you check your Web Components properties to ensure that your external URL is valid?


    Tuesday, October 23, 2007 9:48 PM
  • Yes, as I said before, I can connect to the external url, in my browser, from outside the network, on the computer that is having the issue.  But when I try to drop down the group within communicator, nada.  This is what bothers me the most.

    Wednesday, October 24, 2007 1:04 PM
  • As a next step I would check the IIS logs, event viewer, and enable logging in Communicator to see any of those reveals anything.

    Wednesday, October 24, 2007 2:28 PM
  • The only suspect message that I am receiving is this...


    Event Type: Information
    Event Source: OCS Distribution List Expansion Web Service
    Event Category: (1024)
    Event ID: 62010
    Date:  10/24/2007
    Time:  1:49:03 PM
    User:  N/A

    Partition by OU: False, Output Location: C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Address Book Files\Ext, Redirect: False.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Wednesday, October 24, 2007 7:20 PM
  • We're having the same problem except we aren't using an external address book, we only have internal users. Was anybody able to fix this?




    Friday, May 16, 2008 10:25 PM
  • Go to your web components properties/Group Expansion tab and check the internal URL.  Copy and paste that URL into a browser.  You should get prompted for credentials and then receive the following:


    Live Server Distribution List Expander


    This web service expands Exchange Distribution lists

    The following operations are supported. For a formal definition, please review the Service Description.


    Post back what you receive when you go to that URL and we can work from there.
    Monday, May 19, 2008 3:33 AM
  • I had this problem after I installed the Update Service on a EE front end server. The only way I was able to fix it was like this:

    1. Deactivate Web Conferencing service.
    2. Deactivate Web Components service (make sure you do these first two in this order).
    3. Uninstall Web Conferencing service and reboot.
    4. Uninstall Web Components service.
    5. Reinstall Web Components and reactivicate (using Deployment Wizard).
    6. Reinstall Web Conferencing and reactivicate (using Deployment Wizard).
    That should sort it out.
    Sunday, August 24, 2008 3:35 PM
  • You could also follow this KB article:





    Tuesday, September 23, 2008 12:53 PM