locked
WHS 2011 Connect Install Issue RRS feed

  • Question

  • I get a "Cannot install Connect software because another installation is in progress... I have tried rebooting the client but this does not work.  Any thoughts on how I can get around this - it is occuring on all of the clients I'm trying to set up.
    Thursday, June 30, 2011 3:08 AM

All replies

  • Any application can set a pending reboot flag in the operating system through a registry key. Sometimes a reboot does not clear the flag. This is what setup is detecting.

    To work around the pending reboot issue:
    1. Open Regedit
    2. Find the key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager"
    3. Rename the "PendingFileRenameOperations" value to "PendingFileRenameOperations2"

    Source: http://social.msdn.microsoft.com/forums/en-US/sqlsetupandupgrade/thread/787c7a6b-dff1-4ceb-b5ea-73bc3fb99b3c/

    May Help

    Dave


    The Frog on the Lilypad at Home
    • Proposed as answer by Olaf Engelke Thursday, June 30, 2011 8:42 AM
    Thursday, June 30, 2011 3:43 AM
  • The fix allowed the system to start installing.  It got most of the way through the install however very near the end of the "Connecting to the Server" stage the thermometer started going backwards and the following error appeared: "Windows Home Server has encountered an unexpected error.  Click Close to undo most of the changes.
    Thursday, June 30, 2011 4:51 PM
  • I had that problem after making the Registry change - try a re-boot and install again.

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Thursday, June 30, 2011 5:17 PM
  • Unfortunately this didn't work.  I notice that when I do the Connect install that the Client computer is set up on the Server but is listed as off-line.  If I try and reinstall again, the connector install say that this computer is already set up on the Server.  I have tried to reinstall with it set up on the server and have also removed it from the server and tried to install it.  Neither works.
    Thursday, June 30, 2011 6:05 PM
  • So at some point the connector was installed correctly on the client as you say your client shows on the server but offline? Why did you remove it and did you make any other changes?

     

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Thursday, June 30, 2011 6:14 PM
  • The connector was not installed correctly.  The situation where the connector shows up as installed but off-line occured when I got the "Windows Home Server has encountered an unexpected error."
    Thursday, June 30, 2011 6:51 PM
  • I ran the connector install again to see if any errors were logged by the system.  The following events appeared in the Event Viewer:

    1. Warning: File System Filter 'BackupReader' (Version 6.1, ‎2011‎-‎02‎-‎21T21:59:15.000000000Z) failed to register with Filter Manager. The final status for this operation was 0xc01c0011.
    2. Warning: The driver \Driver\BackupReader failed to load for the device ROOT\BACKUPREADER\INSTANCE.
    3. Error: Product: Windows Home Server 2011 Connector -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action SetupMcConnector, location: C:\Program Files\Windows Server\Bin\esSetup.exe, command: **********

    Hopefully this may help someone diagnose the issue.

    Thursday, June 30, 2011 10:00 PM
  • I tried reinstalling the server which had no problems.  However when I went to install the client the same issues occurred.  I am really stuck!  I'm beginning to wonder if this product is a viable product since the connector issues are all occuring on Windows 7 Home Premium machines from different manufacturers.  It can't be this hard to get up and running!!
    Friday, July 1, 2011 7:13 PM
  • Saw on another forum that having any non-alphabetic characters in the client name could affect the install.  My user names all end in "-PC" so made the change.  No joy!  It looks from the lack of other posts that no one has any idea how to resolve these connector issues.
    Sunday, July 3, 2011 2:42 AM
  • Finally some success.  Not sure which worked.

    1. I removed all references in the registry to Windows Home Server and then rebooted.
    2. Removed client computer from the Dashboard and rebooted.  (This solution had never worked before.)
    3. Turned off Windows Firewall on the client. (This also had not worked before).

    Perhaps a combination of the above was the key.


    Tuesday, July 5, 2011 7:19 PM
  •  

    I have had the same problem. I have had to uninstall any anti virus software. And then remove .NET 4. I had two programs that mentioned .NET 4 to delete.  If your client already has this installed remove it and then reboot. Then try again. WHS will reinstall its version of .NET 4     This worked for me on all 3 of my client machines. You may only need to remove .NET 4 but it doesn’t hurt to temporarily remove AV software.

     

    Will be interesting to hear if this works for you.

     

    PS don’t forget to reinstall your anti virus / software.

     

     

     

     

     

    Tuesday, July 5, 2011 7:30 PM
  • Actually what I did in my previous reply was what worked.  When I connected my second client I only did item 1 (clearing registry on client of any references to Windows Home Server).
    Wednesday, July 6, 2011 5:51 PM
  • I realize that you have already come up with a solution, but I will add info here for others to give it a go when also looking for a solution.  I too had the exact same problem so I tried everything here that was mentioned (clear registry of all traces of WHS 2011, removed .NET 4, removed the client computer from the server dashboard, & rebooted).  That did not work.  Then I read somewhere else where someone advised to clear out all TEMP files.  So I again cleared out the registry (since the millionth install attempt only got so far, with the green install bar getting to about 95% complete before rolling back, & left traces of the failed install in the registry), removed .NET 4, & removed the client computer from the server dashboard.  However, this time, before rebooting, I ran CCleaner to cleanse the system of the junk, so to speak.  I then manually checked around in the program files (C:/program files/ Windows Server) for any trace of the program, manually deleted them, and then emptied the trash bin.  Then I rebooted.

    I again downloaded the Connector software and held my breath as the install bar again got to about 95%, and lo and behold, IT KEPT GOING ALL FINALLY TOOK!!!  This may not work for everyone, but it worked for me.  I hope this helps others.  BTW, I installed the Connector software on two of my desktops (both identical makes & models using Win. 7 Pro) and the other one took to it with no problem.  Also, I did not have to turn off the firewall or anti-virus in my case.

     

    Cheers.

    Friday, July 8, 2011 3:49 PM