locked
E.164 format number calling issue from OC 2007 using phone RRS feed

  • Question

  • Hi 

    I have deployed OCS front end server, OCS mediation Server and OCS proxy server with MCM. My customer is using Nortel CS 1000 PBX. Alll the users are enabled for Enterprise voice with PBX integration. I am stuck with a small issue.

     

    Scenario1:

    When I am making a call from OC 2007 selecting computer, to an ext 111, it normalizes to +97317544111 and call is successfully made to pc as well as phone.

     

    Scenario 2: 

    But when I am making a call from OC 2007 selecting phone to an ext 111, on the communicator it normalizes to +97317544111 and on the phone it displays as 9731754111. After few seconds the phone display as destination busy with busy tone and the call fails. This could be because my PBX doesn't understand E.164 format.

     

    Scenario 3

    While if I make a call directly from the phone to ext 111 the call is successfully made to both phone and PC.

     

    Please advise how can I make a successful call in a second scenario.

     

     

    Thanks in advance. 

     

    Tuesday, November 4, 2008 10:06 AM

All replies

  • Hi,

    Have you looked at this already ?

    http://support.microsoft.com/kb/952785/

    By default, Microsoft Office Communications Server 2007 Mediation Server uses a plus sign (+) to prefix E.164 numbers in the Request Uniform Resource Identifier (URI) for outgoing calls. However, certain private branch exchanges (PBXs) do not comply with Request for Comments (RFC) 3966, “The tel URI for Telephone Numbers” and do not accept numbers that are prefixed with a plus sign (+). Therefore, an outgoing call may not be routed correctly. Additionally, the "From" headers for incoming calls from certain PBXs also do not comply with RFC 3966. In this case, Office Communicator does not resolve the number to the correct user.

    Hope this helps...

    Greetings,
    Tonino Bruno
    Tuesday, November 4, 2008 7:54 PM
  • Hi Tonino

     

    Thanks for your prompt response.

     

    I have tried that article but no luck. 

     

     

    Regards

     

    Nitin
    Wednesday, November 5, 2008 9:28 AM
  • Hi

     

    For RCC you have to normalize you full number to extension with a rule in the normalization file Company_Phone_number_normalization_rules.txt, something like \+97317544(\d{3})$ to $1;phone-context=dialstring

    pb is that RCC rules are downloaded to client registry only when user configured as RCC only. If user is configured as EV+PBX integration, only EV rules are downloaded... so modify your rules file, configure RCC only, check RCC rules are downloaded, and then enalbe EV+PBX integration.

     

    Wednesday, November 5, 2008 10:39 PM
  • Hi,

    I was wondering why you are using an extension in the first place in your tel uri? From your posting on Pro-Exchange I saw that your tel uri was "
    +97317544111;ext=111" which at first sight can be replaced by simply ""+97317544111"? I guess the extension would be required if you have only a single PSTN number (DID) and you have assigned internal extensions to your users (non-DID).

    If you really need to support non DID numbers you may want read this comment from Jens Trier Rasmussen:


    http://blogs.technet.com/jenstr/archive/2008/01/29/how-to-implement-enterprise-voice-in-a-non-did-scenario.aspx

    <Quote>

    When implementing this type of solution you need to make sure that your SIP/PSTN gateway can understand this format. Why? It needs to be able to understand the components of the string and work with them. On outgoing calls from OCS to the PBX they need to be able to extract the extension from the Calling Line Id and present only the extension to the PBX (i.e. strip "tel:+<main number in E.164>;ext="). On  incoming calls to OCS from the PBX they need to generate the format for Calling Line Id and Called Line Id.

    We are looking at alternative solutions for this scenario for future releases of OCS 2007.

    </Quote>

    Sincerely,
    Tonino Bruno
    Wednesday, November 5, 2008 10:51 PM